Whats wrong with Vsync?

It only goes into triple figures briefly on sim start up, sits around 60 fps in main menu for me.

Regularly stays at 100+ fps every time I was at the menu. Vid card is at defaults driver wise.

Do you have VRR turned on in your graphics settings?

What your looking at there is windows own settings for graphics!
Frankly I would suggest that you do away with all that and use the far more comprehensive suite of settings that are available through the GPU’s own software. Eg. NVIDIA Control Panel.

Probably depends on resolution as I use 4k on an RTX2070.
100fps isn’t over the top though but if fps is stupidly high maybe 60fps and vsync is worth using as isn’t much impact to performance.(may not be true if your regularly hitting 60 fps in flight)

I wonder if it’s actually the true fps it’s showing in the menu or on start up. As there was a thing with the in flight menu, that if you moved them to the task bar it would increase the fps reading with every option you moved to the task bar. But it wasn’t the actual true fps.

As has been stated, it seems that most people are achieving better FPS with V-Sync turned off.
You are, though, right with your caution regarding FPS ‘runaway’ when in the menus.
But a better solution is to use your GPU’s software to limit the max number of frames to a more sensible value such as 60 FPS.

1 Like

Isn’t variable refresh rate only available when using certain monitors like G-sync monitors.

It is worth noting that if you rely on windows to make your GPU settings [especially Game Mode] you will find, as have many others, that come the next patch and or windows update, the sim will suddenly start behaving differently!
Better to use only your GPU’s software thus staying in control of your settings.

1 Like

I recommend looking at this post here to explain why I’ve suggested this.

1 Like

This is a good advice indeed in general, but in this case, these Win10 settings DO have a tremendous influence on FS2020, at least, on my test system. It is all documented in “My 4K Setting” post(s), but specifically for these shown here in this discussion:

  • Hardware Accelerated GPU Scheduling (HAGS) alone shouldn’t change much but when combining it with a few other settings it seems to help better.

  • If you do have G-Sync or Freesync (or G-Sync compatible or even not compatible officially yet working - like with my LG27U600), you have to also enable Win10 VRR for UWP/Store apps otherwise it won’t kick-in (NVidia CPL is only for Win32 apps).

see here ( 30 not mean 30fps )

How Vsync-Setting should affect your loading time, I dont know…

On my machine with my refresh rate set to 100Mhz, 60fps frame limiter in FlightSimulator is 100% of my refresh rate. 30fps is 50% of my refresh rate. 20fps is 33% of my refresh rate.

might be because you own a GSync(VRR) monitor that the limiter works in your case seemingly correct…

60 max | 30 step 1 | 20 step 2 | step 3
100 10.0 | 50 20.0 | 33 30.0 | 25 40.0

( and check it in-flight , in main menue it works fine always )

Are you sure that your monitor can display 100 MHz? (= 100.000.000 Hz)
It is still too early for this technique. :wink:

Hi Skipper,

Very interesting remarks.
And if true [please take that in the right spirit], a useful bit of info.
I shall have to do some research and a little experimenting of my own.

Thanks for this.
Regards.

As far as I know the Variable refresh rate option in the Windows Settings App only applies to Windows Store applications, since they are a special type of application. I’m not sure if this applys to MSFS if you bought it though the windows store as opposed to Steam.

Nothing wrong with enabling that setting but should also enable G-Sync/Freesync though your video card cpl , and keep in mind that the game runs in Fullscreen borderless mode unless you have HDR turned on so you’ll need to make sure you’ve changed the setting to account for that.

Curioser and curioser!
More research for me!

Don’t tell me you’re still using that old equipment. :stuck_out_tongue_winking_eye:

1 Like

Yes, thank you. I have all of this set and I am running the Windows Store version. I was trying to help others on this topic.

Everyone in this thread who hasn’t seen this post check it out. Graphics setting with excellent results in 2560x1440
Limiting FPS in nvidia control panel does wonders for stutters and other issues. This sim runs perfectly fine at 30-35 fps no need for more. Limit the fps and give your gpu some overhead to do other things.