Why is it almost impossible to land the DC-3 addon?

Addon download link-Douglas DC3 (FSX) Original Cockpit/Panel » Microsoft Flight Simulator

This is the fsx converted DC-3 and is one of the few addons that keeps the original cockpit. It’s a really good addon but I simply cannot land, anywhere I try! I tried landing in St Maarten with a speed of like 97-100 knots on final to the runway. I then did the flare but then the plane bounced and it kept going like that for some time until I finally got it to stay down. But then, the nose just suddenly tips forward and goes right to the ground, with the empennage section sticking in the air! It looks kind of like this.
mylandingsineverytaildragger

Does anyone else with this addon have this issue? After seeing some documentaries, I really wanted to download this DC-3. I had no other issues with it, but it seems to never want to land! I don’t think it could have been the wind, as I don’t think it could have been enough to tip the plane over. (At least I didn’t set it to be like that.)

Moved to #third-party-addon-discussion:aircraft as this is a conversion.

1 Like

A lot of times these FSX ports work using the legacy flight model vs the modern flight model. Check the the associated material and make the change in your settings if necessary.

I think if you’re flying a converted FSX aircraft. You need to change your flight model to use Legacy.

One Thing I know for sure, it’s not a DC-3 in the picture

4 Likes

I know it is not a DC-3, I was just showing what my landings look like every time I try it.

From the download page:

Note: This conversion is NOT realistic of the actual DC3

If you download a beta version of a free conversion of an FSX aircraft that says it may not work properly, it may very well not work properly…

2 Likes

Hi, I tried this out, and it seemed to help a little bit. It bounced fewer times but it also still just goes down to the ground like in the picture in the original post. Thanks for the help though