Why is the cockpit so blurry in VR

Hi Ash,

Thanks for your reply. Here are my settings, which one would you think could be wrong? As far as I can tell, I have set everything to max.




Can’t really see anything wrong, can you turn up “display resolution” any higher than “best quality”. I run my Oculus Q2 a little higher than that and can get sharp cockpit views even with glass displays. Also, is the cockpit sharp and detailed if you lean in a look at gauges etc up close?

I have a rift so I only know how to increase it within oculus, the pixel override change to 1.6 or 1.8, you need to find the right trade off with performance so I leave mine at 1.4. Still not ‘sharp’ though. I’ve been through every setting for months in nvidia, oculus, windows and msfs and there’s no easy way

Is the sim running smooth with those settings to the max?

To me this looks totaly ok. Please have attention to the position of the headset, a few mm up or down can make big difference.

I have to pull it backwards a little for best view but with your settings my cockpits are beautiful sharp and I can read almost everything without leaning forward or right mouse button.

As a 3090 and G2 user I find even at 100% in game & 100% openXR it looks a little bit blurry in VR due, I suspect, to the TAA… games that use MSAA like DCS tend to look a bit sharper by comparison.

If you supersample above 100% it starts to look much more crisp, but for me at least performance doesn’t really allow running beyond 100% for anything other than a quick test.

Also worth noting that motion smoothing/reprojection made it notably more blurry and soft, if you are using motion smoothing then try with it turned off - you will notice the low frame rate more (especially close to the ground) but will get a clearer image.

Edit - I see from your settings grab that motion reprojection is off already so disregard that last part.

Raising the OXR render scale increases the cockpit clarity for me a lot, but it comes at a cost in smoothness/frame rate. With your current settings you might have some headroom to increase a bit and still keep it smooth. Otherwise you’ll have to decide how important the cockpit clarity is vs. other aspects of the sym.

My understanding is that if you don’t specify a render scale in OXR, Windows will automatically change the render scale (lower it below 100%) for performance. If you want OXR 100 you need to set it to 100 (not leave the ”Custom Render Scale” unchecked).

Smooth enough for me. It is a bit stuttery on the ground parked at the gate, but once in the air it is smooth. But I’m quite a bit more tolerant with regards to fps than most people, 30 fps is enough for me (I know many people disagree with that…)

It’s not the position of the headset, since it is totally crisp in DCS (with same headset and everything…)

Thanks guys, I’ll play around with the various suggestions…

I have always felt that msfs at native resolution and 100 render scale does not look like other vr games at native resolution, this is on a quest 2. I haven’t found the reason why this is but my best guess it is to do with the taa and sharpening filters. If you turn off AA entirely you do get a sharper view but at the cost of horrific shimmering which is even worse!

1 Like

Before I suggest this I want to admit it’s a crazy thought and I can’t replicate it… but your VR settings look great and you should be getting really good clarity… but you’re not… so maybe you should give this a try. Somebody posted this a couple weeks ago. The claim is that the 2D PC settings have an impact on the VR clarity. He states it’s a bug and he submitted the bug to Asobo. I played with the idea and did see an impact but I can’t pin down exactly what happened. It took some fiddling but I finally got my clarity back.

In the PC section of the general settings (not the VR section) set the global redering quality to low. Save the settings and then restart the game. Go back and change the global redering quality to ultra, save the settings and restart the game. Now try VR. See if it clears up the cockpit.

And if you try this let me know if it had any effect. Good luck.

Now that I remember I asked a somewhat similar question as the below topic, it was not conclusive but as always there was some interesting technical information provided by Captain lucky

1 Like

Tried it, didn’t help for me. I also previously tried other tricks that appeared on the forum, like upping the render scale in 2D which some people found increases sharpness in VR. But that also never worked for me for some reason… But definitely worth a try.

Glad you tried it but I was thinking about it more. I think the trick was that after going to “ultra” settings, then you must start your flight in 2D mode and after takeoff switch over to VR. It might be worth another try with that.

Good luck.

What about your eyesight?
Check with an optician it it is 20/20 @ 4m distance.
If it’s not, use prescription lenses…

1 Like

Yes, I wear lenses in VR. That is not the problem, since the same eyes look into the goggles when playing DCS. As I said in my OP, DCS is super sharp, MSFS is not at all. Same eyes, goggles, graphics card, etc…

2 Likes

Set custom render scale in OpenXR Developer Tools. Experiment with the compromise between the performance and flight sim settings (Ultra gives a hit). When setting the render scale in OpenXR Dev. Tools to manual you will have the full control over the resoultion. If you set it to auto you are at the mercy of some programmed logic (probably based on the amount of the VRAM in your graphics card).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.