Why is the update process so convoluted?

This is REALLY getting old.

Had to go to my game room to find something so I decided to boot my gaming rig and get the base update. Nothing showed in the XBox App, nothing showed in the Store. Waited five minutes, nothing. Quit and restarted the XBox and Store apps, no change. Signed out of the XBox app, quit, restarted it and signed back in. Then th XBox App decided on its own to queue up THE ENTIRE 123GB SIM, without apparently noticing it is already installed, nor prompting me for an install location. I rapidly killed that before it demolished my installation, quit the XBox App and started up the sim.

It started up, went through the Checking for Updates stage AND DID NOT FIND THE UPDATE, and eventually loaded up as normal. I went to Content Manager and it DID find, download and install the update for the Junkers, and it did let me “purchase” WUVIII but told me I needed an updated version of the sim to download it.

Quit the sim, reopened the XBox and Store apps to check for updates - still nothing.

It’s been 19 months since this sim launched - there has GOT to be a better way.

Are you being serious? Or just being funny?

Honest question? Updating on PC is literally the most simple and fastest thing I’ve experienced all week.

1 Like

This has been discussed, literally, 45,450,545 times. The game’s update isn’t the problem. You always should be looking where it will install. If it points to your C:\ drive and YOU have the game installed on a different drive, it’s your/our responsibility to ensure you have the correct path.

1 Like

It appears as if you haven’t ever purchased or played a game that installed through the Microsoft Store on PC… they all update the same. Perhaps it is your way that makes updating a pain in the ■■■■, as opposed to Microsoft’s way of handling games via the MS Store. Which in my experience has always be pretty seamless as long as you’re logged in.

What exactly tells you to “download store”.

Are you even on a PC that is running Windows 10?

Not even a sign of MSFS there? Like how did you even purchase MSFS?

You do not see the Microsoft Store app installed on your PC? Did you or someone else by chance remove it, perceiving it as some form bloat or something?

According to you and all you have written it appears like you don’t even have the game! Like, you can’t even log into MS store… How did you purchase the game in the first place?

On the bottom left-hand corner there is a place to click called Library. You click it and then at the upper right-hand side you click check for updates. But I’m assuming based off of what you yourself right, you’re not even signed into your Microsoft account inside the Microsoft Store Application. This would explain why it’s not automatically prompting you or finding the update.

You’re either some Troll Boss (think your some troll boss) or someone of whom is really needing some guidance in how to use their PC and the software that is on it.

Um, no. You missed the part where I mentioned that it was the XBox App that had queued up the entire base sim update. This did NOT occur INSIDE the sim itself.

I’ve been running this sim since Day 1 - I know how this is supposed to work.

Then I’m still not understanding your issue.

I literally opened MSFS, it took me directly to Windows Store and downloaded the update. Re-started MSFS and voila. (I’m on Windows 11, have the Windows Store edition)

You guys ■■■■■ because they don’t have an exact 1:1 recreation of the entire planet down to every tree, along with a perfect match of current real weather, exact real world physics to recreate flight, the exact feel of flight with a toy joystick while sitting in a desk chair, inject every real world flight yet have perfect ATC for your simulated airplane in the middle of them, all for a bargain price… but can’t be bothered yourself to make more than two-clicks with a finger while they actually make an attempt to do all that.

I can just imagine if you guys were around at the dawn of flight you’d complain it’s not really flying, it’s gliding, it’s too slow, too low, and on and on.


Had similar issues this morning but it required a windows reboot to get the XBox App to see the update.
I’m very used to these installs now, but I don’t think I’ll ever understand why the 1st part is required, there must be some techincal reason though. In my mind we should just have to launch the game and if there’s an update to the base game install it then. The optional WU and othe WU updates I can understand. It’s the two stage update process for the base game I can’t get my head around.

If you had read my narrative, you will have noticed that the update did not show in either the XBox App nor the MS Store, and that I signed out and back into the XBox App and then the XBox App tried to reload the entire sim from scratch. I then canceled that, loaded up the sim, AND THE SIM PASSED RIGH THROUGH THE “CHECKING FOR UPDATES” part and did not prompt me for the update, which is still not showing in the Store or XBox Apps.

That is the problem.

The Asobo Nerf Hammer strikes again!

The problem here is that no one (well, maybe MSAsobo) knows how many people experience problems. I have Steam, and my experience has historically been easy. I open MSFS, I’m prompted by the Installation Manager for the update, it downloads and installs, and all is well. I check the Marketplace for any other packages, and either get them or move on.

With EVERY SINGLE UPDATE there are people that have multitudes of problems. If that were the norm, you’d think we’d see thousands of forum entries here with every update, since this is the OFFICIAL site for MSFS and there have been, what, two million copies purchased? Do the math.

What I’m trying to say is that if the actual number of users who have problems is very low, you’re just going to have to make it work because assuming the process works for the vast majority of users, good luck getting MSAsobo to invest in a new download system.

And if I was as peeved as some of the people in this thread, I’d be counting the days until that “other FS” comes online so I could ditch this one.

Now I understand. My “guess” is the update hasn’t reached your server yet, which has happened to me before, too. And you’re right, it SHOULD have since it was launched hours ago.

There is definitely room to improve the experience, and very likely some bugs at play.

Here is how my experience went. I first opened windows store and it found an update for MSFS and downloaded and applied it.

But when I launched the sim, there was nothing done at the “Looking for Updates” step.

I figured since it is a world update, and not a sim update, that it would just be a matter of going into the marketplace, then click “World”, and then you see the Spain update. Click on it to “buy” it, and now you own it. Cool!

That isn’t a terrible experience, thought it could be streamlined a bit.

Problem is, though, the sim won’t install the new world content and it says “newer version is required to install”.

Hmmm… scratching head…

So I exit the sim, relaunch windows store, and the update that was applied earlier is not in the log of updates done recently. Yet I saw it with my 0own eyes.

Clicking “Get Updates” it doesn’t find any.

Relaunched the sim, still can’t install the spain content because “newer version is required”.

So yeah, I’d call this a bit of a problem.

And while I am up on the soap box, I have to say, people really should think before they reply and consider the possibility that just because everything worked for them, if doesn’t mean it works for everyone – and it certainly doesn’t mean people who are having a bad experience are doing anything wrong.


Are you completely stupid? What’s more straightforward is, when you launch it, it installs the update. Not make us go here n there. Have you ever used other programs/applifcations?! They ALL are simple; you have an update, then choose to install it, not the BS that MS/Asobo makes you go through.
And what YOU are saying, is wrong, as there are several steps (hoops!) to go through, NOT just click on it/install it or not; it’s a MANDATORY (shouting btw) ‘update’; THEN you have to go back into the sim, THEN go to the marketplace, then look for it, THEN install it - it’s a complete PitA. As are all the joke ‘updates and bug fixes’ - which Don’t.

1 Like

So an update to the above. Went back upstairs to my PC, which has been sitting with the XBox App opened while I went back to work.

Now I see this, with no idea how long it’s been sitting here, how long it will take, and essentially no network activity going on.

Please for love anything anyone holds sacred, someone please tell Jorg to fix this busted process.


That finally errored out. Restarted my PC and I get this. Doubleyou. Tee. Eff.

It is broken………
It downloaded from Microsoft Store.
I can see the update but it won’t update because it tells me my version is to old?
2 years and still the same problem.
Only solution uninstall and download everything again. I am sick of this process.

I have never once had any complications when updating. I simply start the game as normal, and it tells me there’s an update, and I click the Update button and it updates. Simple as that.

I got the game on gamepass originally, and then bought the game via microsoft. I’ve installed every single update, including every World Update and Sim Update without any issues at all.

What’s my secret? Well I do something which I’m betting most of you guys don’t do. I always have the Xbox app running before attempting to start the game. The Xbox app automatically does all the MS store update stuff. I’ve never had to go to the MS store for an update even once. The app does that all without even asking.

Now some may complain that this is an unnecessary step that is not necessary for other games but think of it like this.

Steam, Blizzard, Ubisoft, Bethesda, GOG, Epic Games all require launchers to be active prior to starting their games. The Xbox app is Microsoft’s launcher. Most games require a launcher of some kind to be active before starting the game which deals with streamlining the update process and FS2020 is no different.

So if you want hassle free updating of Flight Simulator in future I’d suggest firing up the Xbox app prior to starting the game and the update process should be as seamless and easy as it is with most other games. Just give the app time to update whatever it needs to first and you’ll be good to go.

It’s always worked fine for me - but I also purchased the game through Steam, and have it installed on a different drive and it’s easy to find. Only complaint - todays update is downloading really slowly! It’s usually pretty quick for me. Maybe I picked a bad time…

1 Like

Boy, are you angry. I’d hate to see you when something serious happens.

So how useful is this? (ANSWER: It’s not, because this error is not contained anywhere in the linked MS knowledgebase page).

Four computer restarts and three times loading up the sim and it refuses to update. The sim itself goes right past the “Checking for updates” without ever finding the update. The XBox app refuses to install the update it actually finds … For fans of classic absurdist comedy, I’d rather re-read James Heller’s CATCH-22 than keep beating my head against this wall of cryptic error codes and inexplicable failures.