Wildly inconsistent Q2 + Virtual Desktop VR performance over Wifi 6

I have a Ryzen 7 5800x + rtx3080 w/ 32GB RAM. I’m on wifi 6 on fiber. Latest nvidia drivers, etc. Playing on a Quest 2 over Virtual Desktop (so via SteamVR’s openXR implementation).

I’ve observed that many times I’ll have mostly unplayable, choppy <10FPS performance when I launch the game w/ 100 render scaling. 80 gets me playable and removes the vomit inducing rubberbanding.

However, there are rare instances where the stars align, and my game runs smooth as glass at 30FPS. I’ll be able to crank almost everything to ultra and have it at 100 render scaling. Then I’ll play with those same settings later in the day and I can’t even take off because it is rubber banding so bad and I have to crank quality down.

Wifi Analysis
Virtual Desktop seems like it is streaming at 70-80Mbps many times. Sometimes it goes over to 120. I’m on HEVC with buffering enabled.

My wifi 6 modem/router combo has its 5ghz radio dedicated to my headset and I have a separate wifi 5 AP plugged in to service the rest of the devices in the house. I set this manually to a high channel since I can’t control my router’s AP channel. Then I’ll find the best channel and usually it doesn’t overlap, although oddly this modem/router has a 2nd 5ghz radio broadcasting in a high band channel but the bulk of it seems to be in the low band where there is some overlap w/ a neighbor across the street (who is at -90dBm). My signal strength seems to be at -33dBm on the low band 5ghz channel and -35dBm on the high band. I have no idea what that high band is doing other than possibly AT&T reserving it for future mesh backhaul support.

I’m struggling to even diagnose the situation to determine whether this is a wireless congestion issue, a ■■■■ modem/router (arris bgw320), or something with the game or my system. But it seems really weird that it would fluctuate so wildly from borderline playable at 80-90 render scaling to running like glass with everything cranked up. It seems completely random.

Any guidance on what might be wrong, or even how to narrow down where the issue is coming from?

Hey
I just fly Virtual Desktop and that has been the best for me sofar. Have you tried that one already?

Are you sitting right next to your router? Line of sight is recommended, although I have been able to get away with playing some Half Life Alyx in the next room.

I was initially having similar issues - it would seem to work well, low latency high bandwidth etc, but would randomly hiccup. I finally caved in and bought a new router (recommended by VD developer about £40) and had no issues since. Have you tried swapping your 2 routers to see if the other one is any better?

Also you could try the official air link which is free, to rule out any issue with VD itself

Not to be rude, but…did you read my post title and the body of the post? I call out multiple times I’m using Virtual Desktop.

The secondary ap that the rest of the house is on is ~2’ in front of me on my desk. The modem/router the Quest 2 is connected to is also ~2’ but next to my left foot on the floor. It generally has a direct LoS to the headset although the desk top occasionally covers it if I lean forward.

I’m struggling to explain this, but it isn’t just a random few second blip of hiccups. It is the difference between my entire session running at 30fps, smooth as glass on high/ultra settings and 100 render scale vs. the exact same settings getting me 10-20fps or sometimes unplayably lower no matter what I do. It’s like the weather changed or something.

I’ve been considering this at the least because I can’t manually configure 5ghz channels on this modem/router because AT&T suck. I’ve been considering a DFS capable router as well since that seems wide open. Which wifi 6 router did the VD developer recommend? Also, I’m not sure i need an actual router so much as a good access point. The modem serves as a router and I can plug into that.

You know, I used to be on my wifi 5 AmplifiHD before I switched to fiber, and had similar issues (although nowhere good as performance when it “behaved well”). It’s a giant headache to switch everything again since the rest of the devices in the home are on it at present, so I’ll likely get a new wifi 6 AP for the Q2 (AmplifiHD is just wifi 5) and see if that solves it and if not, return it.

I’d tried it before but the shimmering and quality were worse than VD. Might be time to give it another go–I also have an aftermarket link cable I coudl try, but I had even worse luck with that historically. Generally I hate the Oculus software compared to VD overall, but I guess I shoudl rule things out.

What’s the process these days to switch between them? I recall having to edit a registry key because of needing to switch openXR runtimes.

Oh so sorry I dont know where I was with my head​:thinking: To many drinks last night :joy:
Still its weird with youre system it should run perfect. I run with an i8700 and an Rtx2060 no issues.

Have you tried to change some of the the settings in the virtual link settings on youre glasses?
I had to put them on medium and 72hrz for good result. Maybe something you can change there?

I can see that I am connected at 866Mb at the router. Whats youre connection speed?
Sometimes my Quest for no reason took the 2,4 ghz network so switched that off.

Indeed that does sound different to my issue which was resolved with the new router. Could it be to do with the “automatically adjust bitrate” feature? I always set this disabled in the VD desktop streamer app, but maybe if it is enabled it could be the hidden variable that is affecting your sessions? Otherwise I would definitely be tempted to try Air Link as that should confirm whether it is an issue with VD or whether it is something else. I also prefer VD due to gamma adjustment but the sharpness is now quite similar since Link V33 got a sharpen mode, and anyway the idea would be to temporarily try AirLink to try to isolate the problem.

You can now use the Oculus desktop app and go to settings/beta/set Oculus runtime. However sometimes that doesn’t work for me and you will need to do the manual registry edit:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenXR\1
Set active runtime to:
C:\Program Files\Oculus\Support\oculus-runtime\oculus_openxr_64.json

Router list is below (I got this off the virtual desktop discord which is a good place to ask questions)

Recommended Routers
The routers following routers have been reported to work reliably from a number of users.
- Asus RT-AX86U (300 US$): “https://www.amazon.com/ASUS-RT-AX86U-802-11ax-Lifetime-Internet/dp/B08BJHS3X7
- Asus RT-AX55 (145 US$): “https://www.amazon.com/ASUS-AX1800-WiFi-Router-RT-AX55/dp/B08J6CFM39
- TP-Link Archer C6 or A6 (40 US$): “https://www.amazon.com/TP-Link-AC1200-Smart-WiFi-Router/dp/B07N1L5HX1
(We don’t recommend TP-Link AX routers as they have lots of issues)

I’ve had auto bitrate on, but I can try it. Not quite sure what it’s relationship to performance is. I always assumed leaving it on would reduce quality to avoid stutter, no?

Will give the airlink approach a go this week. Although I have an Asus RT-AX86U arriving tomorrow, so that could be the ticket as well.