Won't reinstall after not using for a couple of months - Game Services issue

I tried playing MS2020 on my Win 10 PC (up to date) after a couple of months away from playing but it failed to even start up.
I uninstalled but now it won’t get past me choosing the drive location to reinstall it. After a while of doing nothing the Install button becomes highlighted again.

I tried via the Xbox PC app but it says I need to download Game Services but that’s been done. It continues to report the same thing.

I’ve also done the Powershell removal of Game Services but no change.

Is there a list of repair steps for this problem ?

Thank you


Your topic has been moved into the General Discussion & Community Support category.

The Bug Reporting category is for posting suspected or confirmed bugs that other users are able to reproduce without duplicating an existing bug topic. Using the template is required in order to provide valuable information, feedback, and replication steps to our test team.

If you are not sure if your issue is a bug or need further input from the community, please use the General Discussion & Community Support category. If the community can replicate your issue, first search the Bug Reporting category to see if there’s an existing topic. If it already exists, contribute to that report. Duplicate bug reports will be closed.

If you believe it is a new report, then create a new bug topic using the provided topic template.

NOTE: All issues caused by or involving third-party addons/mods should be reported to the third-party developer. Assure that no addons/mods are used when reporting issues in Bug Reports.