Working fine up to and after SU5. Now crashes every time after loading a flight-unplayable

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.


Are you using Developer Mode or made changes in it?


Brief description of the issue:

I flew for many hours, no issues, logged back into the sim (same day) and now it crashes at the three quarter flight loading screen. It appears to be right before it goes in game. I have tried many airports, drop in flights, activities, etc. I have tried all graphics settings and fixes I can find throughout the forums.

Provide Screenshot(s)/video(s) of the issue encountered:

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x00000000
Faulting module name: FlightSimulator.exe, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x0000000001a123c7
Faulting process id: 0x3a34
Faulting application start time: 0x01d78ac5cd187f5d
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.14.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.14.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report Id: fbee770c-ed00-4489-8b72-18a3aef14068
Faulting package full name: Microsoft.FlightSimulator_1.18.14.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App
Detail steps to reproduce the issue encountered:

PC specs for those who want to assist (if not entered in your profile)

Windows 10
i7-9700K (not OC)
Build Version # when you first started experiencing this issue: (SU5)

Are you on the Steam or Microsoft Store version?

Microsoft Store

Anyone getting the same error and any luck with a possible cause/solution.


There’s alot of post about this. There’s a hotfix #2 coming next week hopefully it fixes the problems people are having.

1 Like

I had the same issue, removing the free Garmin 1000 fixed it for me.


hmm… we can not help much more. You just follow already the relevant topic.

Please use the existing thread for this issue:

I hope it gets resolved soon.