Working Title CJ4 Discussion Thread

It is fixed with the fix for now.

Permanent fix with SU 10.

Not complaining here, just looking for a sanity check

Just would like to hear if anyone has the CJ4 working well enough to:

  • use VR, with Honeycomb Alpha, Bravo and the Logitech radio stack

  • combine with P2ATC and Navigraph (works for me)

------ For me this a toy for VFR flights and not quite a sim; can’t get past this-------

  1. MSFS Reported bug: The ALTITUDE x1000/x100 workarounds with the mouse or Bravo knobs don’t work
  2. Reported bug: The heading knob stuck at inc/dec of 10 degrees (no workaround identified)
  3. Not reported: The Logitech radio for COM 1 works, but NAV 1 is overridden by the CDU tuned freq.
  4. Autopilot heading hold not consistent and other A/P anomalies

----SOLVED----
Many thanks to Henrik for the guidance.

  1. Solved with SPAD.NeXt and MSFS license
  2. Find youtube channel with Les O’Reilly
  3. Find his video, keywords: WT CJ4 Honeycomb where he identifies the settings for the Honeycomb Bravo and how to install his code.
  4. Plug in your hardware and run SPAD.Next. Load his Online snippets.
  5. Go back into MSFS controls and unset the knobs/buttons/switches that may conflict with your SPAD.NeXt events.
  6. nice, thanks so much!!

Yes. HC Alpha and Bravo; Reverb G2 VR; Logitech radio panel. It all works, as does Navigraph. I don’t have P2ATC.

I fly it with the Honeycomb controllers. It works beautifully, but I do run them via SPAD.neXt. Many things on the Bravo won’t work well through the MSFS native bindings.

1 Like

I don’t know where you read that, because it can actually solve the acceleration issue with heading and altitude.

Les O’Reilly has a YouTube video where he explains how he solved 100 vs 1000 feet altitude by using 100 feet increments below 18000 feet and 1000 above.

I chose to make a shift-key on the Alpha so that I can make things move faster by pressing it while rotating the knob.

This thread is not about SPAD.neXt, and I’m not at my home computer right now, but once you get the hang of how to use SPAD.neXt with conditions, it shouldn’t be too difficult to figure out how to do it.

Henrik, thank you, …solved… I updated my original post. -whew-

I was piloting a flight in a CJ4 in daylight hours and benign sunny weather conditions. Everything was working perfectly and I was in a stable configuration approaching the runway. I disabled the autopilot a mile or so out. My airspeed was 120kts with full flaps. As I crossed the runway threshold the plane suddenly accelerated strongly and began to climb and my attempt to land was in vain and there was a nasty crash.

My only input on approach was minor adjustments to heading to land centrally on the runway. I never touched the throttles or engaged the autopilot.

It so happened that I was recording the landing with Sky Dolly and on replay it confirmed that the throttles and the N! readings never moved.

You could argue that I should have attempted a go-around but that’s not the point. The big question is, “Why did it suddenly develop a mind of its own?” A job for “Air Crash Investigations” I think.

Has anyone else experienced a problem like this?

P.S. Please don’t direct me to Discord. It’s the most confusing and complicated website I’ve ever seen. No way to create a topic like this one.

DISCORD is a chat really :slight_smile: you just check the channel on the left (for example if there is one called SUPPORT) and you type in there like you were chatting in a Whatsapp Group :slight_smile:

Now back on topic, could it be some sort of glitch with any other addons you have installed? What controller do you use?

Unlike real air crash investigations, a flight sim is just a computer. Therefore there are no environmental or mechanical failure paths. Everything is simulated. Therefore the behavior you observed is and must only be the result of what was “asked for”. Garbage in, garbage out so to speak.

A flight simulator just takes the input the user gives and converts it to output. I’m not saying you did anything wrong. Just that you have to consider that the simulator is not an AI and can’t “go rogue”. It can’t think. It just does what it’s told. If it did something weird during landing that’s because it was somehow told to do it. Begin your investigation with that understanding.

I am surprised because the WT CJ4 is probably one of the most stable aircraft in my fleet.

Surely you can recreate your flight? (not replay the captured video)

  1. Check your assists and co-pilot settings. They can do some amazingly weird things during flights.
  2. Don’t use the ESC pause menu during flight. I find that when resuming flight, trim is set to 100% and the aircraft starts climbing uncontrollably until stalling and crashing.

I believe it was clearly a humourous comment, I doubt anyone would expect Air Crash Investigation to investigate a flight sim crash.

But you can’t say a simulator is without errors and faults, as we’ve seen in a lot of cases, bugs in software can occur unexpectedly and be triggered by the most bizarre and unexpected things, even after much testing. There’s literally hundreds of threads for bugs/unexpected behaviour.

My last 150 or so hours have all been in the WT CJ4 without a hiccup, so I am leaning towards pilot error. Is it possible you hit the TO/GA button (if you’re using a honeycomb on the side of the throttle) which initiated the go-around?

Maybe the next thing to get modeled is the “black box”. :slight_smile:

I have to cut the throttle all he way off when entering the Approach.

No flare at all.

Throttle to 0 when landing.
Speed below 136 & above 100.

I have re-visited this problem and I have found that on arrival at the runway threshold under VNAV the aircraft begins a missed approach procedure. I then deleted the missed approach entry in the MCDU Legs and the CJ4 landed properly.

What do you mean “begins a missed approach procedure”? You have autopilot turned off during landing don’t you? You know the CJ4 does not have auto land right?

1 Like

Can someone tell me how to get rid of this on my display?
The pointer that is saying 1.11NM.
Sometimes it gets on the PFD where I need to see the PFD and not it.

Thanks…

I think those are POI indicators. You can turn them off in the Assistance menu(??)

Note - this is a screenshot from Working Title’s Discord. Use the same link referenced below for the update.

https://www.workingtitle.aero/packages/cj4/2022/09/21/cj4-release-v0.12.14.html

Just installed the latest sim update and the newest WT cj4 update (12.14) and I’m getting the same result as FlightSimmer676 above. Both screens scrambled.

Can anyone help - btw, I’m no expert.

Many thanks.