Working Title G1000 NXi Discussion Thread

There is a known bug when moving through the FMS pages quickly…It will crash the sim from requesting the pages too quick…

4 Likes

Hi, i have two questions about the Working Title G1000 on the Cessna 172.

1st
Sometime i see this in the Autopilot display: GPS ROL ("GPS is in white, “ROL” in green.
The airplane Autopilot then never fallows the GPS and i cant get him to follow it. I noticed that when the GPS works the “GPS” text is in green. So whats the problem here? The CDI is on GPS, i have a waypoint, AP is on and NAV Mode is on. I tried disabling the AP and enabling it again, tried turning NAV mode on/off…it does not work. But activating Heading Mode always works and the aircraft will follow the selected Heading.

2nd
How do i get rid of the two magenta tapered lines showing my flight attitude ? Sometimes after disabling the AP they seem to get stuck in a strange angle and they are distracting. While playing around i once managed to disable them but i dont know how i did that.

Thanks

  1. You need to be close to your path for GPS to switch from armed (white) to green (active). So fly towards your track and it will activate.

  2. Turn off FD (flight director)

3 Likes

G1000 NXi Flight Plans programming from scratch / MSFS Tutorial

4 Likes

I think that is bugged. I have seen it turn off, either in previous releases or certain situations, but 99% of the time once it’s on you can’t turn it off again. Even though the FD button itself turns on, and off.

2 Likes

After having engaged the AutoPilot once, the FD cannot be turned off, even if the autopilot is disengaged. I believe this to be a bug in the NXi.

1 Like

I think this is a bug - I’ve had the same issue recently.

2nd
How do i get rid of the two magenta tapered lines showing my flight attitude ? Sometimes after disabling the AP they seem to get stuck in a strange angle and they are distracting. While playing around i once managed to disable them but i dont know how i did that.

Nope, @BigCow74 already answered to this

  1. .../...
    
  2. Turn off FD (flight director)

Maybe it’s a bug :grin:

1 Like

Glad I found this answer. I use a hardware rotary for the FMS knob and sometimes experience CTD’s when interacting with the knob. Must be this bug then.
In Spad.next I can add a pause between each rotary click, would that help to prevent this behavior?

2 Likes

No it’s not the rate at which the commands are sent in but how fast the NXi is then processing things … you can also make this happen just using the mouse in the VC … Matt has already stated that it is a bug over in the discord “NXi issues” channel which is where they asked that all reports and issues be filed with them…

1 Like

Is there a way to save flight plans? And load them?

Thanks

It looks like it can’t be accomplish for the moment. A solution would be to save in the NXi folder itself due to sandbox issue in MSFS, though this would be an issue by itself on each NXi update
I was requesting for same feature previously

1 Like

Every flight I do the sim CTD’s as soon as I am given my approach by ATC and I start dialling it in :frowning:

Add to that the loss of ATC audio on handover to the Approach frequency and things are pretty irritating at the moment, and we are well past anything from Asobo that could be called a “hotfix” at this stage, with no indication that anything will happen before the next sim upsetdate :frowning:

With the NXi you have to be close to the magenta line for GPS to capture the flight path. I use HDG mode to intercept it. IIRC from previous discussion this is how the IRL unit works.

I think if you are in HDG or GPS mode and you simply turn off the AP master. The AP disconnects but since the AP is in a mode that wants to go back to a certain heading / bearing the flight director will show the direction the plane needs to go.

Try turning off any AP modes like HDG, GPS, VS, IAS, etc and get it to the ROL PIT mode. Then turn off the AP master.

When my TBM is in AP altitude hold mode, I adjust AP select knob to new desired altitude. However the aircraft Altitude changes immediately before i have chance to push VS button and set the desired vertical speed.This is the case using aircraft cockpit
dials OR using a honeycomb bravo. Can anyone advise how to rectify? Cant see any duplucate control bindings.

The TBM is the G3000, not the G1000 NXi, so you might have the wrong thread for help on that.

NEXRAD does not seem to be working in the G1000. The option is selected in the MFD but it does not display any weather. Any ideas?

Apologies.Will ask on another thread.

NEXRAD only shows actual precipitation. It may be cloudy around you for miles, but if none of that is precip, NEXRAD shows clear.

1 Like