World map zoom in hangs/crashes the game

Are you on Steam or Microsoft Store version?

Are you using Developer Mode or made changes in it?

Brief description of the issue:
When zooming in on the world map (any airport) to choose a stand to spawn, the game hangs and stops responding…

Detail steps to reproduce the issue encountered:
Go on the world map, zoom in close to the max so you get to see the stands, and wait for a bit. It’ll hang and stop responding

PC specs and/or peripheral set up of relevant:
m2 970 EVO PLUS

Build Version # when you first started experiencing this issue:
not sure, latest with all updates as of 28th Jan 2022

Do you have a lot of addons, particularly airports?

none at all, apart from the Premium + Deluxe airports and FBW320/787X but I removed these 2 planes and still does the same thing

Any overclock on your PC?
Also, try deleting your rolling cache and then trying.

only remember this old topic:

but thought it was fixed…

hmm, the solution in that post seems to point at add-ons.
My install has some (default) packages unticked (training scenarios I never use, etc.) to free up some space. Would make sense if it was previously fixed but occurs again only for me in this specific use case and install environment I have.

I just nuked my install by verifying the integrity on Steam and I’m redownloading what I assume is everything. Will update this thread later.

only the CPU at 5GHz but it is tested and retested and retested to be stable since 2020, every month.

I just nuked my install by verifying the integrity on Steam and I’m redownloading now. Will update this thread later.

Yeah, that’s what verify does! :upside_down_face:
If you are still having issues, and if the rolling cache deletion didn’t help, for the sake of trying, I would remove the OC.
There are loads of posts in here on that subject.
MSFS is extremely fussy with OC, even when everything else works great.
You can always restore it since you already know what you have set.

1 Like

I’ll try and see, thanks for the suggestion

such a shame Asobo/ms servers haven’t been upscaled yet to handle higher download speeds…
I get that same download speed but in megabytes on Steam :wink:

@MichaMMA @TheSevenflyer

My CPU OC and voltage control has been turned to XMP/default profile.

This is also on a clean MSFS install with everything checked/installed (previously verified integrity which nuked my install and had to redownload ~110GB), also deleted rolling cache after this. There is no GPU OC or voltage control.

Same result…

hmmm… to be sure… you had never ever these google maps add-on installed ?

1 Like

I did, but that is an app you have to run each time you start the game, and I haven’t been running that for these tests. As far as I know it doesn’t modify any of the actual game files?

Here’s my community folder, but even if I empty this folder it still does the same thing.


It’s definitely an issue with the map rendering, as I get artifacts such as these, in Europe as well. The internet connection is 1Gbps fibre so that’s definitely not an issue

nope… this google-add-on a example of a worst add-on…

Please open : C:\Windows\System32\drivers\etc\hosts file and check whether some strange ip-adresses are added. Best is to remove the hosts file ( may backup ) and restart your pc.

ah… and… remove these add-on and never touch it again :wink:


well that’s completely fixed it, and the map issues! thanks!!

I did have some stuff pointing from some azure URLs to localhost in there, though that app would restore the hosts after quitting but seems not


yes… this is what these add-on do… we have some reports about in forum.

Users are often to “trusty” with add-ons. As example with help of the hosts file “attackers” can do all, e.g. forward specific addresses to here own proxy etc… in old ages this was easiest kind of “virus” implementation" which exist… If an add-on ask for admin-right, never click “yes” :slight_smile:

EDIT: I got a note and would clarify…
I have no critism at the behavior/functionality the add-on bring into game. But, in my opionion an add-on should never change system files. If it do it, there must be a big warn message about and a un-installer script.


I want to thank for the help the host file was corrupt this was the fix …

So the google map addon is a no go I guess

1 Like

Thank you!

I was facing the same problem. Removing the host file and the map replacement tool fixed it. This should be reported on so that the tool gets flagged and removed.

1 Like