Would really like to fix this, but not sure If I can fix this from my end

Would really like to fix this, but not sure If I can fix this from my end, Here Goes.

So, I’ve downloaded this scenery from Flightsim.to, it is a very nice scenery pack compiled by 30WEST, Refuge Cove - Discovery Islands.

----In the screenshot provided, you can see an Object within an Object, which indicates 2 sceneries in one, but when disabling JUST the Refuge Cove scenery everything disappears along with the scenery, so I don’t think it’s s second scenery for that area, when I re-enabled JUST the Refuge Cove scenery, the scenery comes up along with this Object that shouldn’t be there.

---- Ok, now, Last night, I went through my community folder, I disabled all USA, CANADA, and ALASKA Scenery, and the Object DID NOT disappear.

---- I then Disabled all Other Regions such as PNG, Indonesia, Asia, UK, ect: ect:, Object still DID NOT disappear.

---- I was left with Aircraft and other folder’s Such as GSX Pro, and FSLT non scenery related, except for one that I missed, PAKD Kodiak Municipal Airport----> PAKD Kodiak Municipal Airport/9Z3 Lilly Lake Seaplane Base » Microsoft Flight Simulator

---- Turns out getting rid of this scenery resolved the issue, but here’s the thing, although it did get rid of the issue, after placing all of the other sceneries that I’ve Removed during the troubleshooting phase back into the community folder, the Object came back.

---- Last thing I Did to try and get rid of the Issue is Move his Refuge Cove Scenery to the very bottom of the list in the Content.XML File which DID NOT resolve the Issue.
2

The only thing I Can think of i,s his scenery may be calling for that Object to appear, whenever a scenery that Uses the Object is installed. Any Thoughts? Is there anything I can do to fix this from my end? I did Contact the Developer but still Pending a Reply.

That white building looks like some generic autogen?

I assume you’re using Addons Linker… have you tried scanning & fixing the ModelLib names? (In Tools menu)

Thanks for the Reply, Not currently using Add-on Linker, but I Do use the ModelLibchanger to scan all sceneries to rename incorrect modelLib.BGL files. ModelLibChanger » Microsoft Flight Simulator

No worries. I know how annoying it can be to track down issues like this!

I don’t know much about how it all works behind the scenes (no pun intended!) either. Just piecing together knowledge from trial and error, mainly.

Have you tried putting that scenery FIRST in XML instead of last (by renaming the folder with a- in front or something)?

I agree it does look like a Generic, still not understanding why it keeps showing up over @ CAK6 , removing all other sceneries and Libraries makes it disappear.

Here’s one of the Screenshots pulled from the PAKD scenery over @ Flightsim.to, I believe this is the building that keeps appearing over @ CAK6.

What’s even more Strange SDK will not Exclude it when drawing an Exclusion Polygon over the Object.

Another thing I did was create an Empty Community Folder…

— I then installed the Refuge Cove Scenery along with the Required Assets

— Added PAKD Scenery and the Object anomaly shows up @ CAK6, which is strange considering it’s a fresh Community folder with just his Scenery, the Required Assets and the PAKD Scenery.

— After Removing the PAKD Scenery from the Newly Re-generated Community folder the Object disappears.

Weird indeed. So the rogue building only appears when you have PAKD also installed? In which case your assumption sounds quite likely that the CAK6 scenery is calling for that model in that position. Or, at least, it’s calling something of exactly the same name!

Is there maybe a small item designed to be inside or near the wooden shack that it could mistakenly be swapping out for the white house?

Seems to be appearing when any scenery is in the community folder, while I was troubleshooting, I pretty much removed anything scenery related out of the community folder except one, Wich was PAKD Scenery. When I removed it, the object disappeared.

After finishing up and thinking I Fixed the Issue, I placed all the other sceneries previously removed back into the Community folder, except PAKD Wich I Left out, and the Object Re-appeared. lol

I’m not sure…is there a way I can find out via the SDK?

No idea, sorry. I didn’t realise I was in the SDK section of the forums until after my first reply heheh.

I’m not a developer and never once used it so I’m not the guy to ask :wink:

Oh, Ok, Im pretty new to the SDK so I’m still learning, but it seems like you may be on to something.

I can’t think of any other reason why that House keeps on showing up, maybe someone decided to build a house inside the Shed IDK LoL.

Yeah that’s the 5 star accommodation there. If you have the extra money you can be a bit warmer over night :slight_smile:

1 Like

If you enable the debug model Lods , using the package name / objects name options you will know the packages is putting that building there
Autogen building will not shot anything, but those can be excluded with simple polygon

1 Like

Hmmm … nothing to do with the rolling cache is it?

I see you have another package in the content.xml called “required library-refuge cove”. Perhaps try giving that a priority of 2 as well.

I’d like to thank everyone for the help, I was able to get in contact with the Developer, who has resolved the issue. :100: :+1: