X52 Controller, unable to steer aircraft on the ground, ongoing problem

The same problem as with my last post. I still have NO fix despite the several replies to previous post. ALL aircraft type, when I land, the rudder keeps juddering from left to right, unable to steer aircraft, so it either crashes or ends up on the grass. No suggestions have worked? It is easier to land on water. Tried Default controller and Saitek X52 option. Also Generic or Modern mode. I have tried altering the various assistance settings. Every setting I can think of. The Win10 controller calibration setup works fine as does the Logitech Saitek X52 setup software. I have NO controller problems with AeroFly FS2 Flightsim. I eventually received a reply from MS FS Tech Support and have asked me to send a video of rudder control problem when I land. They have also asked for screenshots of the keybindings and peripheral profiles, but I don’t understand what this is? Maybe someone here can explain. I still like flying in FS2020, but have to forget the landings, at least on land. This problem has lasted for over 4 months, and seems there is NO solution!?

In settings try to uninstall rudder controll and then reinstall rudder settings control after update 7 settings got changed somehow even thou looks good. Good luck.

How very odd. My X52 works fine, I steer by twisting the joystick. I guess you aren’t landing with the handbrake on?

I have the same problem, driving me nuts. Using an Xbox One controller. I have learned how to feather it on takeoff (because otherwise it goes nuts) so it works on takeoff but as soon as I land, a perfect landing makes me look like an idiot. I’ll double check the brakes but I know I am not inadvertently pressing them after I take off.

As for uninstalling rudder control, how/where do you do that? Thx.

Just a shot in the dark, as I’m a X52 user as well, but how are the condition of your cables?

I had to change my cable that connects the throttle to the stick, no problems since.

Thanks for reply. Where are the settings to uninstall and re-install the rudder or other controls. I think that I may have already tried this.

Thanks for reply. Yes it is very odd, and especially that the aircraft is able to ‘Take-Off’ straight. I did check the handbrake before landing, OK.

Thanks for reply. As with StyledSeeker235, how do you uninstall and re-install the control settings. It is possible I may have already tried this. I will look again.

Thanks for reply. The cables are fine. I know this is so, because the Win10 and Saitek settings show the rudder as working OK, and there is NO rudder problem in AeroFly FS2 Flightsim.

As already mentioned, MS/Asobo Tech Support have asked for a video on the rudder steering problem upon landing, I know how to do this. They have also asked for a screenshot of the keybindings and peripheral profiles, but not sure where to look for this. Advice please?

I was having the same problem with my saitek 290 pro. I went to the settings menu and remapped the rudder settings on my joystick rudder axis settings. the rudder would turn when looking at rudder from outside view but would not hold. after remapping the xy or rudder settings it fixed the problem. Dont know if this will work for your stick or not. it is in settings menu where joystick and keyboard settings are shown. They looked good but somehow the settings got changed with the update 7.

go to settings and look at rudder settings for joystick. should be axis settings… just redo these settings the mouse, keyboard, and joystick settings are there. hope you know where settings are.
regards and good luck.

I also changed the curve on rudder settings a little. Just change the curve a little and save the settings. may make a difference It is not your joystick but the flight sim settings .

Make sure Auto Rudder Assist if Off. After updates everything gets set to easy and that is one of the thing that get turned on.

I ran into that problems myself. Turned it off and problem fixed.

Sorry it is not settings but control options. go to options and then control options. remove rudder and validate. then redo rudder as before. validate and then set sensitivity as you like it. Hope this works.

Thanks to all for your advice. I have been tweaking some of the ‘Assistance Option/Piloting’. The whole list was set to ‘OFF’? I have turned ‘ON’ Auto Rudder, Assist Yoke, Landing, Takeoff, Controller Sens. All others ‘OFF’. Now, I don’t have any Rudder problems when landing. It would be interesting to see what effect if I turned them all ‘OFF’ again? I have also been tweaking and re-setting some of the controller settings. I started to have the rudder (ground steering) problems after one of the updates. It is VERY annoying when these updates upsets many of your settings.