X52HOTAS - Jitters with Z, X, Y AXIS

HI everybody,

I wanted to share an annoying experience I’m having recently, i could find a couple of people having the same issues on different forums but couldn’t find any resolution for the problem…

The problem is the following : I’m having jitters with the x52 hotas throttle with all axis related controls, so the throttle itself but also the 2 “knobs” controls on the right top corner of the throttler.

Basically, it’s like there are constant mico moves all the time.

Usually, it’s not really annoying, but flying the DC6 is a problem, as during the test phases, u need to reduce the speed for each engine, which i can’t under those circumstances.

  • community folder has been cleaned up before doing additional tests
  • the latest gc driver is installed
  • i tried different versions of the x52 driver
  • windows 10 is running with the latest patch
  • same with bios , latest driver installed
  • i made some tests with the keyboard unplugged to ensure there are no conflicts between controllers, no chance
  • i uninstalled fspuic7 be thinking it could interfer, nothing

This was not happening in the past, i can’t remember exactly when this started, but it’s quite recent.

One interesting test i made is that if i have the controller test software from windows 10 running with the calibration screen and all axis monitors while FS2020 is not running, no jitters.

As soon as i launch FS2020 and it reaches one of the last loading screens , then the jitters start ! So it has definitively something to do with FS2020 or one of the underyling application or framework layer it s using.

If you have any idea i could dig out to help me resolving this problem, would be super great :).

Thanks in advance !

I have a similar issue with my HOTAS One on the XBox X. Only one axis though - the elevator. The other axis are all rock solid with no movement when the stick is left untouched. The Elevator twitches though are causing the plane to be almost uncontrollable (lots of manual input, feels like constant turbulence & can’t trim to steady flight) in manual flight. Even on the ground at standstill in external view, with no hands on the stick you can see the elevators twitching up and down with no input. I thought it was a hardware problem with the stick, and it could still be I suppose.

The only way I can get the sim to get on top of this is to reduce sensitivity of the elevator axis (-30% say) AND put in a 10% dead zone. TBH the rudder and aileron axis both work better at -30% sensitivity too as the Hotas One feels a bit too responsive otherwise (to me).

The downside for me right now is that there is a known bug on XBox where any changes I make to sensitivities aren’t saved beyond current flight/session which I’m hoping they will fix soon as it’s a grind having to redo sensitivity adjustments every time I go into FS.

I have an original Saitek X52 and I get jitters on every single axis, including the rotaries and slider on the throttle lever. The only time it doesn’t happen is when the axis is pushed to either 0% or 100% and left there. Luckily, the jitters are quite small and don’t affect manual flight. But I can sit in a cold/dark cockpit and watch the yoke wiggle ever so slightly. As for the rotaries, I leave both at 100% when I fly the TBM so that they don’t affect the single lever power control. In the C208 (the only other t-prop I fly), I use the rotaries instead of the mouse to control the prop and condition levers. (Feathering still requires the mouse.)

Hi guys,

Thx for your feedback, i feel less lonely lol.

What i don’t get, is that a friend of mine has exactly the same model without the issue on any axis … So i guess he’s super lucky …

I’m quite disappointed by the lack of reliability of this joy for that price i must say.

1 Like

If you google it, there seems to be a few other people with bad or dirty potentiometers on their TM’s.
There are also some discussions on cleaning them. Google “cleaning potentiometers thrustmaster”. Not sure I feel that adventurous though and will probably stick with just inserting a wider than necessary (10-14%) dead zone in the sensitivity settings for elevators. I could of course try a warranty claim, but I’m not sure if it’s expected behaviour ie within tolerance limts or not.

I exchanged the hotas and could make the warranty working, exactly the same problem…

1 Like

But yes, i ve also checked couple of article stalking about it … Thx for the reply

1 Like

I had similar issue tried everything, even removing the spring. Ended up taking the plunge on a virpil, best move I ever made. Now I just use the thrust lever part of the x52 and no more jitters.

Even on my very precise T16000M and Gladiator NXT I’m using a 2% deadzone to avoid any possible problems.
I usually exchange my joysticks when the required deadzone increases to >5%.

A sensitivity of (at least) -30% on all flight control axis seems to be required in MSFS to compensate for the greatly reduced travel of standard joysticks to achieve a realistic control response.
But sensitivity has nothing to do with jitter.

I’m well past that 5% deadzone on the elevator on my new Hotas One, maybe I should warranty it as it was new in June. I can visibly see the simulated stick moving inside cockpit and the elevators moving while in outside view on the ground with no inputs by me. I agree -30% on every main axis except throttle which is better with a linear response.

Thx for all ur posts, meanwhile, i wanted to share information with you that i fixed my problem : a powered USB 3.0 hub !

No jitters anymore :))

Well have extremely low ones from time to time on the Z axis, depending of the position it s set, but uncomparable with what i had before.

So, it looks the HOTAS x52 is badly built in terms of power management apparently.

I would suggest to try the same ! Costs me 20 euros

1 Like

That is interesting, I may have to try this. I contacted Thrustmaster for my Hotas One vertical axis only jitter and they said to try it on a PC (instead of the XBox) with their PC drivers which I did and saw the same vertical axis jitter.
They then told me it was defective, uneconomical to repair and to return it to the seller under warranty.
Maybe that is indeed the case since it’s only on one axis.
It would be really interesting to try to see if the jitter changed/went away with a powered USB3 hub though. Right now it is sitting in a box awaiting shipment back to the seller. Meanwhile I can’t flight sim.

I still find this bit of your original statement interesting in light of your USB3 power findings. So FS2020 modifies available USB pwower requiring a powered hub? It’s a strange one.