Xbox Controller on PC - Camera Bound to Yoke Control

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons?

I do not have any mods

Brief description of the issue:

Since the most recent update, I can no longer use my Xbox Controller for my Primary Flight Controls. I have the yoke bound with the left joystick. Without any adjustments from my end, the camera now moves within the cockpit while using the left joystick, along with the yoke. It makes it impossible to play the game. I have tried un-binding every single other item attached to the left joystick. The issue still persists, and the camera will shift in that direction of the yoke input.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

No steps made to cause the issue

PC specs and/or peripheral set up if relevant:

Xbox controller connected to PC via Bluetooth. Playing on Windows, not Steam.

Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Is this your issue?

Its not necessarily a camera “float”. I remember this one. If you went to move the camera it would just keep floating in that direction until you went another. This is different.

Essentially, it’s like the arrow key function on the keyboard that will move your stationary view up, down, left or right, is tied to the left joystick on the xbox controller, along with moving the yoke. I have confirmed that the yoke functions are the only things tied to the left joystick. Restarted the sim, tried to reset the controller layout. The only thing i havent tried is uninstalling the entire thing and reinstalling.

Thank you for the reply.

1 Like

Bump. I hate that I can’t use the simulator in this current state. While I wait for someone to chime in on here, I’m going to try what I’ve been avoiding…complete re-install :neutral_face: I will update with the results in a few hours.

Update #1: Re-install crashed about 1/2 way through. Opened back up in “Safe Mode” and starting on re-install attempt #2.

Update #2: Re-install crashed again. This time I identified it at 44% completion. Re-starting installation once more.

Update #3: Re-install successful. Started a basic flight in a Cub with no adjustments to Xbox controller settings. In Cockpit camera issue still persists. Adjusted In-Cockpit camera settings to unbind all functions attached to left joystick (L). Issue still persists. Game is still unplayable with an Xbox controller. Help :pensive: