Xbox controller triggers are still a binary input despite having a sensitivty option now

I play with an Xbox controller and for the longest time the sim only recognized them as binary inputs, so assigning them to my rudder meant I could only apply full rudder input and not take advantage of the analog input.

I’ve been away from the sim for a bit but just loaded it up again today and I see the right and left triggers now listed in the sensitivity menu in the control options. However they still appear to be either on/off binary inputs. I pull the trigger back slightly but do not see it registering in the sensitivity menu at all until it reaches a certain point, at which it goes all the way to 100%. Has anyone else experienced this?

Yep, I had this. Just delete your current controller profile and let it create a fresh one. Triggers should then work in an analog fashion and self-centre on release.

@DNBOF Was it fresh as in totally new with no buttons set? I’m trying everything possible to avoid that because there are tons of menu nav and other buttons that come preset with the default.

Nothing I’m trying seems to work. I’ve cloned the default preset as well as a custom one I made a while back but neither time the triggers worked properly. Did you delete your only custom preset (I had a few, wondering if I should delete those too) and then create a fresh preset with the “new” option or were you able to clone the default and go from there?

I fixed it by setting my RT and LT to the “rudder axis” key bind instead of just rudder

1 Like

After the last update I thought the rudder axis was finally working incrementally. Now it is responding with on/off again. I don’t understand what is going on.

And it takes me about two hours to rebuild my controller mappings, so I’m not anxious to delete my profile and redo it to see if the rudder axis responds correctly again. That’s another two hours I’d rather be flying and not fixing.

After the update, we started seeing a lot of complaints that my controller rudders don’t work anymore, or that my rudders don’t self-center anymore. Was the mapping behavior changed back?

To add to my last post, I am mapped to rudder axis.

I’ve seen lots of other people complaining about the same thing but I don’t seem to experience it. Setting them to the axis specific binds did the trick for me. I can’t really replicate the wild control or self-centering issues. Using a MS Elite Series 2 controller if it’s any reference.

Some people having a problem and other not seeing the same thing seems to be a common theme in MSFS. It’s puzzling to me.

Ok, good question. I had a custom profile and following the latest update my triggers went binary and would not self-centre. I deleted that profile and started again from default profile and with that got analog and self-centre back.

I’m with you, controller profiles are such a black art I try not to mess with them

Availability on the Logitech T.16000M seems to be loosening up. I got one for $110 from Amazon a few weeks ago, and they still have some (4 as of when I checked a bit ago) for a few bucks more. I specifically ordered it without the throttle “quadrant”, as it’s my intent to get a Honeycomb Bravo for that purpose. It does have a single axis throttle onboard, but as you may imagine it’s not the best.

(In fact, Sporty’s is now taking pre-orders on the Bravo, so I jumped at the chance and ordered one this morning for (hopefully) early February delivery.)

I specifically ordered the Logitech as an interim solution, fully intending to replace it with the Hoenycomb Tango (I think?) stick, but I like it way more than I thought I would and may just keep it. But we’ll see what the Tango has to offer as more details become available. I can’t use a yoke (which I’d much prefer to) because I’m disabled and can’t use rudder pedals, so the twist rudder on the stick is mandatory.

At any rate, I can wholeheartedly endorse the Thrustmaster, and would strongly encourage it’s use over an XBox controller. They have their uses, I have one and use it for the drone cam, but since I’ve switched to VR I haven’t used it at all. Airplanes are not meant to be controlled by console controllers.

As for your actual original question, unfortunately I’m useless as far as an answer goes, it’s just not in my wheelhouse.