Xbox/PC screens go black then CTD

Does this apply to the Xbox as well? Does the fact that I am using the Xbox Game Pass (Free Version) of FS have any effect on this update?

1 Like

On my side, I can’t manage to make almost any flight in the North, especially North America, Europe, North Asia. I just manage to make flights to the South Latin America / South, Africa Australia.
On Xbox series S

After seldom being dropped, for some reason, today I had a couple CTDs today doing a couple legs of a bush trip. Fortunately they were when I was on the ground and did not zap my flights.

I just got a CTD Sim freezes up then CTD live weather live traffic in photorealistic

Yes you can join the beta in the xbox insider hub

I wonder if servers at MSFS/Asobo are partly involved in this fault.

I had several consecutive flight’s loading to runway with black screens. Then without changing a thing it tried a third time and suddenly all loaded correctly and completed a 2 hours flight no issue.

Its not a game breaker for me but so many others have a far worse time. This shouldn’t be happening on standard build consoles

Most of my CTD’s have been the same day as an update - that would indicate to me that server load does play a part here.

1 Like

Bug is so weird. Played for 3 days no avionics glitch, game was running absolute perfect. Turned on today and tried 3 flights so far all ending up with screens blank.

3 Likes

Hopefully Sim Update 10 will touch on this topic

Hi.
I experience same issue, but unlike most other reports I read, my A320 screens are all blank from the beginning. I have tried starting cold and dark at a parking stand, and the avionics stay black when turning on batteries. Even the battery status right beside the battery buttons stay black.
If loading the A320 onto the runway all set up, the screens are all black still too.

My MSFS should be completely updated. I am playing on XBox S on the Game Pass version.

When the screens go black you have to restart the sim. Just initiating a new flight doesn’t reset the display code.

Hi MimikriX.
I should have written that: I have restarted both game and console several times. The problem arises almost every time, but weirdly enough not every time. I suspect it is rarer to occur on first instance after console reboot, but I am not sure.

Let me know, if you have any other suggestions. Otherwise, I will install that debugging app and create a bug report.

1 Like

Nope, unfortunately not. Just had a perfect flight. Went back to the globe and started yet another one cold and dark. Displays were initially black but after a few seconds came back on again. It lastet till short of pulling the throttle to toga on the runway and boom they went black again. :sob:

Nevertheless I manage to make flights. Certainly not in all the cities, especially the northern one, where I have mostly black screens at the beginning. I disabled the multiplayer mode, the AI traffic mode is offline, the HDR of my screen disabled. This being said I only have crashes or black screens on the gate after flights of more than 6 hours.
My cache is also disabled.
I’m in beta mode on xbox series s

After several unpredictable black screens (and afterwards CTD’s) on Xbox S, SU9, I am getting a feeling that it is related to the navdata that the sim is caching somewhere.

When I fly low and slow, VFR, using a very minimum of VOR’s, in default and 3rd party planes, for weeks I have no issues and even thinking the bug does not exist.

The last few weeks I have been flying airliners (default planes) again and using the FMS, doing flight planning. Now the black screens and CTD’s starts to hit me too.

Sometimes I actually can predict when it is going to happen in a flight when I am getting prepared for it. Examples:

  • When you hit the screenshot button, but a clip is created (Some weird Xbox bug that happens sometimes after a reboot, wrong cached setting?) Almost certain somewhere during my flight I get black screens.
  • When entering fuel amounts in Weight and balance. When the amount jumps to something else than you entered (cached data?), black screen and CTD will occur.
  • When entering waypoints in the FMS and the FMS gives you a choice to choose between 2 OF THE SAME waypoints (cached data?), somewhere during your flight black screen will happen followed by CTD.

When I preparing flights and none of the above oddities happen, I have a smooth flight that can last more than 5 hours.

So yeah it might be memory and cache related. This could be Rolling cache from MSFS or some other cache/memory that Xbox is using to boost performance in startup etc.

I mean it is really weird that one time you load up the sim after a reboot and you have two of the same waypoints in the FMS and a next time in the same situation (enter the same waypoint) The FMS only finds one and adds it to your plan as it should. That means to me that somehow this data is being cached somewhere.

2 Likes

I don’t have the CTD issues that others have experienced, but thr A320neo black screens have taken place at Charles de Gaulle and Paris Orly. With black screens in thr aircraft, you can no longer follow a flightplan as the autopilot will only fly in a straight line, and you have to manually adjust height and speed.

Black screens have happened on final approach to Paris Orly and the aircraft becomes uncontrollable.

Decided to give Xbox a try after 6 months today. Tried to load up with the A320 at Gibraltar. But nope! Like a slap on the wrist, the sim crashes on pressing start flight. I guess back to my gaming rig it is then. You guys let me know when the sim is finally fixed on console. lol.

2 Likes

What my expierience is, with this issue.
I haven’t any CTD or Blank avionics on all planes, even the A320neo, at any airport, Third party airport or not. No issues over 21 flights with the A320neo, no matter what flightime or wheather! All that on Xbox series S! And I’m pretty happy with that. But two important things
I don’t use rolling cache, and live wheather or live traffic. But it also makes fun!

Over 4 months, finally no issues with the sim. Of course, few small little bugs, like quality of live issues😂! Like cars flying over the road. But no crashes like that!

Still having various CTDs and blank avionic problems. I specifically noticed that today when I inputted the entire flight plan into the MCDU (I am in the A320neo), I would continue getting blank avionics after putting it in, then they’d come back on a few seconds later, but I’d lose my full flight plan. Kinda infuriating losing 20 minutes of work, this happened to me four times BTW.

2 Likes