Xbox Series X - CTD trying to do almost anything since SU6

Hi all,

Since MSFS 2020 updated to SU6 on my Xbox Series X, i’m having a heck of a time keeping it from crashing out to the Xbox dashboard and i’m not sure what’s going on.

After it updated, i selected EWR from the World Map, pressed ‘Fly’ and the screen started to fade out, seemed to pause for a moment, then crashed to the dashboard.

Tried a different plane, same problem. Then i tried a different plane at TPA, it loaded this time, but as soon as i exited and went back to the main menu it crashed back to the dashboard.

I uninstalled ‘Airport Regional Environment X’ and deleted my rolling cache. No luck.

Anyone know what might be going on?

Did you try a full reinstall? I did get a few crashes and definitely more than pre-SU6, but that was flyable.

In addition to clearing out your cache, you may also want to try completely closing and quitting the game and doing a hard restart on your Xbox (not just placing it in standby, actually turning the console off and back on). That has helped me in the past

Just dry the following:

Delete Rolling cache - close flight sim - shutdown Xbox - disconnect it from power at least for min 30sek. - connect it back - start flight sim - add rolling cache. I personally restart flight sim after creating the new rolling cache once more.

This procedure help me after WU6 to became Flight Sim stable again, as I was facing similar problem like you this time.

Hope this helps

Unfortunately no luck. I was able to get in a fly a little bit this time, but as soon as I tried to go back to the main menu if crashed out again.

CTDs are still frequent on Xbox. During the weekend I got CTD from the following:

  • CTD when pressing “Fly” after creating a flight plan
  • CTD when trying to go back to the main menu after a flight
  • CTD during flight, completely randomly (after less than an hour)
  • After landing, but still taxiing around the airport (I got a CTD just as I was stopping at the gate)

Nothing really seems to have changed in this regard, crashes are frequent and the game is not stable at all on Xbox (Series X). I am able to complete some great flights but then again there are periods when the sim just crashes left and right. This is really unfortunate and extremely frequent.

Can’t even leave Orlando airport because the game just crashes every time.

Sadly, CTDs continue after SU7. I haven’t been able to fly much more than an hour. Just got a CTD mid-flight after 75 minutes, at 40000 ft with the Citation Longitude. Longer flights are still not possible on Xbox.

After SU7 update, I tried to update the content in Content Manager. I got continuous CTD. Eventually it corrupted my installation so I couldn’t remove but I couldn’t update packages. I had no choice but to do a complete delete, then reinstall. Since then I haven’t had an issue. Perhaps you have a corrupted file from a crash.

I find most of these crash issues to be with the DLC. Apparently they have no way to test and rely on Microsoft. Everyone seems to be passing the buck instead on accepting responsibility and resolving this for us