Xbox Series X- HOTAS One Issues

Yeah something is definitely going wrong with this stick profile, most things think they are F2


Same issues for me, the buttons aren’t inputting in game properly- I hope it’s a fast fix on Thrustmasters end. Using my controller for now

1 Like

Same issue here


Same issue.: and… somedefault buttons don’t respond


Make sure the switch on the back is on Xbox not PC and then make sure the light on the Xbox button is on. I use mine for my pc and it’s literally the complete opposite of that for it to work. Hope that helps possibly

1 Like

Same issues for me too… when I mapping button 5 (X) it appears like B1…
and when I mapping button 6 (A) it appears also B1 !!

This is the all mapping i checked :
Real button on T flight // what happen in FSim :
F2 = B4
B2 = B2
F1 = A
B1 = B5
:arrow_up: = F2
:arrow_down: = A
:arrow_left: = Y
:arrow_right: = B2
Throttle = F2
select button = B
start button = Y
Next = A
Prev = X
B5 = B5
Y = B2
B = F2
A = B1
X = B1
B3 = B3
B4 = B4
back throttle button = F2


I’m glad it’s not just me. I was worried my hotas was faulty! Hopefully it’ll get fixed soon. In the meantime it’s a combo of hotas/controller/mouse to keep flying.

It’s like the Xbox controller and the hotas set up is conflicting with each other. I have full left roll but limited right roll

1 Like

I’m having the same problem

I thought it was just me!! I’ve been using a combo with the controller. But I’m glad I’m not the only one with issues.

In the release notes, it is a known issue with a ‘workaround’.

Just copied this from the known issue link:

  • Xbox players using the Thrustmaster T.Flight HOTAS One: Mappings on the Controls screen does not match the labeling of the buttons and axes on the peripheral.
    • Workaround:
      • Though what you see on the screen is incorrect, if you make an assignment through scanning it will be accurate. Do not use the drop-down to create your mapping.

I was having the same issues, but I’m at work for another 3 hours so will try this when I get home…although I’ve no idea what “Make an assignment through scanning” means lol.

If we make our own configuration will that still work in the training exercises or will it still want us to press B4 to center the cockpit, which ended up being F2?

1 Like

Can confirm that their listed workaround works. When you go to select the input for an action, click on the button that it has mapped instead of the drop down(recommend using a mouse for this), and then just press the actual button on the Hotas One that you want to map the action to. The button it says you pressed will be incorrect, but just ignore that. The button will work as intended.
Some buttons may be need to be manually unmapped from other commands though, or else it will do both commands.


Anyone know what is “Left Joystick Axis 5” ? on the Hotas? It’s supposed to be to trim the plane.
I don’t know how to trim the plane.

This is my problem too, but being a neophyte to this world, I have no idea what “if you make an assignment through scanning it will be accurate” means.

I’d be v grateful to learn how to ‘make an assignment through scanning’.

I’m watching youtubers go through assignments on peripherals without profiles, but I’m assuming that involves using the drop-downs which is, in this case, not gonna work.

Help please. I wanna fly! (with the HOTAS). bd.

I’m having the same issues. I tried the workaround with several of the buttons as well as the elevator, ailerons and rudder but none of these functions worked at all.

Instead of a work around how about they just fix it??

Will they fix it ??

1 Like

Should be the rocker on the back of the throttle


When you assign a button it give you two options. Scanning is the top one, which basically means it sits and waits (scanning) for your next your button presses to see which one you want to assign. The other option is to select the buttons from the drop down, which is the one Asobo are saying you should avoid ofr now.

I was having the same issues as everyone else, miss matched buttons etc, I figured the work around by myself but it was confusing to say the least, thought a firmware update on the Hotas might help but havnt got around to it.

One thing that helped me was to go into free flight, take off and get some altitude then live pause the game.
You’ll find it in the menu section, just make sure your filter is set from ‘assigned’ to all, that will enable you to scroll down and find it.

I bound the Y+Trigger button on the throttle and stick, that gives me flexibility to jump in and out of the controller bindings without worrying about flying, I’ve adjusted all the sensitivitys to half, and a dead zone of 5, among many others such as the smart Cam, next and previous etc.

If I find some useful binds I’ll post then up.