XBOX Series X noob. Bug with training

I’m new to MSFS (well I did play in 20 years ago but that’s it) and was looking forward to firing up a Cesna on my XBox Series X. I’ve got a LGCX and the game simply looks amazing.

I thought I’d start from scratch and take up the training guides but soon found that the objectives are sticking and not progressing. You can work around this by pausing (sometimes multiple times) and it will kick starts the progress again, but it happens so often that it spoils the experience.

I tried just waiting to see if it was a time enabled milestone, but no, it just maintains a 'no objective banner.

Anyone else?

This has been happening to me as well. Pausing and unpausing, changing cameras. Sometimes it won’t even progress. Hopefully this is addressed soon.

I am having the same issue as well. Makes it really difficult to play at all…

It hung once for me. I restarted the console and had no further issues.


When you say hung, do you mean that the instructor started giving direction and then stopped? This is what is happening for me.

I hope they sort it, but I’m not holding my breath! It looks like the same problem was on the PC version in early 2020! Apparently up and down keys remedied it…

Yes, I was waiting for further instructions that never came, though it only happened once to me.

It worked. Restart the console!! Weird hey? Must be a cache issue or something…


Much to be said for a restart. :blush:

:rofl::rofl::rofl:I did laugh when it worked!!

restarting fixed mine as well!!

Having the same exact issue! Restarting worked at first but the issue comes back again.

Hard reboot appears to have worked for me too. Was able to get through the second Flight Training module successfully (finally). Will try more later.

Reset helped objectives progress, but training session doesn’t complete. Then says I failed. :disappointed:

Same issue, very frustrating, I can complete a few objectives but then the instructor just stops giving more after one or two are complete and I fly around or sit there with no further instruction. Restart did not remedy

Same thing is happening to me! Very frustrating. During the training my instructor tells me I’ve gone outside the training area and it restarts.

Now on to the 4th activity attitude pitch and 5 th turns roll and after the first section nothing as you can’t complete the training.

Good morning.

I have flight simulator on Series X and to date no problem.
I am completing the training and have arrived on the VFR flight.
Well, by resuming flight training now the objectives are no longer received and / or are not communicated leaving the player in a sort of infinite free flight!
I can’t understand what happened.
I can’t figure it out.
What can I do?

This morning I try to uninstall the Flight Simulator from my Series X and reinstall it, after which I restart the console. But how is a forced reboot done? Do I have to unplug the power?

Good morning.
The same thing happened to me too.
Yesterday after installing a “world” update, I resumed training, it makes me start a mission (I arrived on the VFR flight), but the objectives are not updated and they do not advance!