Xbox update today (3 Nov) killed MSFS Start up! No action what so ever!

I just tried to get MSFS to run after updating Xbox.
I 'll try to repair ap. and report back.

1 Like

Just for fun …

I made a zendesk report which is “solved” right now. And you know what ?

Always the same pre written answer

  • Download & Install the Xbox app (haha i told us that i got an update today for this app)
  • Make sure Windows is up to date -> Why did they asked me the build and version of my win install when i did the ticket ??
  • Make sure all the updates in the Microsoft Store are installed, especially Gaming Services and Xbox Companion app -> cf. first point

Just tried to “repair” MSFS. Did not work.

I can confirm. After the lastest update of Gaming Services (version 2.47.2002.0) unable to start MSFS at all.
Main window opens but after couple seconds if closes to desktop without any error message.


Same problem here. MSFS does not start.

1 Like

see here:

Write reports to zendesk to wake up support!

You thread is the third today about the same issue. It would IMO be more helpful to combine your thread with the others. Please ask forum admin to do that. If you do not know how to, I can do that for you.

1 Like

Defender is causing the problem. It was identified at the other thread under the “bug” section.
If defender is disabled then MSFS works.

You should get a pop up on the splash screen asking for network permission. If not, like mentioned above disable Defender.

If you don’t want to disabling Defender every time you launch MSFS. Exclude the MSFS Directory (C:/Users/…) from real time analysis.
I’ve just try and it works

You need to allow MSFS through your firewall. You may have hit “decline” when this popped up.

To do so:

Search Firewall

  • click Windows Firewall in search results

In the Windows Firewall page click “allow an app through windows firewall”

In the following page hit the “change settings” button, this requires admin privileges.

Scroll down the list in the same page and search for Microsoft Flight Simulator - ensure “private” is ticked. You may tick both “private” and “public”.

This should allow MSFS to start up now, without the need to disable your entire Windows Firewall or Defender.


same here. only black screen for a few seconds

Same here. :frowning: It’s already enabled to allow through firewall.

1 Like

Same. I’ve tried all the “fixes”. Defender, community folder, unplug peripherals, disable monitoring, pour whisky into the CPU, none of it works. Loads to the black screen with the white border and crashes out.

1 Like

Same here! Launch game, black screen with white border for few seconds then bam, nothing.


both are checked marked but still have the issue.

1 Like

Forgive me if this is a silly response but have you tried restarting and/or doing a full shut down start up?

Yes , also uninstalling MSFS and then Installing

You should still not disable your entire AV and Firewall. I’ve replicated this issue on another device and adding an exclusion within windows defender solves this issue ( ) - if the firewall exception didn’t work.

same thing here. MSFS allowed through firewall, both checked. No dice. Loads for a sec screen goes black and punted to desktop.