XBox X World Updates

Have managed to install update 13 and some World Updates.
Content Manager shows me that I have updates available for VI Germany, VII Australia, VIII Spain , Portugal, X USA, and XII New Zealand.
Despite numerous downloads over the past fortnight, which seem to run right the way through to decompressing, CM still shows me that I have these five updates available.
Market Place doesn’t show them.
Version is 1.34.16,0
Any help will be greatly appreciated.

Arthur.

Try either expanding or collapsing individual packages from the top row. It could be a livery or content update that doesn’t show in bundle view. Otherwise, maybe restarting helps?

Hello there,

Thank you for your post! Your topic has been moved to the Tech Talk subcategory of General Discussion & Community Support. The General Discussion category is meant for discussions that fall outside our other sub-categories.

Please check out these other categories for your future posts:

  • Aircraft
    is where you discuss current or future planes coming to MSFS as well as assistance with liveries.
  • World
    is where you discuss scenery, airports, and weather.
  • Aviate, Navigate, Communicate
    is where you ask for help with flying.
  • Tech Talk
    is where you discuss installation, graphics, drivers, performance, CTDs, peripherals, and hardware.
  • Menus & Activities
    is where you discuss activities (landing challenges, bush trips, etc), plus anything accessed by the menus including the Marketplace, settings, logbook, cameras, etc.

We have received several reports of this issue just as you describe with those same World Updates and some bush trips getting stuck in an update loop for Series S/X users. Our QA team has been able to reproduce the problem on our side and is now researching the root cause. Unfortunately we do not have a time frame to share for it’s resolution, but just know that this is actively being researched and a fix will be released once it is found.

1 Like

Thank you for that BoomUga.

Thanks as I also have this same problem

I have the same problem with world update II, V, VI. I install them and on every restart I need to update them again (xbox series x)

Thanks for advise. Have tried that - installs all the Asobo products properly, but none of the MS.
Thanks