[Xbox / xCloud] Control profiles not saving

Cloud gamers here to, and the controlls was messed up after su10, so the rudders didnt work.
Took me 2 weeks to figure out and make a custom setting.
Then su11 and helicopters happend and bom, settings is gone!
And that is not all!
When deleting settings the game losses controller input completely and you cant do anything in the game! You just sit there like an idiot in the menus because you deleted the controller!
This is the most idiotic thing I have ever experienced in all my years of gaming!
Did this first time when trying to get back the rudders, and the only sollution is to delete the save in the cloud = bye bye all of your progress!

It should not be possible to delete all ways of controlling in the menus!

When it happend again now when it automatically deleted my settings just because I switched to default helicopter controlls, It was devestating!
For some reason this time a restart was all I needed to do for the game to function again, so maybe they have fixed this, hopefully.
My settings wasnt back but at least the default plane setting was choosen instead.

1 Like

No issues with profiles on my end. Series X, with 3 custom profiles. I’d recommend a fresh install, also resetting cache while keeping games.

Cannot “reinstall” the cloud game.
Bebides, even on Xbox Series you also lost any control profiles you had made prior to the update.

May we remind the developers this is NOT a free software?

We paid for this. They unnecessarily updated something. They broke the controls mapping, the controls setups saving and the ability to create new controls settings. They completely ignored this issue for weeks still and have not fixed what they just broke.

You should at least test your update before you force everyone to download it.

1 Like

I have the same problem. It looks like it’s not a saving problem coz when I look into profiles on PC I have a lot of them created on xbox cloud but I can’t see them on xbox. Very annoying. it’s weird coz 2 days ago it worked then I start switching between legacy and modern Flight model coz I couldn’t worked out how to hover helicopter and now better not to use rudders and helicopters at All.

Same problem here. Duplicate Profil or change Default didn’t save at all.

Now I see the Problem is now longer then 1 month…

I hope they will look at it.

1 Like

Has Microsoft at least acknowledged the problem yet?
It’s been over a month already guys! I haven’t made any single flights since this last uncalled-for anniversary update due to this issue.

I wish I could just roll back to the last functional version of the sim until Microsoft decides they want to fix what they needlessly broke…

1 Like

Same problem here. Edit or duplicate profile didn’t save.
xcloud browser or app

Yeah. I’m not sure what’s going on, just very disappointed in the development team.
Found multiple similar threads, commented on their latest youtube videos, checked every news updates - they have not acknowledged the problem or mentioned anything at all, completely ignoring all the threads we’ve made.
Their official bug tracking thread has a bogus fix telling us we should delete our cloud data (pretty much restoring our profile), not only that doesn’t work at all - the bug remains - but it made us lose all of our profile progress data / flight hours together with the possibility of recovering our custom made control profiles we’ve made before this last anniversary broken update.
Way to go!!!

Aaargh
Spent about 30 minutes again mapping everything and tweaking sensitivities and deadzone thinking the controls would not restart to default if you don’t change the profile.

Well, just started MSFS again and to my surprise all my mapping is gone. I’m not touching this again until they fix it…

Good thing the bug has finally been confirmed, let’s hope they manage to fix this 2 months old bug soon.

1 Like

I have to redo all the bindings every time I try to use the Xbox controller for Cloud gaming. I saw a YouTube video where someone said you should be able to create a separate profile for each aircraft! Don’t know what planet they were living on but it certainly wasn’t on Microsoft Flight Simulator.

2 Likes

It’s still not working at all for Cloud gaming. My control profile was gone and there is no any possibility to create the new one.

3 Likes

Hello Scomin, I’m having the same issue. I thought it had been resolved by Asobo, but it hasn’t. I contacted Asobo and was directed to XBOX support, which isn’t human at all. According to the “known issues” notes on Zendesk, this is a cloud profile issue and basically I would need a PC running MSFS natively or the Console to delete these corrupted files in the cloud, which is not an option for me. I don’t think Xcloud will make a move to provide something to delete cloud profiles anytime soon.

2 Likes

This bug needed to be taken more seriously.
I’m shocked it still hasn’t been resolved.

I’m not going to buy a console or much less bother a friend to log in with his console and delete my cloud profile. This answer on Zendesk seems like a joke.

1 Like

Well, I tried to contact Microsoft about this on Xcloud! It doesn’t seem like they’re concerned about it unfortunately, since those who have consoles can solve it. And the Xcloud platform itself would have to offer this option to delete the profile. In short, they don’t care.

Please Devs, Listen to our voice!

1 Like

Having the same problem on series x with the Thrustmaster Airbus captain pack, I can’t save profiles on the Thrustmaster but I can save with the controller or a mouse.

2 Likes