XboxX sim not working

The Sim not working anymore, as not connecting to internet. The store is greyed-out, and I can’t do a new flight, or load a saved flight.

I uninstalled and reinstalled everything, and it worked for a day. Same problem today.

Other games on the Xbox X connect fine.

I get the WARNING: you are currently offline and do not have optional offline files installed.

When I hit Exit and download offline content, get the following: Something went wrong.

What the heck happened? Do I have to uninstall and reinstall the entire game every time I want to play?

Check to see if “Online Functionality” is set to "ON under General Options > Data


That fixed it. Thank you!

Why did it change to off?

This will automatically switch OFF if there’s been an issue with connectivity while playing - such as your internet dropped or the servers dropped or any hiccup along the way. :slight_smile:

Thank you very much!

I appreciate the assistance!

1 Like

Sorry to post this here but don’t know how to start a new one but does anyone know how to fix this ■■■■ issue I’ve tried everything I know how to do

Hello @N2O4LIFE1990,
I’ve moved your post into this topic as it may be the same issue. See my post above:

As a new user, you will not be able to create a new topic due to a lower trust level. See this guide on how to advance:

Someone posted the fix. You have to enabled the on line settings in options menu.