Yet Another Strange Thing re: Loss of Controls

Not sure if this is an issue related strictly to VR, or not. After SU6, some people lost the ability to select anything from the top in-flight menu. It was suggested to make a key command “Toggle Instrument View 10”. For some reason, doing this allowed the menu to work. I assigned mine to my X56 trigger. The problem was fixed either by a fix update or SU7 (I forgot) and you can now access the menu normally.

However something I noticed remains. With certain aircraft (and maybe all of them), I noticed a loss in rudder/nosewheel control when taxiing. Hitting my Saitek pedals did nothing.

Also, I think there may be a few other systems affected by this also, but I am not sure.

But if I hit the original key command I had previously set up for “Toggle Instrument View 10”, rudder and nosewheel control are immediately restored.

I have seen some posts elsewhere from baffled pilots wondering why they now have no controls working. Perhaps this will help.

I have remarked that if you open atc menu and your mouse is over it, I can’t do anything with my joystick. Moving mousepointer away, everything works again. this with al topmenu’s…


Oh ok, I got ya. I just tried making a flight in the FBW A320. I had no throttle or rudder control. I hit the trigger button I mentioned above and my view jerked to the left 90 degrees (this is Rift S VR). But the throttle and rudder worked. I hit the button again and my view returned to normal, but I lost throttle and rudder. So I get these two choices, looking left or having a working throttle/rudder pedals. This does not occur in the Baron 58 and Cessnas which I fly regularly. And Im on PC version. Guess I’m going to go play DCS.

Same issue here. I have hardware throttle and steering wheel . They become unresponsive (steering wheel buttons only) if I click in any menu windows like VOR or towser communication. I have to click with the mouse into the cockpit to get them responsive again.
Very annoying!
I guess they did not QA the VR when they released the bug fix. I filed a ticket for that already but I’m not sure they picked it up.

1 Like

VR users are still second-class citizens.

Any time the mouse is focused on a menu in VR, it will kill the throttle and rudder controls.

Most of the time this happens to me while landing. Resulting in running off the runway. It’s one of the reasons I try to keep AI ATC turned on.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.