"You are trying to assign an action to a device that is not selected."

When I attempt to set up my Thrustmaster TCA quadrant to the Throttle 1/Throttle 2 axes, I get the above error - even though the device definitely is selected on the top of the page.

I have tried everything - unplugging everything else, unplugging the TCA flap/spoiler add-on, uninstalling all software add-ons, even a full uninstall/reinstall. Nothing has worked.

Anyone have any ideas?

2 Likes

I am having the exact same issue. Looking for solutions!

So in the default profile, the Joystick L-axis X is set as throttle 1 axis (0-100%). I can see the white line move left and right when I move the left throttle. However, when I try to scan for my left throttle on that function, I get a button press when hitting the first detent instead of it seeing the axis. So I get an error message saying im trying to assign an action to a device that is not selected…

I have downloaded the latest driver from thrustmaster.

Ok I unscrewed the plastic bumper module from underneath the quadrant that gives the throttle its detents. Still I get the error message that Im trying to assign an action to a device that is not selected…

  1. Have you tried creating s blank profile for it and binding the axes and buttons etc one by one to check and define their properties?

  2. You aren’t trying to bind a physical axis to a digital button are you? I’m not sure that would work without some complaint from the software.

*Each peripheral having its own compartmentalised config list and having to select the correct peripheral from the list to bind a function was a really odd design decision from Asobo. It’s a bit janky and harder to set up than simply having a single list of functions and all peripherals being available for binding within it.

1 Like

I have this exact problem. I am trying to re-map the throttle and I get this message even though the Thrustmaster is selected!

you are trying to assign an action to a device that is not selected

anyone have a fix
thanks
Josh

You can scroll further (to right) and see other input options.
“Joystic” is separate from “Throttle”
In case anybody is wondering.

1 Like

Having this with Bravo Throttle Quadrant… never had this issue before this update, but I haven’t tried to change anything since I got the Bravo… very confused.

You’ll get this if there is an active input from another device when you are doing the scan. For some reason they decided to scan all devices for input rather than just the specific device you are trying to map a binding to.
I get this with a 3d Connexion Enterprise spacemouse so have it on a usb switch so I can disable it when I want to scan for input.

Had this exact problem on two different Bravos (thinking it was a hardware issue until the new on did the same). What fixed it for me, was going all the way out to the desktop. Going to Control Panel–>Windows Devices–Bravo Throttle Quadrant–>Right Click on it to–>Game Controller Settings–>Click on Bravo Throttle Quadrant–>Settings Tab and then hit RESET to DEFAULT. Fixed it straight away.