Your last session of Microsoft Flight Simulator ended unexpectedly

After the installation of Microsoft Flight Simulator 6 Update,
And starting Microsoft Flight Simulator the image below appears
I have already tried many different things to fix this and the message still appears on Microsoft Flight Simulator Startup

Your last session of Microsoft Flight Simulator  ended unexpectedly

i am also getting the same message, any fix?

I have moved this to Bugs and Issues since it is more likely to be seen there

Have you tried to move the contents of your Community folder to another place? When you installed WU6 did you empty the community folder before installing

If removing the contents of the community folder works and you can start normally then you can return your community content one at a time to find which one is causing the issue

hmm i emptied the community folder before the installation of wu6.

Install was fine no problems there, even startet the game ones new after install without any community stuff and boom got the massage.

There was no crash involved what so ever, i just closed the sim over the menu like you should with no ctd.
But i still get the massage every time i start the sim, as said even with an empty community folder.

Than with my mods in the community folder (and i have a lot of stuff like 220gb or so) i get the message at the start but i face no crashes what so ever.

Even after SU5 i just had crashes when i move the map, where you plan your flights, to fast.
Other than that not one single ctd.

Same now with WU6 the game runs without problems the map crashes are gone too and i use the community stuff till now without crashes, but still the message at the start appears.

I mean its no problem just one click and its gone but its funny when it tells you you crashed when its not true^^

Before I update Microsoft Flight Simulator I move all files from the Community folder to a different folder on my had drive.
I also close my Flyinside Heli Manager.
There was no crash during Microsoft Flight Simulator Update Version 6

Theres another thread about this already. I to have no addons and it doesnt matter how I finish the flight, next time I run the game the old safe mode box appears again. Its the ‘Press any Key’ screen all over again. LOL???

2 Likes

Chances are good that the sim experienced an error during shutdown…

In Windows Explorer, goto:

C:\Users\%username%\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState\

And delete the file “running.lock”

Next startup you won’t get that message anymore.

2 Likes

Thank problem for me to Community 16go!

How do you exit MSFS after a flight? Are you using the Quit to desktop option in the main menu? You should only get that message after an abnormal exit.

So I went to try this and looked for

C:\Users\%username%\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState\

No Microsoft.FlightSimulator* dir at all at that location. So I searched all drives on the system for a file called running.lock. No such file on the any of my drives including sub folders that match of even come close to matching…

Thanks for trying but no cigar for you on this one LOL.

Always from the quit on the bottom of the main page. Doesnt matter if I abend the flight, make a flight plan and follow it to a T. Land in a grassy field, always the same thing.

I really really am starting to hate this GAME! It still runs fine, its just the stupid little window everytime I start. I should -r usercfg.opt and see if that changes anything maybe it just dont like LOD=10 settings in the cfg file…

Sorry. Are you MS store version or Steam?

We’ll get this. It’s bugging me too much to give up.

Edit - are you able to find the LocalState folder in your search?

When you start the sim and see this message what is the first thing you do, what do you click?

Do you select to CONTINUE IN SAFE MODE or CONTINUE IN NORMAL MODE?

@sttovo

I wonder if opting to run in safe mode and upon exiting the sim while in safe mode keeps this message appearing at startup?

Steam Version. I just cleaned the registry, and restarted the game, even though I have LOD=10 LOD was definatly not 10 so I went to appdefault/roaming/microsoftflightsimulator/ to edit useropt file except that it hasnt been changed…Started the sim again it still looked like hell, just killed it in task manager, went back to usercfg.opt to check it again, and now there is a lock file, so now Im gonna restart again and see what happens.

It seems kinda of strange that it was looking for that file that didnt exist wonder if theres a flag in the software that gets set, and for some reason .

Okay after testing again still same results, I deleted the lock file started the sim, watched it remake the lock file, and 2 screens later give me the safe mode screen again. I did notice that the sim is looking really bad at the moment, even with extended LOD’s from out of hopkins heading east just past downtown cleveland is a desert no trees bldgs etc. it looks real bad at the moment.

Guess its time to reboot modem router machine and see if that fixes my LOD’s…

Nope - I tried that many times. That running.lock file is the key. It doesn’t seem to clear out even if a normal session is exited. I just finished creating a Task in Windows to delete the running.lock file every time MSFS crashes. Working great for me, haven’t seen that message since.

I’m so sorry, I’ve not seen that happen in my case. Once I delete that file that message is gone for me. Grrrrrrrrrrrrrrrrr. I’ll keep messing with it and if I find anything new I’ll report back.

I’m now getting it constantly too. It was fine yesterday, now every time I start the game this pops up even though all is ok. I haven’t had a single crash with WU6.

Another for the bug list as it appears to now just come up at random.

Seriously guys (@sttovo @BubbaBlitz7348 ) I would check your system reports. If you keep having this pop up the sim is detecting an error…

1 Like