Beachcraft Bonanza terrible autopilot

That may be the case, I have no idea why it only happens with the G1000 though.

I did some small amount of testing and found that my experience with VS mode being broken may be tied to attempting to use FLC mode during that flight. I haven’t scientifically tested the VS mode in the past like I have the FLC because it is an intermittent problem with VS and I don’t remember if during those flights I had toggled FLC or stalled during a climb or something. It appears that using FLC mode permanently ■■■■■ the AP for that flight for me, meaning even with ALT, FLC and VS mode disabled, having recovered from the 100% pitch issue enabling AP at any point will trim me 100% for the rest of the flight.

I have had flights where I have recovered it, through sheer mashing buttons, enabling different AP modes, enabling and disabling the flight director, turning AP on and off repeatedly, manually removing the trim each time it sometimes eventually stops trying to take me on a 1 way trip to meet God.

Same thing here, very frustrating.

I’ve had the same thing happen, and have discovered that if I hand-fly to my proper course direction and stabilize the climb, then engage the autopilot, it seems to work every time. If I take off, raise the gear and hit the autopilot, it will often crash.

AFAIK, that is how most GA autopilot systems work IRL. The aircraft has to be hand-flown to the proper attitude, pitch, etc prior to engaging the AP. Please correct me if I am wrong.

This I can’t confirm on my side. I always use FLC to climb and VS to descend, never had any issues.
I (like some others suggested) always hand-fly the departure until I’m stable in the climb and on-course of GPS when enabling AP.

To avoid the sudden climb, use FLC not with a pre-set speed but simply engage it with the current speed during climb and then, if required, dial it back in increments which will gradually increase pitch to match the speed.

That works well for me, while I don’t want to say that the way you use it is wrong. It’s just a hint how you could have a more comfortable flight.

Also I have the G36 mod installed, it changes some performance values and might also have impact on the behavior.

Just Check the “Known Issues” Site:


  • We are looking into the bug reports and will provide additional information.

the autopilot doesn’t work for me in any propeller plane. i think we just have to wait for the next patch. i’m currently flying without an autopilot. (i know that this is not a real help) :wink:

Having worked on and installed autopilots in the past, you are generally correct about GA AP systems. They’re not like airliners or jets designed to be engaged very shortly after takeoff. In the GA world the systems are not typically sophisticated enough to null out large control surface deflections and you’ll sometimes have systems attempting to max out elevator trim and disconnecting the whole AP.

I have yet to try this out in the G36 to see if it works the way I would expect it to, but then again I’ve never worked or flown on anything with avionics like the G1000.

It is also good pilotage to only engage the AP once the aircraft is in its stabilized climb (trim included). I tend to only ask autopilot to hold what I’ve done, rather than genuinely fly the airplane for me; I’ll do the majority of my pitch changes by hand, then reengage the system so I can focus on other tasks. In the real world, autopilots are often finicky and break kinda frequently, so you learn to use it as a pilot aid, rather than depending on it to fly for you. Like cruise control in your car, it’s nice to have, but you shouldn’t need it to drive on the highway.

I’ll also add how I use the FD/AP in the 172:

On the ramp, I’ll set my altitude, runway heading bug, enable the FD, and set the FLC for the enroute climb airspeed. The command bars activate and frig off to somewhere. I’ll line up, takeoff (using Vx or Vy as appropriate) and get to at least 500’AGL before I start looking for the command bars again. Once I’m at about pattern altitude, I’ll nose down to get my enroute climb airspeed (matched up with command bars by this point) and engage the AP. Then I’ll move the heading bug to fly me to the route, only engaging the NAV once it’s almost perfectly lined up.


It has been said by many that FLC is iffy at best. Try using VS and pick a moderate climb rate to start. If you have power to spare, then increase. If you notice your speed dropping, bring the nose down.

Tried it again, making sure I did as suggested.

As I said: stabilized climb at 600 fpm and 95 knots with elevator trim at about 5% up - hand flying with almost no pressure on yoke in a steady climb. FLC is set for 93 knots when I engage AP (in outside view so I can easily see % elevator trim) - the trim INSTANTLY goes to 100% UP and VS zooms to about 1800 fpm. AP tries to bring nose back down but speed bleeds off so fast that a stall warning sounds within a few seconds.

This scenario DOES NOT OCCUR when I put the plane in an identical climb profile but first engage the VS at 600 fpm and then engage the AP. As soon as the AP takes control at 95 knots & 600 fpm VS - I SWITCH from AP/VS to AP/FLC (93 knot target) and it works perfectly - the nose goes up a tiny bit to pull the IAS down to 93 knots. After that - FLC works just as I expect it to.

1 Like

I haven’t had any issues with the default aircraft AP following the GPS except the Bonanza. It does the same for me and it’s frustrating.

Ditto for the Carenado C182. The AP in HDG mode is screen door on a submarine useless. Does exactly the same thing. I regret having wasted my money on that steaming pile of manure “premium” add-on.

dont set lvl mode on the ground. only engage any autopilot modes while already in the air, this isn’t how its done irl. this is pilot error. I will make a clip of how it should be done

I am flying from KLGB to KMCC in the G36 right now (with the performance improvement mod, but that shouldn’t change the AP behavior that I am aware of). Preset NAV mode and FLC at 100kts, altitude bug to 8000ft before takeoff but did not engage AP.

Took off, got the plane established in a climb at ~110kts, and hand flew a heading with my intersecting GPS NAV course at a shallow angle. Engaged AP just before the intersection. AP captured the NAV heading and pitched up to the 100kt FLC climb speed, then climbed to 8,000 ft and leveled off.

Later I wanted to climb a bit to get some more separation to some mountains. So I set the altitude bug to 10,000, punched in FLC mode again and set it to 100kts. AP pitched to maintain the 100kt speed and leveled off as expected at 10,000 ft.

After clearing the mountains I decided to descend back to 8,000. Set altitude bug to 8,000, selected VS mode, -500 fpm, and decreased throttle a little bit to maintain a constant speed. The AP descended at the requested rate and leveled off at 8,000 ft, at which point I increased throttle back to the original cruise setting.

I planned this flight in LittleNavMap using Victor airways, AP has had no problem following all heading changes at intersections. (Via GPS, not using actual VORs)

I will say I had very poor AP performance in all aircraft back in August immediately after launch. This seemed to be related to having the manual trim mapped to an axis interfering with the AP. I mapped them to 2 buttons instead and the problem went away for me at that point.

It seems like not everyone is having the same experience with the sim, so I’ll admit this is just my experience.

I do think that Asobo should provide a manual explaining the operation of the default avionics and any way that it differs from the actual real-life Garmins - especially since the Garmin implementations are missing a lot of features, which makes it unclear if a given feature is implemented, not implemented, implemented differently from the real thing, or broken and needs a bug report. If anyone else shares this feeling, please consider upvoting this wishlist item that I created asking for official documentation - Add a 'Learning Center' or other official documentation

Correct, this seems to be pilot error. I’ve never had this happen.

Try this. No autopilot modes should be set on the ground (including LVL) This seems to be pilot error in pretty much all cases from the descriptions I am seeing here.

I always set it to NAV and FLC with the climb speed of 100kts on the ground and simply engage once I have a stable climb.
Never had any issue with that, so I don’t understand your general rule.

Just what my flight instructor taught me.

Yeah, but I don’t think setting up the AP on the ground makes it misbehave, so the bug isn’t originating from when you set it up.

I don’t use autopilot until I am in the air and stabilized. It always seems to work good from there.

Ok so are people using the G36 mod and the Working Title G1000 mod? Because I’m using those two and have no serious issues.

I am only using the G36 mod. Have not installed the Working Title G1000.