Blessed are the ones who dont get CTDs

You never know Salem. Could be. I’d remove it and test as well. At least check the bios to see how much bandwidth it is sharing with the EVGA3080ti FTW3.

I’ve disabled it as a hardware profile and uninstalled drivers/software and it made no difference. It shares no bandwidth with the 3080Ti - it’s via Chipset on that slot, the GPU slot has 16 dedicated lanes to the CPU. I guess it’s no effort to fully pull it (at least when my collarbone is healed, I can’t hoik PC equipment about with ease right now). I did also consider the capture card as I’ve seen others have issues with the capture one codec/.dll which is why I disabled it in device manager and uninstalled the software - I mean, it shouldn’t have an impact, but if it does, it does.

The QVL is interesting - since I consulted it at time of RAM purchase and the specific kit was listed! Note they’re now showing 4 stick configurations only, which is bizarre and likely the reason for so few kits being listed and them being so slow. I’m well aware through the communities I manage of DDR5 being a bit of a pig at the outset, but it’s improved markedly. MSI’s QVLs suck, that list really doesn’t give you much of anything since they’re not making it clear the differences between 1,2 and 4 stick kits. 4 Sticks of DDR5, basically nothing runs at the moment.

Pangoly still shows the original QVL list and my RAM is listed

And it’s also shown compatible with the Motherboard on G.Skills QVL list

Despite the above; It’s stable. It’s stable through Memtest 86, it’s rock solid in 4 months use, literally no other stability issues, and I do know what unstable ram looks and feels like since I OC RAM for fun and profit. The sim exhibits the same fault with XMP enabled and disabled. Obviously it being a memory fault, memory is your first concern, but this is (I maintain) A code error (code not keeping track of it’s variables properly - see here and not a hardware memory fault which are WAY more evil, and impact every aspect of a PCs operation. If it is, somehow a hardware fault that only fs2020 picks up? Well, I guess there’s a first time for everything.

One of the sentiments I resent is that FS2020 is somehow ‘special’ and touches hardware that other software simply can’t reach. I mean, it’s true to a degree because it does appear to crash with far more hardware or software environment configurations than anything else. But that doesn’t mean the hardware’s the problem. The single common thread is the flight sim itself.

Ultimately: If it’s the audio codec on my motherboard (Or associated software), the NIC on the motherboard (Or associated software), some other component I, and the others experiencing this fault have (Or associated software), or just ‘something else’… Once you’ve done the list of quick known fixes, I don’t see this as my problem any more. There are other past-times out there. It’s an Asobo problem.

It may be an Asobo problem to fix, but it is still also a “problem” for the MSFS USER., who may not want to desert a sinking ship.

But at least the MSFS user has an option to fix the Problem : – switch to XP11 / XP12

1 Like

Hey WeirdNeville.

Can you tell me when the crash occurs? Does the sim actually make it to the main menu? Or does it happen when you try and load a flight? Let me know. Thanks.

I must be luck to be one of the Blessed Ones – touch wood …

Oh…I can vouch for it. Has been a roller coaster for me - very unstable at the begning then couple of months of stability and completely unusable since SU9, cant even go past the donut screen that checks for updates. Tried everything right from cloud profiue reset to drivers to peripherals to getting the sim in vanilla state - nothnig works.

Can you tell me when the crash occurs? Does the sim actually make it to the main menu? Or does it happen when you try and load a flight? Let me know. Thanks.

At Random: In menu occasionally having done nothing. In Flights from 5-30 mins. I’ve had it be stable for 3 hrs, several bush trip legs, then crash, or not crash at all for a day. It’s rare (-20% chance) I complete any given bush trip leg.

If you genuinely want to know what I’ve tried for this particular phase of crashes on my main system.

GPUS: Swapped to RTX 3080/RTX 3070/RTX 3080Ti
RAM: Run XMP On/Off/Single Sticks/Tried second RAM kit
SSD: Run from C: (OS drive) and second dedicated Game Drive
USB: Removed all extra USB devices. Set USB to nbever power down in power states. Swapped Joysticks. Tried different Keyboard/Mouse.
Audio: Tried ‘same audio output’. Turned all sound off.

GPU: Rolled back to previously stable Nvidia Driver version. Tried other driver versions.
Audio: Uninstalled all Audio drivers/Additional software.
HAGS is set to off but have tried it on as well
Tried Watchdog Countdown Registry Fix
Uninstalled Occulus Drivers/Software

Turned all bing data/photogrammetry off.
Turned AI ATC voice off
Turned Onedrive Off

(My Sim is basically vanilla base edition: I have the Garmin NXi which I’ve removed for now, and the Bleriot XI and a couple of sailplanes as add ins, which I’ve also removed and haven’t replaced since last reinstall - those are the only mods I have, never run google maps, never used pushback toolbar or whatever, never bought anything else 3rd party)
Cleared Community folder
Run in Safe mode
Run with zero additional downloads (not even world updates)
Reinstalled twice
Run at lowered settings (to reduce GPU load)
Ensured Xbox App/MS Store is updated/logged in.
Tried different aircraft/locations/modes (Bush trip, free flight over city, free flight over middle of no-where)

Thing I haven’t tried yet but might:
Change CPU (I’ve got a 12600 knocking about that is stable in my test bench)
Remove capture card (A pain but when I’m healed up I might give it a go)

Things I haven’t tried and am not willing to try:
Reinstall Windows
Remove software essential to my work (Adobe suite mainly)
Swap out motherboard.

None of the above changes prevented the memory read error CTD.

Neville … honestly … ugh the bush stuff :frowning:

just go fly somewhere

I know, I’m kinda saying you’re having fun wrong … but give just simming a chance.

Edit: I only say this because it’s so often a complaint and it may well be ■■■■■■■■

1 Like

It’s exactly what I want to do though: Fly a route that’s been handed to me, discover some new scenery, get to know the aircraft a bit. It’s just how I enjoy the game. And sorry but It is a game to me!!!

1 Like

And that’s perfectly fine.

I’d actually advocate for a more progression based structure overall: I’d love to see a career mode whereby you start with a rented cessna and do mail drops and passenger flights, graduate to afford faster aircraft for time sensitive missions (organ transport??), can take on missions such as ferry flights (to try new aircraft without purchase) and pass training to open up access to big planes. You could end up demo’ing long haul routes as you build an actual airline. To me that would offer a really nice pathway to explore the riches of Flight Sim. The ill fated ‘MS Flight’ attempted something similar, a few missions anyway, and I enjoyed it and felt it would open up the hobby to a wider audience. But right now I just want the core fixed as a priority.

What version of Windows are you on?

Given everything you’ve tried it’s not the fame that’s the problem. Almost certainly something else on your system is causing the game to crash.


And yes, obviously it’s Something given others have 100% stability. I just can’t work out what and you can see by my process of elimination I’m running out of ideas! Decent crash dumps, fault logging/reporting would be nice.

I maintain that it is the sim that’s the problem: Simple conflicts, some random bit of hardware, USB disconnects, the wrong .dll, the wrong driver, some add-in that doesn’t play nice should not cause CTD’s. If they do, they hsould accurately report what is in conflict so the user can address it. No other software does this on my system. This isn’t the only system I’ve had CTD issues with (my old 10850K system, completely different, Win 10) went through 2 phases of this after Sim Updates, and were ultimately fixed by Sim updates.

I’m about challenging myself and my PC, I’m nearly had enough AM “ironbrew” to attempt LA to San Fran in the MD-82 … I’ve never read any of the manuals and the plane never stops buzzing at me but I have a blast.

Oh and it’s my Saturday, dont judge lol

Used to get a fair few CTD’s & BSOD’s before I upgraded my GTX 1070 8GB to an RTX 3060 12GB. Over a month since my upgrade & not a single CTD!

There is another 617 people topic on this same error.
In case anyone in here are interested.

MSFS Application Error - memory could not be read

Speaking of Heatkiller it’s like a molecular filter, I noticed my flow had reduced so I drained split and capped the system so I could sort of blow fluid through it backward and sure enough the heatkiller had a partial clog.

May have been hose fragments of even paper towel from assembly?

Going to break it down and open it up next weekend, sure the reverse flow only partially cleared it.

If you get a flow slowdown GentlestCurve98 be aware it’s probably something clogging up the CPU block.

1 Like

All is fine for me. Clean water, stabil flow (clean every 6-8months my systes) But thx

There is a small sieve (or better really fine finns) in the cooler. Maybe parts from a soldered radiator Rosin etc

1 Like

Yes the fins are so fine that you could probably add one to your home water and clog it in days.

Anyway, i like the Heatkiller. The best CPU Cooler in my Eyes.