Cannot start the sim. Nothing happens after clicking "Launch" button in MS Store

Hello, since January i cannot run the sim. After clicking “Launch” button in MS Store nothing happens.
Sometimes it starts but it’s very random and let’s say it’s 1 time within 30 tries. When it finally starts and I quit it to check if it will start again it does not start anymore.
I think it happened after the latest updated of the sim or after installing 20H2 windows update and it’s additional stuff(yeah, i did not update windows for a while).

I have latest updates of windows and M$ store.
What I’ve tried:

  • store: terminate repair reset
  • xbox: terminate repair reset uninstall
  • MSFS: terminate repair reset uninstall
  • Gaming services: terminate repair reset
  • Firewall: switched off
  • AV: turned off
  • sfc scannow
  • DISMM commands
  • Reverting windows updates
  • Reinstalling microsoft store
  • Restarting PC
  • Full reinstall of the sim:
    ** game on drive C:\ and data on other drive
    ** on other drive game and data

After i click the “launch” button, sometimes i see the process in task manager but the games does not start and has 6000 K of memory usage when normally it has 300 000 K / 1 000 000 K.

I’ve read some topics that issue can be related to windows 20H2 update, but also people were mentioning that gaming services are the reason.

I have no idea what is wrong and how i can fix it. Can anyone share some advice?
The worst thing is that when it starts it happens randomly so i cannot provide/use some steps to be able to always run the sim :frowning:

Thanks in advance.


11days ago you wrote:

it’s seems that it works well now.

Strange thing !

And why, realy why ?! , the issue reporter IGNORE the issue template !

Now I have to ask you abut your System Specs !

1 Like

Maybe it’s because it’s still full from having a big breakfast? :rofl:


I wrote that it seems, but it was just a good luck, after the reinstall sim Has started, then ive Turned off the pc. After running it back again sim still worked. Ive wrote the post, but later that day it has started again to not Launch.

I5 4690k gtx960 16gb DDR3 win10.
Do you need something else?

can you please check you windows virtual memory setting (pagefile ) ?

If not already tried, please change your setting as following:
Minimum Value: 4GiG
Maximum Value: 25Gig

Also ensure there is enough free space on your disc.


I know… I want to be only show you, that we need exact info’s within the issue reporting :wink:

1 Like

Did that, but it did not help :frowning: I had pagefile set to “system manage”. I’ve changed it on C:\ initial size 4000MB and max size 25000MB. Made a restart, at first try MSFS process appeared in task manager but with only mentioned previously 6000K memory without launching the game, made a restart second time and this time nothing happend, no process no sim launch nothing.

True :wink: sorry for that.

What i can say more. I’ve tried to run msfs from xbox app, from start menu, nvidia experiance and from store. In all cases behavior is always the same.
I’ve checked also event viewer → administrative events. I’ve found some issues which might be related:

  • EventID 10016: SID (S-1-5-21-1559981577-3067427662-2071518969-1001) from address LocalHost (użycie LRPC) running in the application container Microsoft.GamingApp_2102.1001.17.0_x64__8wekyb3d8bbwe SID (S-1-15-2-1723189366-2159580849-2248400763-1481059666-1951766778-2756563051-3565589001). This security permission can be modified using the Component Services administrative tool.
  • EventID 7011: A timeout (30000 milliseconds) was reached while waiting for a transaction response from the WSearch service.
  • i cannot find it right now but i had something like: csrss.exe process is blocking flighsimulator.exe process.

Other side effects from not being able to launch the sim:

  • when i try to lunch it with MS Store and it won’t, sometimes task manager goes out of order and is not responding
  • when i try to lunch it with MS Store and it won’t, when i move to start menu and click msfs icon it does not respond, just like it would be disabled, start menu works well but after clicking the msfs icon it does not even collapse

PS: i have the sim launcher on SSD c:\ drive with 125GB of free space, and the whole ASOBO data on HDD f:\ with 2TB of free space

and to be more clear, i did not have any issues with the sim since i’ve been participating in beta from may 2020. I did not change any hardware too.
Only thing that i’ve made are the updates: sim, windows and drivers.
I did some cleaning on C:\ drive but it was before the clean install of msfs which i’ve done 11 days ago (my quoted post) and shouldn’t affect the sim(just a removal of old files/leftovers).

Oh and maybe one thing more, i’ve encountered some search and indexing problems after windows update. Start menu showed me few times that indexing is off, but i’ve fixed it and now i do not have this issue anymore.

hmmm… so the main issue since a while seems not the cause for yours…

If I understood you correctly, the application is started and works in background but will never come “on top” ( will realy start ) ?

Which kind of anti-virus protection tool you have ?

It depends, as i mentioned sometimes it:

  • it launches i see the process games starts and i can play, than the Memory in task manager is way above 500 000K

  • process starts, but game do not come “on top” and memory usage is only 6 000K(this value is very much the same each time, around >6000K)

  • nothing happens, no game on top, no process and task manager stops working, cannot be reluched etc. only pc restart brings back task manager

Eset nod32 antivirus. I did not have any problems with it previously, after those issues appeared i’ve tried to run the sim with:

  • device control switched off

  • real time protection switched off

bad things in mind… I remember me that this caused similar issue:

But if you already disabled real time protected … hmmm :thinking:

If you check the windows update page, is there an pending update ?

And can you try to disable windows Quick-Start ?

( open power energy settings => choose left “Choose what happens if you press power button” => Disable Quick-Start => save and Restart )

forgot to write about this one too, i’ve already did it. Fast startup is disabled.

want not hear that… because I’am running out of ideas :confused: :joy:

Yeah, me too that’s why i’ve wrote this post, as i did almost everything what i’ve found in internet :stuck_out_tongue:

I did not create a ticket on zendesk but do they replay fast ? or sooner we will get new sim/windows update than a response from them :stuck_out_tongue: ?

Maybe i should try also on microsoft forum? As this one seems to be related also to gaming services / ms store etc.?

do it… allways ! The support/devs can not be faster than a community, but your issue is “reported”.

I hope it has nothing to do with the graphics card… the problem is , that you changed more as one thing : new msfs release and also windows update.
You also tried to re-install the nvidia drivers ?

True, i was lazy, just wanted to get quick response. I’ll do it later today :wink:

No i did not, you think that i might be a good idea ? Alright i’ll give it a try :wink:

at least “a idea” :joy: … possible choose “completly re-installing” in installer menu

One thing you could do is to uninstall again, but this time delete the entire MSFS registry before re-installing.

You mean to:
Uninstall msfs with apps and features and then go to regeddit find flightsimulator entries and remove all of them yes? Later Store->download and install. And its all about the game 1.3gb not the data 130gb from asobo yes?

@GameBlogger3710 @MichaMMA none of you suggestion did not help :frowning: