Classic gauges lighting in VR

From the very little information I’ve found on this bug it seems to me that it may only affect index users. Can someone with an index try and report back? Or any headset for that matter!

I have a Oculus Quest 2 and can confirm that standard gauges flicker badly at night. The brighter the light setting the worse it gets. It looks like each side of the gauge has a black bar that’s a bit out of phase (Sorry for the Star Trek jargon) which seems to cause the flicker.

Both the stock C172 and the Just Flight Piper PA28 Turbo III/IV suffer from this. The GNS530/430 do not have the problem. It really stops me dead in my tracks from enjoying evening flights.

Ok! So it’s not limited to the index! Is anyone flying with gauge lights on at night in VR??

I flew the Arrow III at night earlier today, the gauges were flicker free no matter how I adjusted them - I was trying to get a good balance with the red cockpit light so tried various brightness settings.

That was with a G2. Hope you find a solution.

EDIT: The JF PA28 III and IV have just received an update. No listed fix for that issue but perhaps it may help?

I applied the update but the same issue appears. One thing I did notice is that the further away from the panel the worse the effect got. At about 6" from the panel the effect isn’t noticeable.

It’s frustrating because I’d love to do some night dusk time VR flying in the piper or other gauged planes.

1 Like

Index user here as well. This issue has been bothering me since day one. I entered a zendesk ticket about it several months ago, but I suspect that it is such a low priority issue that it won’t get fixed, at least any time soon.

I don’t have this issue in G2 on Piper or other analog aircraft.

Well the problem has gone away. I flew two wonderful night/dawn flights with the panel lights at about 50% brightness and the red overhead at its first notch of brightness. It was very nice!! No black vertical bars in my gauges. If I really look I see a whisper of a dark bar at the very top edge of some gauges but like I said, I am really looking for them. As I pull my head waaayyy back (almost sitting in the rear), I start to see some bars. But still no where near what I was seeing before and not really vertical like they were before either.

I can’t be 100% certain, but I believe that I solved it by switching on VSYNC on the PC side and setting my frames at 30. I’ve noticed that the VSYNC will sometimes be off after a reboot of the game and I simply switch it back on (Just like the PC render scale will drop to match the VR side after a reboot). I’ve tried to make the vertical bars come back by switching VSYNC back off but they seem to be gone permanently. It’s like the act of turning VSYNC on again did something to realign the rendering of the lighting on those gauges in VR.

I tried this, not for the gauges particularly, but because of a post in the 200% PC render trick thread. (I perhaps should cross post into that threat as well… this all seems related… cross talk between PC and VR graphic settings)

I’m having the very best performance, visual quality and satisfaction in flying in VR ever.

I’m able to set my render scaling to 90 to 100 and get very smooth performance inside and out of the cockpit. My GTN 750 inside the Piper Arrow III is nearly as crisp as my monitor. All my gauges are virtually perfect and the outside terrain just moves smooth as smooth can be. This is with HIGH clouds and Live weather.

I set my PC render scale to 200%, turn on VSYNC and set it at 30

SteamVR: SS 124 (tho I’m not convinced it’s actually doing anything, but I trust CpLucky8!), frames locked at 30 with 33.3MS prediction.

RTX 2070S / AMD 3600X / Latest NVIDIA Drivers / HAGS off

1 Like

well the solution is SteamVR FOV scaling… At 100 or 95 you see bars, at 90 no more bars (slight horizontal at the top depending on how close or far away), drop the FOV to 85 and now you have full on Horizontal bars… so the solution for now is to run SteamVR at 90% FOV…

Actually 126 is slightly better but just a small tad.

If the 27th release permits, TAA 100 + SS 152 + FOV 95 + FS2020 Textures ULTRA should be much better with the Index. (I’m running 90hz/18fps/33ms though on 9700K+2070S)

If you can afford it, TAA 100 + SS 300 gives you the same details edge to edge as TAA 100 + SS 126 + FOV 50!

That was a typo! I’m actually running 126…

I’ve tried the 18 FPS lock with motion smoothing. It’s good! But the small distortions I get when looking out the side through the window break it for me. My current settings are really good for me. Many thanks to your suggestions! It’s so good in fact that, although I’m very much looking forward to see what the July 27th update brings, I’m not overly anxious about it.

Could you confirm my FOV at 90 for the lighting in the classic gauges compared to 95 and 100?

I suspect us Index users are a minority over here!

Cheers!
Matt

Do you mean this type of bug:

  • Jump into the 787 at night
  • Light up the glare shield
  • Notice the rendering problem with the light cones over the glare shield

I didn’t try comparing changing the FOV or whether this affects the Index only though. Good points to cross-check!

In the meantime, I don’t believe I have a solve for your question, but related to it, here are topics about night lighting you might want to check out to see if you agree with:

Airliner exterior lighting bug - Bugs & Issues / Virtual Reality (VR) - Microsoft Flight Simulator Forums

This appears to be what I’m experiencing. It corrects itself when I reduce the FOV to 90. Anything higher gives me vertical bars and anything lower (85 or so) gives me horizontal bars.

1 Like

SU5 didn’t fix this light banding issue for me. I’ve had it since day one. I resort to turning the gauge lights off and using the head torch or overhead lights. Not ideal.

Using Valve Index.

Did you try changing your FOV to 90 in SteamVR?

Not yet, but to be frank that’s not really an acceptable solution to me. I’d rather use my current methods than restrict my FOV any further.

Oh I agree 100%! But it does point to where the problem is. And it does allow me to fly at night in VR. An added positive to reducing my FOV is that it allows me to raise my render scale in game without impacting performance.

FOV doesn’t change anything for me with the Index.

Can you please see the screenshots here and see if you can repro the same:
[BUG] Shader code ‘viewdir’ and shadow/light rendering are inconsistent on right eye - Bugs & Issues / Virtual Reality (VR) - Microsoft Flight Simulator Forums

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.