Clean install display drivers massively improves VR performance!

Hi simmers, been struggling to get the best out of the OpenXR tool, the reprojection wasn’t working well and had to set graphical settings to low. All that has changed with the revelation below that my Nvidia graphics driver installation was massively holding back performance - doing a clean install has improved matters no end.

I had actually discovered this by mistake as I was solving a random blanking out in VR while watching movies, so @zooze74 gave me some tips on clearing out my Nvidia drivers and that has changed everything.

For reference my system is an Intel 9900K @ 4.3Ghz, Asus 2080Ti, 64 GB RAM and I can get a solid 30fps with smooth visuals using reprojection and mixture of high and medium settings with 70% OpenXR scaling and MSFS scaling at 70% on the HP Reverb G2 and it’s looking pretty clear. Reprojection still has artifacts but it doesn’t seem as bad now and it definately improve frames, even without reprojection doing a clean install makes a significant difference.

Not saying this will work for you but if you have been messing around and are still unhappy with performance you might want to try the following steps.

Clearing out old Graphics Drivers

These are for Nvidia but should apply to AMD as well.

  1. From Add or remove programs type in nvidia and uninstall all drivers and applications. You might need to restart your system several times for this to work.
  2. Remove you graphics vendor installation directory I.e. for Nvidia the default was C:\NVIDIA.
  3. Open Disk Cleanup and select Clean up system files, check all boxes - ensure you check Direct X Shader Cache.
  4. Optionally remove any temporary files from C:\Windows\Temp and C:\Users\{USERID}\AppData\Local\Temp.
  5. Download and install your vendor driver. For Nvidia I used 452.06 as this was optimised for MSFS, more recent drivers have introduced a little more stutter.

OpenXR Reprojection settings

MSFS Graphics settings

Again thank you @zooze74 for the suggestion and tips for a clean install of the display driver. Thank you also to @CptLucky8 for the excellent analysis in VR. Also @mac2244 I hope this technique also improves reprojection with the OpenXR tool, before this change reprojection for me wasn’t even an option.


Excellent guide. Followed it today on my i9-10850k, 64Gb, 2080Ti machine and VR in the G2 is much better. Individual values are going to be personal choice I guess, but getting OpenXR 70% scaling but with reprojection turned off anbd MSFS scaling at 90% feels about right, e.g. when turning hard while looking out the side window no longer makes me so giddy feeling.

Rolling back to the 452.06 driver gave the biggest gains for sure.

Excellent :+1:t2:

1 Like

I notice this in a lot of post where people are setting the OpenXR render scale to 70% then having the in game render scale at 70%. Isn’t that 70% of 70% == 49%?

It is all explained in great details, and more, here:
My 2070 SUPER VR settings and suggestion (Reverb G2 - WMR)

1 Like

For me OpenXR at 70% and FS Render Scale at 100% seems to give me stable frames and a nice looking cockpit. I can notice the degradation when running 70 and 70. I’m on a Kingpin 3090 though.
Interestingly enough any time I set FS Render scale to 80% the game crashes.

interesting post not time I update my drivers might give a reinstall a go.
actually I got a significant increase in fps from the last patch and running it now with reprojection off - runs very smooth with no jitters and my fps is around 30-40 (note I found the game changer for me was setting the rendering in OXR to 50 but leaving rendering in game to 100.
never got the reprojection to improve on this - in the OXR frame counter I was jumping between a red and blue screen - with full motion reprojection on then it would jump to depth reprojection on with lots of jitters - not sure if its bug or my 2080ti was struggling to run it…

What driver version are you using for your 3090?

Version 457.30. Maybe a little better FPS

1 Like

I tried running 70/100, huge mistake,it basically locked up , wouldn’t let me toggle in and out of VR, just sat there in WMR. couldn’t get control of mouse. had to shut FS2020 down with task-manager. Set it back to 70/70 and all is good but with a bit of smudgy cockpit graphics but certainly playable. I can always lean down and read the glass cockpit. I have a 6800K with a 2080Ti, which certainly is no Kingpin 3090. I have my OpenXR set to the “Automatic” setting as opposed to disabled, could that have caused it? Or should i go to something like 70/80 or 70/90 or would that even handle it… I would hate to keep shutting it down with task-manager in fear that I’m going to corrupt something and have it start doing CTD on me. By the way, when I’m in game, my CPU is not maxed out but i noticed the GPU was pegging up pretty high like 89 to 95 percent at times (70/70) . My 6800K CPU is running at 3.9999 GHz and I’m running the game on a Samsung Pro M.2 SSD w/32GB RAM. ALSO, and this is a big ALSO. After running the game for longer flights 30 min. or so, i get a freeze up (computer is NOT froze, i can click and run anything on the desktop) in MS FS2020 only and it takes about 1 minute or longer for it to come out of the freeze, but if I wait, it always comes out of the freeze. Could that be that I need to clear the Shader Cache or would that just cause even more problems? What else could i look at to possibly lead me to the answer on the freeze ups? It’s starts to do that freeze up more and more the farther I’m in to my flight sim sessions. I’ve looked at other processes that are running…just can’t figure it out. Maybe i’ll look at task manager during the next freeze and see if the GPU is clocked at 100% ? or CPU, but I doubt it’s CPU since I can do anything I want in WIndows 10 during the flight sim freeze out.

doesnt removing shader cache requires long load times and for the cache to build up over long periods before things would get back to normal before removing the cache?


where can i find the openxr Setup?
I take the oculus openxr and where is the point to change From 100 % to 70% openxr render?

I have Setup in olucus tray Tool fov to 0.7 0.7 and in game 80 % rendern.

where can i find the openxr percent Setup?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.