Cockpit Darkening When Looking Out Window

sounds like you mean the human eye adaption… may try to disable in UserCfg if you not like these kind of realism ( set to 0 )

{PostProcess
	Enabled 1
	EyeAdaptation 1            <----------------
1 Like

Yes there is, go into appdata/roaming/microsoftflightsimulator and open usercfg.opt with a text editor.
Now scroll the a bit until you see post process effects section, leave that set to 1, below that you will see a bunch of other selection on of those is eye adaptation set that to 0 and that will get rid of that effect. You can go farther down that part of the list and eliminate dirty windows, lens flare …

Here this is how I have mine set:
{PostProcess
Enabled 1
EyeAdaptation 0
ColorGrading 0
Sharpen 0
Fringe 0
LensDistortion 0
Dirt 0
LensFlare 0
FilmGrain 0
Vignette 0
LensBlurMultiplier 0.000000
FringeMultiplier 0.000000
}

I have had mixed results with just setting postprocess to 0, so any more I leave that alone. As always make a backup copy of this file 1st just in case you screw something up ;p

1 Like

Try disabling Bloom in your graphics settings.

1 Like

@N6722C

Maybe you could share this part of the starter batch file? It still works perfectly. I‘m not at home for the next hours unfortunately.

The problem is that the eye adaption part in the usercfg.opt resets all the time.

1 Like

I tried it and the value is not reseted in my case…

Can you check what you have in this part in your uscfg file ?

{Graphics
Version 1.1.0
Preset Custom <--------

Later. I‘m not at home atm.

Or you can set the +R (read only) bit on the file and you’ll only be able to make changes when you turn it off.

I like this option better because I can experiment in the menu settings an no matter how bad I mess things up, it will always return to the I know this works settings everytime…

1 Like

I’m on Xbox and don’t have the ability to alter any files. My only option is to leave the game hud on screen as well. Kills the immersion a bit but at least I can see what I need quickly.

1 Like

I just tried this, but unfortunately, even after setting EyeAdaptation to ‘0’, nothing seems to change. The panel still darkens when moving the viewpoint up, and lightens when moving the viewpoint down. I have checked to make sure that the cfg file is not resetting, and it is not.

I think the issue with that may be that @Ephedrin87 may have his backup file in the same folder. I did that at first, and renamed it to ‘usercfg_Backup’ and it kept resetting. Moving the backup to my desktop resolved the resetting issue.

i would like a setting for that too(on/off), its overdone.

2 Likes

Well the only other thing that I did other then make changes to that file, was to select YCbCr422 in the NVCP and change the bit depth from 8 to 10. There was a thread along while ago about this and that for some reason rbg didnt render the correct way, and the solution was ^ this. Try that its a two step process
go into NVCP / Change Resolution / and down under where you set your resolution is another set of boxes, select use nvidia color settings, then select YCbCr422 and click apply, after that in the same spot goto output color depth and choose either 10 bit or 12 bit (12 bit looks better in 4k) and click apply. and then run the game again and see if it makes a difference…

Here’s my entire usercfg.opt file incase you want to try it out:

Version 66
{Video
Adapter “NVIDIA GeForce GTX 1080”
Monitor 0
Windowed 1
FullscreenBorderless 1
Resolution 3840 2160
FullScreenResolution 3840 2160
PrimaryScaling 1.000000
SecondaryScaling 1.000000
PrimaryScalingVR 0.800000
SecondaryScalingVR 1.000000
VSync 1
HDR10 1
Raytracing 1
PreferD3D12 0
PosX 1
PosY 0
}
{Graphics
Version 1.1.0
Preset Custom
{Texture
MaxAnisotropy 16
Quality 0
}
{SuperSampling
SuperSampling 2
}
{Terrain
LoDFactor 4.000000
}
{OffscreenTerrainPreCaching
Enabled 0
Quality 3
}
{ObjectsLoD
LoDFactor 3.000000
}
{Shadows
MaxSliceCount 4
Size 2048
DLightContributionCullingThresholdS0 0.100000
DLightContributionCullingThresholdS1 0.100000
DLightContributionCullingThresholdS2 0.100000
DLightContributionCullingThresholdS3 0.100000
OmniContributionCullingThreshold 0.000000
}
{HeightFieldShadows
Enabled 1
Size 1024
}
{SSRaytracedShadows
Enabled 1
Quality 3
}
{Water
FFTSize 512
}
{VolumetricClouds
Enabled 1
Quality 3
}
{VolumetricLights
Enabled 1
Quality 3
}
{ReflectionProbe
Size 256
}
{SSR
Enabled 1
HalfRes 0
Quality 3
}
{WindShield
Quality 0
}
{SSAO
Enabled 1
Quality 3
}
{AA
Enabled 1
Type 2
}
{Bloom
Enabled 0
}
{DOF
Enabled 0
Quality 3
}
{MotionBlur
Enabled 0
Quality 3
}
{Buildings
Enabled 1
Quality 3
}
{VegetationLarge
Enabled 1
Quality 3
}
{VegetationSmall
Enabled 1
Quality 3
}
{TextureSynthesis
Quality 3
}
{PostProcess
Enabled 1
EyeAdaptation 0
ColorGrading 0
Sharpen 0
Fringe 0
LensDistortion 0
Dirt 0
LensFlare 0
FilmGrain 0
Vignette 0
LensBlurMultiplier 1.000000
FringeMultiplier 1.000000
}
{VectorDataTessellation
Enabled 1
Quality 3
}
}
{GraphicsVR
Version 1.1.0
Preset VRDefault
{Texture
MaxAnisotropy 4
Quality 1
}
{SuperSampling
SuperSampling 0
}
{Terrain
LoDFactor 1.000000
}
{OffscreenTerrainPreCaching
Enabled 1
Quality 0
}
{ObjectsLoD
LoDFactor 1.000000
}
{Shadows
MaxSliceCount 4
Size 768
DLightContributionCullingThresholdS0 0.100000
DLightContributionCullingThresholdS1 0.100000
DLightContributionCullingThresholdS2 0.100000
DLightContributionCullingThresholdS3 0.100000
OmniContributionCullingThreshold 0.050000
}
{HeightFieldShadows
Enabled 1
Size 256
}
{SSRaytracedShadows
Enabled 0
Quality 0
}
{Water
FFTSize 128
}
{VolumetricClouds
Enabled 1
Quality 0
}
{VolumetricLights
Enabled 0
Quality 0
}
{ReflectionProbe
Size 128
}
{SSR
Enabled 0
HalfRes 0
Quality 0
}
{WindShield
Quality 1
}
{SSAO
Enabled 0
Quality 0
}
{AA
Enabled 1
Type 2
}
{Bloom
Enabled 1
}
{DOF
Enabled 0
Quality 0
}
{MotionBlur
Enabled 0
Quality 0
}
{Buildings
Enabled 1
Quality 1
}
{VegetationLarge
Enabled 1
Quality 1
}
{VegetationSmall
Enabled 0
Quality 1
}
{TextureSynthesis
Quality 0
}
{PostProcess
Enabled 1
EyeAdaptation 1
ColorGrading 1
Sharpen 1
Fringe 0
LensDistortion 0
Dirt 0
LensFlare 0
FilmGrain 0
Vignette 0
LensBlurMultiplier 1.000000
FringeMultiplier 1.000000
}
{VectorDataTessellation
Enabled 1
Quality 1
}
}
InstalledPackagesPath “D:\SteamLibrary\steamapps\common\MicrosoftFlightSimulator”

Yes, the Preset Custom is the key to making it stick !!

I’ll package up my latest version of the Startup Splash Screen & auto edit program, and post it here. (It always makes sure that Preset Custom" is present )

MSFS Launcher.zip.pln (70.0 KB)

Its all TEXT, no exe… look at it and use it at your own risk

Works great for me, and you can easily add any other program you want to load BEFORE MSFS runs.

Note: It does make consecutive backups of key config file each time it is run. If you don’t want that, just delete that part of the script, or occasionally go and delete the backups.

Note: You will have to edit the scripts to put in your own users USERNAME, as well as a few edits if you are on Steam ?

1 Like

Would also recommend a filter aka Nvidia.
Made the sim so much better for me: crisper, lighter outside and inside cockpit, got rid of msfs’s yellowish tint etc.
Much more akin real life lighting, where msfs is
way too dark when sun is low, (overcast) cloud layers - could barely see instruments in the Arrow(s).

1 Like

I knew it wans not just my 66 plus eyes but if I start messing with any files I am sure I will end up turning on the oven or shutting off the microwave .

1 Like

Just turn off Bloom in the graphics settings under the general option.

Thank you I may still need to see an eye doctor but turning off bloom helped a great deal.

just to be sure: also dont forget there are two areas in these file … “Graphics” for 2D and “GraphicsVR” just for VR.

exactly this was what I want to check… an additional script should not be necessary.

1 Like

There is a wishlist to add a setting to turn this ON/OFF:
https://forums.flightsimulator.com/t/instrument-readability-cockpit-too-dark-eye-adaptation/309363

2 Likes

Interesting, didn’t know there was a separate VR section. Perhaps, I was accident checking that. Will check when I get home.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.