Consistent CTD, Suspecting terrain issue

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Brief description of the issue:

Consistent CTD Flying low over mountains between PHNG and PHNL particularly at (or near) Pali Hwy peak (Nu’uanu Pali Lookout). I suspect a terrain issue, in real life there are a couple of road tunnels in the area that may be having issues rendering correctly in game. From what I “can” see, before crashing, the highway looks pretty mangled. Issue is repeatable for me, same CTD, in same area 4 times. First 3 flights were made in the H135, last attempt was made in the Bell 47G.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Flying low over peek.

PC specs and/or peripheral set up if relevant:

10700K CPU, 32GB ram, Radeon 6900XT GPU.

Build Version # when you first started experiencing this issue:

Listed in pictures.

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

In addition, before my last attempt, I did delete my terrain cache. Made no difference.

This particular CTD, so far, seems to be limited to a specific area. These CTD “error codes” seem pretty generic and uninformative. I’ve seen the same code for random CTDs that I’ve had in the past several patches back. Unfortunately, the only useful information is the Bucket ID and whatever data was sent to Microsoft; however, only the developer has any insight on what it means if they actually dig into the report that was sent.

hmmm… often the users see the “grammar” message within the windows event log message.

May be you can post the exact coords, possible with VFR map screenshot, where its happens. Then we can retry and check whether its similar to the grammar topic.

1 Like

21.366133401956944, -157.79407966812798
Google map coords.

Thank you for finding that previous post. Not seeing the same event viewer path/grammar error as he did though.


thanks for sharing this.

I tried it and can confirm that there is a issue.

  1. if I try to start at the given coords
    => MSFS freeze while loading
  2. if I start neary by and fly into direction of these point
    => MSFS freeze ( no CTD, but freeze and needs to killed per TaskManager )



Tried with H135 and Cessna 172SH.

Own Steam too, but I assume issue is idendepend of that.

And, because of the “freeze” it looks not exact same as the grammar reports, but may be is caused by same reason “issue with terrain”, as you mentioned.

Ps: you can vote for your own bug :slight_smile:

1 Like

Thank you, again, for taking the time to verify this issue.

It also doesn’t seem to be limited to this point. I have also had issues flying a mile or 2 directly west of the area on the south side of the mountain; however, the point I have given is quite consistent.

My system does freeze for a second or less before CTD. I’m guessing this is just how the differences in our systems handle the issue (AMD vs NVidia for example).

Hi guys,

I’m unable for the moment to check this one out on my system but I have a suggestion.

Try flying towards the said location at different altitudes. Maybe we can gain some valuable information that way.

Cheers Mark

Normally I fly though there around 1500 to 2000 (for the visuals and to clear the mountain pass). I tried flying over that point today at 4000 feet and it still CTD for me. After 11 CTDs with different gaming settings and different planes, it starts getting a little frustrating. :slight_smile: Feels like I’m just continuously flying into an invisible wall that crashes the game.

yep… thats exact the same as the grammar, we just not get the grammar - message :slight_smile:
@Boobbuster007 I tried also different altitutes.

We can only report that ( ZenDesk is important ) and have to wait. Thus, in meanwhile you can only avoid these area.

What I want to try next time is the older workaround for the grammar issue: lower the autogen settings from ultra to high/medium… If this helps, we know it is same root-cause :slight_smile:

1 Like

@SpYdR70 now I tried some test-cases.

If I lower the setting of Buildings to Low and tLOD 100 , I can manage the mentioned coords.
( my normal is : ultra and 190 )

BUT then I flew a bit longer in that area and I get first time a crash. Different message than yours,

ucrtbase crash

Name der fehlerhaften Anwendung: FlightSimulator.exe, Version:, Zeitstempel: 0x00000000
Name des fehlerhaften Moduls: ucrtbase.dll, Version: 10.0.19041.789, Zeitstempel: 0x2bd748bf
Ausnahmecode: 0xc0000409
Fehleroffset: 0x0000000000071208
ID des fehlerhaften Prozesses: 0x4d30
Startzeit der fehlerhaften Anwendung: 0x01d887e827c836bc
Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Pfad des fehlerhaften Moduls: C:\WINDOWS\System32\ucrtbase.dll

but I guess its not important. Its all the same root cause, similar to [grammer.pggmod].

I have also noticed some strange Bing Data blocks on the map too, which don’t seem to be present on the Bing Maps website (currently). Notice in one area where I have marked missing buildings (I may have crashed around there too). I don’t know how Building Autogen works, but I don’t think it helps to have building images cut in half or incomplete. Will look a little closer in game tonight and try with lowered settings.

1 Like

wow… yeah… you are right… my eyes not noticed it, but these blocks are also on my screenshot of the map. That can be part of the cause…

Hi @SpYdR70

seems with SU10 there is no longer the CTD.

Can you confirm ?