Constant CTD every flight now (ntdll.dll)

surprise surprise restart the sim and a new error appears

cant even load a flight now



And it randomly coses again

1 Like

I’m dreading starting up the game today. Always feel heart in mouth “will it let me play today”. Even once loaded I’m not sure now. Got 5 or more CTD just during flight yesterday in some new planes I bought that I wanted to check out as well as some of this startup nonsense.

Gave up last night. Don’t know why your post got hidden.

If only the error messages meant something more precise we’d know where to investigate.

Desperately needs a logger to see if it’s a specific mod causing the crashes.


Exactly the same errors. Tried to start with- and without a flightplan, doesn’t make any difference. Also the music ‘hangs’ and after that it’s over…
I’ll try the DDU-way, as I think it’s (probably) the newest displaydriver with a flaw… (516.94 WHQL)

Maybe… what version would you put on instead?

I’m starting to think it’s traffic related. The new thing I put on was the new Simple GA mod which requires AI Offline traffic and Ultra for model variety.

Before that I was running with no traffic for a few days and still got a CTD on my last session but they are more often now. Total mystery. Booting up now so let’s see what occurs today!

EDIT: …aaaand CTD on starting flight. 0xc00005 job

have you already tried to disable xmp mode in bios ?

PS: may be intressting for you might be these topic MSFS Application Error - memory could not be read

I had a surprise night off from work last night, and I sat in front of my computer with the insatiable urge to fly…but I haven’t flown in months because of the constant fear of CTDs. That fear turns my excitement into dread. I can’t enjoy my time flying when every stutter might be a CTD. I ultimately decided to do something else. I miss flying so incredibly much, but MSFS is unusable for me until I know for sure I’m not wasting my time prepping for a flight that I’ll never get to finish. MSFS is the only game or program I have problems with. I’ve run stress tests with no issues… I’ll try again with the next update, but it’s been several updates since I flew without fear.


Same here. I’ve never had a problem with CTDs before (like most people I’ve had the odd one now and then), but a restart has always fixed them. But in the last 24 hours I’ve attempted 4 flights with different aircraft, and somewhere between 20 mins and an hour into the flight, they’ve all resulted in a CTD. I’m not using the SU10 beta, so despite not having had any recent major updates, something seems to have changed in the last day or so. Hope SU10 improves things when it arrives.


The recent spike in CTD, also discussed at length in MSFS Application Error - memory could not be read btw, might be linked to the availability for download of the latest beta software, which is likely to have caused a bit of spike in demand on the MSFS servers.

How and why this seems to be the case is one for the devs, who to be fair, are apparently looking into the issue.

I have also had two CTDs yesterday, one halfway through a flight and one while loading. I do use the FBW and a couple of liveries, but I have had them for ages with hardly any crashes.

In a community we had yesterday three crashes and today multiple ones, all from people who had a stable MSFS so far.
I today had the first CTD for aboud half a year…
We are all on current release, not SU10 beta.
Some people get crash events in eventviewer, some don’t. Some get popups upon crash, some don’t.
My crash today was with nt.dll and had a different code (34 I think).

Something is going on and since we couldn’t find a common factor (installed software etc.), it’s hard to tell what it is.
Maybe some update of gaming services or windows that got rolled out? But I always install them manually hence did not update for some time now…


these one: ntdll.dll / 0xc0000374 ? …

Where I assume that have nothing to do with the “memory could not read” issue.

I’am since three hours in the air and no issue so far.

1 Like

Yep, I think that was it, here my exact position:

I will try another flight later on the same route to see if that was just a one-off.

There is definitely a spike in CTDs in the last few days, but can’t tell if they have a common source.

I must say that I have a lot of scenery, the Fenix, AxisAndOhs, GSX, Volanta etc. running. But apart from GSX nothing changed compared to the last weeks and months of flying with no issues…
Others experiencing CTDs in the last few days have a much more “vanilla” MSFS setup and still have the crashes.


that would be nice. I mentioned here that I knew these kind of CTD from a map issue and if you get same CTD at same location we can be sure :slight_smile: But may be there are other reasons. At least @Kassadgla now know, that he is not alone.

1 Like

I had no issues since I bought the game but since August 16, I am experiencing CTD’s all the time. I first repaired, then reset, then uninstall and re-install, to no avail. I have only the PMDG in the Community folder and always a CTD a few minutes later during setup. About to give up and hope SU10 miraculously solves the issue. It does noy make sense on why all of a sudden, the sim has become so unstable.

@chrisross106677 Try
Rename exe.xml to exe.xml_copy
Delete file named content.xml

Rename community folder to community_copy
Create an empty community folder.

Launch msfs.

Also delete and turn off rolling cache.

This is odd but I too am having CTDs now almost every flight over the last couple of days too. Same as others, ntdll.dll and 0xo0000374. Its really irritating! Even in safe mode it crashes. Public Build SU9 on PC, W11 Nvidia GC RTX3080 with I9 9900K CPU.

I have even tried new Community Folder, no peripherals, just keyboard & mouse and AI pilot flying and still it crashes. Its now unusable for me.


Same here, almost nothing changed, and yet, since yesterday, I have CTD every time I try to fly.

1 Like

Same for me. Last week I had 8 BSODs on a two day weekend. I solved them by rolling back my NVIDIA drivers to 516.59.

Now, this weekend I did 2 flights so far and had 3 CTDs … Something weird is going on.

Finally! I’m so glad you started this post. Been having similar CTDs for the last couple of days (starting on the 14th, I believe). Before that the game had been running smooth for two years. I haven’t changed any hardware, the CTDs just appeared from one day to the next. Running the game on Win10, SU9, current Nvidia drivers. Admittedly I’m running a lot of addons via MSFS Addons Linker. I’m also playing with a lot of programs in the background - Little Navmap, NeoFly, AAO, FS Hudbar, FSRealistic, Simple Traffic, Pushback. Controller-wise I have my Logitech throttle and quadrants plugged in as well as a Behringer Xtouch and head tracking via iPhone. But none of these are new and the whole setup had been running without problems up to now.

At first I encountered constant CTDs as soon as I hit the „Fly“ button - but after removing all the addons (renamed community folder) and deleting content.xml and restarting in safe mode I got the game to start flights again. Now I have random CTDs, so can never know whether I can finish a flight or not. When I don’t have a crash, I’m encountering stutters which seem to be related to terrain loading or sth like that. They are a new “experience“ as well. Don’t know, whether they are a “light“ form of CTD?

So, long story short - is there something we all have in common? Or is it sth based on Microsoft’s side?