Control Preferences Not saving --- Really frustrating, looking for solution --

First off, I filed a bug report on this already.


  • I set up control and camera presets for my keyboard, yoke peddles and mouse for most frequently flown planes (152, 172, DA40 and DA62) and saved them as such.
  • Each flight I go into controls and switch the profile to the plane I am going to fly, apply and save.
  • I load up the flight, and NOTHING works per the presets previously saved.
  • All my preferences from buttons, camera, sensitivities, etc are not applied or they are forgotten

Now, here is the really frustrating part, the camera settings are mapped, the positions for those cameras are “forgotten”. Button One on the Honeycomb yoke I use to return to my default pilot view, for example. When I look at preferences, its there as the correct saved camera location, but that actual location is forgotten and I have to set it up again.

For the other control options on keyboard or yoke, they are just lost. Those settings are not saved period. Same with sensitivity adjustments, deadzone adjustments, etc.

I’m beyond frustrated with this at this point, it makes it so I don’t want to fly as I have to spend too much time remapping things based on my hardware and preferences. I can deal with the P.O.S. default camera views and its “smart” features that suddenly have you viewing the insides of the roof or co-pilot seat at random, as long as I can snap back quickly. (I don’t know what triggers this yet, probably a double or tripple mapped key somewhere I can’t find)

But having to re-set up my yoke every flight… I am at my wits end…

I can’t be the only person with this issue… I’m hoping someone has found a solution to this, as I have not yet been able to.



Sorry this sounds mega frustrating! I’ve been watching posts relating to controls pretty diligently and haven’t seen this specific issue appear very often. So I’m hoping there is a way to find a solution for you. I know it’s annoying when someone asks “have you tried”, but we kind of have to start there to see if we can narrow this down! Bear with the “fishing expedition”, these are just some related issues that I’ve seen come up over the last week or so …

  • Did you download from Steam or the MS Store. Can you backtrack and make sure your login’s are all correct and working properly? The control profiles are directly linked to your gamer account / MS account and sometimes people have had their accounts get switched.
  • This one will get me a ■■■■■ look, but have you fully exited the sim and rebooted the PC? Controller profiles sometimes take a couple of cycles to “stick”. Shouldn’t be that way I know!
  • Are you running any external controller calibration or management apps? These sometimes interfere (and sometimes don’t).
  • Specific to your Profiles, if you click on a controller at the top of the Controls screen, can you scroll through your different Profiles for that controller? Sorry for being obvious but I’m trying to verify that the base level custom Profiles are getting saved. When you look at the binding assignments section for the screen, do you see any of your custom bindings at all?
  • When you are creating custom mappings for an input (button, key, control axis), are you also deleting any existing bindings for that same input? MSFS allows you to assign multiple command bindings to the same input. This can create crossed input conditions and some pretty bizarre behavior.
  • Similarly, when you are creating custom bindings, are you doing it by manually Selecting the Input number from the drop down list, or are you using the Search By Input box and physically triggering the input on your controller?

You sound like you understand the process pretty well, so there’s probably nothing in these that you don’t already know, but I have to throw them out anyway. Let me know what happens (if anything) and we’ll take it from there … Rick

1 Like

Thanks for the feedback, response:

  • MS Store. Am I logged in? I would assume so, the account is the same for the app as it is here. I typically use steam, went out on a limb, and tried MS Store. :wink:
  • Yes, this has been an issue since launch. Multiple reboots of everything between now and then.
  • No, everything is plug and run, no 3rd party software needed for my Honeycomb Yoke or Logitech rudder pedals.
  • Yes, you can switch through. They are labeled by plane type, and the naming/saves SURVIVE the restart of the application, but the settings don’t. The camera is the biggest offender by far and has to be re-setup EVERY SINGLE TIME.
  • Its extremely frustrating you can tripple+ bind controls… that’s a huge oversite. That being said, I “THINK” I cleared the second, third etc bindings, but its very hard to know for sure. I have not found an easy way to check without slogging through EVERYTHING.
  • Varies. ctrl+alt+<#> for camera location saves. Then set the memorized camera location as the input on the stick. (Save location one, joystick button one move to saved location 1) For controls, I’ll find the control I want in the list, then press the button to assign where I can. They key-switch being the expectation on my honeycomb. This has proven to be -programmable in that manor.

Slogging through the over-complicated control layout isn’t the issue as much as nothing survives and application restart, or even a re-load of planes.

The camera overall needs to be completely re-done, but I am not the first to have issues with it. :slight_smile: TrackIR or VR is probably the best solution here IMO.

Also, I submitted a feature request to load profiles automatically based on planeload. (Tie them together) Which wouldn’t help here anyway as the settings don’t save?

Spent some time experimenting with this more to try and find a solution. And in the process found more bugs, or if normal, very strange behavior.

Profile Manager:

For each device you can save customer profiles, which is neat. However, if you need to delete said profile, you can only do that once before you need to exit back out to the main menu before doing it again. The Delete button goes away after deleting a profile on said device after deleting a profile and staying in the controls menu. Changing profiles on the same device ,or going to another profile on another device the delete button will be gone. Dropping out to the main menu, then going back in to restores the button.

Default Controls (F12):

Same issue as above. After defaulting settings for a device, you have to drop back to the main menu before you can do it again.

Starting Fresh:

I wiped everything and started over. I created a new profile (just for yoke) by editing my controls as normal. Camera settings …… Sorta works. The views will snap back to the correct direction, but with a slant up or down or different zoom from where I saved. Improvement? Okay, I’ll take it.

This also goes for the snap left / snap right defaults. Snap left sometimes snaps more up looking into the wing, or more down looking at the door frame. Completely random… But when it chooses a certain way, it seems to stay for that flight.

Rest of the control settings (Keyboard dead zones etc) keep now.


Camera is still a bugged out mess, but the pre-sets seem to keep after wiping everything and starting over.

I have the DVD version. Despite uninstalling and reinstalling twice I am still unable to save my joystick profile. The joystick is recognised so I create a new one using the Preset Manager. It is NEVER available after. I have a ticket with MS devs but will not get a personal solution. Any ideas guys? Thanks