CTD - After 'checking for updates' on loading screen

Are you on Steam or Microsoft Store version?

Store

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.

None

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

I have only just got this game on the Game Pass, and haven’t been able to get on it at all. It gets to the loading screen after ‘checking for updates’ and then just crashes straight to desktop. Any help would be greatly appreciated as I cannot even get on the game to play it. I have bought a new joystick and throttle for it which is just sitting gathering dust at the moment.

I am sure I have played it before on this PC with no issues (sadly no restore points that I can go back to). I can play other games fine so I do not think it is a hardware issue.

Provide Screenshot(s)/video(s) of the issue encountered:

This is the following error report from windows:

07/10/2021 14:09 Application Error Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x00000000 Faulting module name: ucrtbase.dll, version: 10.0.19041.789, time stamp: 0x2bd748bf Exception code: 0xc0000409 Fault offset: 0x000000000007286e Faulting process ID: 0x2554 Faulting application start time: 0x01d7bb849a308742 Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.19.9.0_x64__8wekyb3d8bbwe\FlightSimulator.exe Faulting module path: C:\WINDOWS\System32\ucrtbase.dll Report ID: 96b4abee-e128-4f41-907d-ed01ef579f6e Faulting package full name: Microsoft.FlightSimulator_1.19.9.0_x64__8wekyb3d8bbwe Faulting package-relative application ID: App

Detail steps to reproduce the issue encountered:

I have taken the following steps to try and fix this-

  • Reinstalling the game (a few times onto different drives)
  • Reinstalling Windows
  • Installing Visual Studio (different years and repairing each one)
  • Installing US Language Pack
  • Disabling Audio Service
  • System Scans and Disk Scans
  • Changing Nvidia Settings
  • Updating all and any drivers (Inc GPU)
  • Probably more but cannot remeber

PC specs for those who want to assist (if not entered in your profile)

CPU - Intel Core i5-9600KF

GPU - Nvidia Geforce GTX 1050 Ti

RAM - 16GB

Motherboard - Gigabyte H310M S2H 2.0

PSU - Corsair CV550

I have Windows 10 21H1

Build Version # when you first started experiencing this issue:

1.19.9.0

Did you submit this to Zendesk? If so, what is your ticket #?

Yes #128590 - followed all their steps to no avail.

Hi,

at first, thanks for that very good issue report.

The keywords are " 0xc0000409 + ucrtbase.dll ". It seems you tried already a lot known things which cause that ( so far we know ).

things which I have in mind are

  • the Anti-Virus protection and may be Firewall. Have you tried to disable it ?
  • have you installed the xbox app ? … I remember something was bit special for gamepass users…
  • check to relogin in xbox , dont forget to restart
  • try to go offline ( check existing topics )

As mentioned we have some topics about these error combination.
As eample an older summary:

But we have also newer topics where users still fight with the issue. May be you find something usefully in that topics:
https://forums.flightsimulator.com/search?q=0xc0000409%20%20ucrtbase.dll%20%20order:latest

1 Like

So I have followed a post from looking above. I can load it while offline, but as soon as I plug my ethernet cable back in, it crashes.

also tried the re-login hint and installed the xbox app ?
( example: Ucrtbase.dll // need help / work offline but not online - #11 by mamiegrosbisous … funny… in the solution of that topic I wrote same as here in topic, the age is coming :laughing:)

I hope that helps… otherwise we are possible more by cases where we have accounting issue or cloud-settings under suspection ( but no solution ).

EDIT: and question: is the error message in case “re plug ethernet” the same …000409 ?

I have just tried logging in and then out and restarting and that has not worked. I am using the Xbox app that is correct.

Error codes remain the same when plugging the ethernet cable back in.

hmmm… may be is then a conflict with an existing setting.

You can also check whether you have Capture One installed or ProcessLasso ? And try to disconnect all devices (joystick,etc) when you start the game… but not sure whether it’s relevant in your case.
You have also no other addtional software installed related to MSFS ?

We have some topics about “works only offline”. May be all should merged together that we see how many users are affected and for which we find a solution and where not.

I have none of the two apps you stated installed. Tried disconnecting devices to no avail.

That would be a good idea to merge

I have fixed it!

Had to make a new Xbox/Microsoft account and then ran it on there. It has now loaded online!

1 Like

How can you run a game from another account?

Unsure. I just created a new account on another email. MSFS2020 was still there, loaded it up and it worked :man_shrugging:t3:

A kind of “accounting” issue we suspect also in the other topics, therefore these “re-login” hint.

But how you are able to bind MSFS to the new account, is a bit magic :laughing:

For info, the following thread is still open (and is now the main one) for reporting/discussing this issue further: