Default Settings every time I start the sim

Dear Community,

as of yesterday, without me changing anything, the simulator keeps reverting everything to default every time I start the Sim, even if in the previous session I had saved the settings and quit the simulator correctly, using the menus.

This means that every time I start the sim, the setup wizard appears asking me the typical questions (accessibility, graphic, control settings, etc.)

I have already tried removing the usercfg.opt file in the appdata folder, it gets recreated, but the behaviour continues.

This is extremely annoying, can anyone point me in the right direction please?

I have been running the sim always OK since the alpha version, so I am not understanding what is happening.

Help me please ! :slight_smile:

Thanks a lot!

2 Likes

Try changing the usercfg.opt by hand, and then save it, right click, choose properties, at the bottom of the screen there click read only apply and save, then try loading the simulator…

Even though I had FullScreen set in game I found that in the usercfg file it kept setting it borderless window even when I changed it in the file, after I added the read only attrib on the file it quit, the downside of this is that is you make a config change in game, it wont save to that file, so it will be gone unless you re-edit your file and make the same change there…BTW this got rid of my studders as well lol

Thanks for the hint, however I cannot believe this being a definitive and long lasting solution.
I am thinking if doing a clean installation would solve this…such tedious thing to do …

No one else had this issue?

Same started happening to me, only started today. All settings reset on each launch.

3 Likes

Same. Not playing until patch once again. Back to DCS. -_-

3 Likes

Same here! I suspect this early morning xbox gaming services update in windows update: since this update this morning, at every start of the sim fs2020 asks to set all the settings as it was the first time !

1 Like

Is this affecting also the Steam edition? I’m afraid of starting my SIM.

Don’t reinstall, it’s most probably global issue.

1 Like

That probably won’t help.
Most of your settings are kept in the cloud and are restored when you re-install

So this would mean several files are being reset to their defaults?

Have you tried restarting without an Internet connection?

There is a bug’s thread discussing this very issue.

Please continue all feedback in the bug thread to keep the information in one source.

For that reason alone I will be closing this thread for now.