Discussion: Update #4 (1.9.5.0)

Agreed … the whole Update system seems to be very “mixed up” and counter intuative.

Maybe Gamers are use to this, with other games updates, but without any clear instructions, and with it being so confusing & misleading, its always an ADVENTURE to figure out how to actually achieve the update.

Don’t know if it was doing it prior to this update, but the aircraft I’m flying a lot right now is the Bonanza G36 Turbo. At night, the empennage virtually glows.

Windows time is correct. I don’t think they are using Win time and that’s the problem I think.

image

Just an advice if you are putting time into posting crash log put down your hardware specs let them see on what system you run it on.

Also in Switzerland. Way to tall buildings in industrial areas.

Solved it. You also must update the japan update in the content manager!

The default sim provided database appears to be working fine, likely either a corrupt file or interfering file in the Community folder.

3 Likes

sorry for my English, you have to log out of Xbox and store and uninstall the Xbox app etc. and then reinstall it then everything works again.

Did they finally fix the awfull and bugy camera system? Or can I keep FS2020 in hibernation mode?

For me this update did some very appreciable things:
-might be placebo, or the scenery, but the loading was blazingly fast! Like 30seconds from flight planning window to being in the cockpit! It’s easily half the previous loading times
-good thing: now when you turn on the battery, the garmin system initializes instead of being immediately operational. That’s perfect for immersion (and i’d love to know if some are upset by the “press the rightmost soft key to continue” message :smiley: )

Did a small flight with the TBM, nothing to report, worked quite well but haven’t tested every system.

One thing to note, my MSFS has worked pretty well since the start, just a few CTD but nothing terrible. FPS have increased with every single update.

2 Likes

Hello,
And the approach, let’s talk about it also ATC is nonsense?
Try a landing on Gibraltar (LXGB) !!!
cordially

Just tried a flight from LSZB to LSZG. Half way out of LSZB i had a CTD. No message, nothing. Just a crash without notice. IVAO client was connected.

After update 1.9.5.0 for me:

  • Tall building fix - fixed
  • “Dolphin EFX” fixed
  • moving map CTD - on my system fixed. And before it could be solved by starting VFR Map when beginning the flight at let the VFR map always opened (or minimized). Than no CTD happened “on my system”* *) saying “on my system” is very important
  • Thunder and lightning still don’t fits to real live in some situations - but that was maybe not on ASOBOs priority list (?)
  • marketplace and contents manager was not working due to some liveries. Exchanged the livery’s by Mega pack 11.x helped and fixed it

For me some major bugs were solved. I read a lot of complaints here (like CTD etc.) but we all have to take into account: Please first check your own system before giving the fault and responsibilty to ASOBO Team. Often errors caused due to contents in community folder. And some users may not have there hardware and windows system up to date too. There are too many factors that may cause problems.

9 Likes

Tall buildings in much regions fixed but unfortunally not in my home village and homregion :confused:

I had many CTDs on my system, when logging into a flight with multiplayer and AI traffic set to “on” before Patch 1.9.5.0. I don’t know what have coused this, since my system is stable in other games. Tested yesterday and all CTDs were gone.

Loading times have decreased significally for me since the new patch.

Thank you Asobo! -> for me <-, the newest patch feels great. Looking forward for other fixes and enhancements.

3 Likes

LOL so it was you that edited my file, while flying yesterday, one of my ATC contacts kept telling me the vector to my next waypoint was ONE TREE FIVE… TREE really I was no where near New England! ;p

1 Like

Msfs has already somehow taken up over 500GB of my drive with minimal use of caching.

No thanks. If anything I think I’ll be uninstalling soon and circling back to it in 6 months when they finally admit their installer had all sorts of problems including gobbling up space the sim isn’t even using.

Yeah just checked your area and you’re right, that does not look normal and sucks. TBF I just checked my hometowns area (northern Germany) after the patch plus those on my world tour (currently central and eastern Africa, where other building types are used). In my area I’d say less than 0.1% of the buildings are heavily missplaced - all of them are logistics parks, barns, silos and remote food/drug stores. Most of them are decipted as Office/Living Buildings. But almost none of them are excessively high. Tought the issue would be fixed then, as all of them are just autogen buildings, same as in your area. :confused:.

Yah the patching process is just a shame, bought the Steam version as Steam offers the best speed and stability on my end when it comes to installing/patching. But now we have to download three different pieces of the game every patch (Core files, base game files, official dlc files) from three different sources. I even had to reduce my GPUs powerlimit, as it is maxed out during the patching process…

As usual, I didn’t have any problems, not even after that.
Well, it wasn’t all fixed, but there is still another day.
And let’s be honest, the whining here is enormous. Well, in terms of price, the Sim is not exactly a VW Polo, more like a Mercedes if you have bought a Deluxe and still everyone expects a Maybach for the price of a Mercedes.

Think of it as buying a cheap share, the longer you keep it and the more profitable the sim becomes. :thinking:

1 Like