Edinburgh flat and without buildings and houses

since that update they made to adapt the game to xbox I have problems, the city of Edinburgh is like this here, yes it’s on the ultra, yes the internet is working, no I don’t have any mod, yes everything is up to date and installed, yes I’ve already tried to clear the cache, yes I’ve tried to reinstall several times, yes I’ve tried to format it, honestly I don’t know what else to do to fix it

Steam version
9900k RTX2080 32GB etc…

This thread may be of interest:

There are reports in that thread of Edinburgh missing tiles of AI buildings (as well as other cities)
There are also reports of incorrect ai procedural buildings being rendered on other tiles, as “blocky” cuboids.

1 Like

I’ll check it out, but is there a solution for this?

Not yet but more votes would help

is ther ANY information that Asobo is even aware ot it? i’m following this since it happend and there is litteraly no info what so ever, neither SU, WU or even hotfix that this is known, under investigation let alone being fixed!? This bug renders the UK/Scandinavia world updates useless…


Also USA. Here a pic of Dallas

so this problem started for me after SU5, BUT if i remove the UK package the city goes back to normal, they are doing something wrong in these world updates

Hi @Rwy1964,
Please keep the topic related to Edinburg. Thank you!

Limiting conversation to simply Edinburgh may not be helpful to anybody if the issue is in fact something deeper in the general code.

Edinburgh is an example of an issue which is being reported as happening at least with UK and Nordic world update regions and could perhaps be global?

Although with regards that post of Dallas I’m not sure it exhibits the same issue (I know a lot more about how Edinburgh looked prior to SU5 and have no idea how Dallas looked)


I’ve seen some users reporting similar issues on Stockholm but haven’t tested the region