Flight Design CTSL brakes don't return to 0% with rudder pedal toe brakes

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.

done

Are you using Developer Mode or made changes in it?

no

Brief description of the issue:

The Flight Design CTSL in real life doesn’t have toe brakes or differential braking; the brakes are controlled by a single lever next to the throttle.

When controlling brakes via the left and right toe brake axes on my Logitech/Saitek rudder pedals, I’ve found that on this plane – at least since SU5, though I can’t rule out that it may have happened before – the brake lever doesn’t always release fully when I release the toe brakes. This causes me to slow down or stop unexpectedly during taxi, and have difficulties restarting.

Testing showed that the left and right brake axes behave differently: the left axis controls the highest 75% of the brake lever, while the right axis controls the lowest 25%. That is, pressing only the right toe brake all the way sets the brake lever to about 25% (modest braking power) and no higher, and releasing it returns to 0%; while pressing only the left toe brake all the way sets the brake lever to about 100%, but releasing it returns to about 25% (the high point of the other pedal).

As a result, if you use both toe brakes together “roughly evenly” but not exactly evenly, sometimes the brake will get stuck at 25% after you release the pedals.

Tapping the right pedal lightly and releasing it returns the brake lever to 0%, and allows you to continue taxiing.

As a workaround, one can assign one toe brake (or another axis, like repurposing a prop RPM lever on your throttle unit that’s not otherwise in use) to both left and right brake axes together. This allows them to combine together up to 100%, and release evenly back to 0%.

Also, using a lever next to your throttle instead of the toe brakes will, in fact, be more true to life! :wink:

Provide Screenshot(s)/video(s) of the issue encountered:

didn’t record them, but described above. can take videos if someone thinks it’s important.

Detail steps to reproduce the issue encountered:

  • connect Logitech/Saitek rudder pedals
  • configure toe brake axes to control left and right brake axes, either directly in MSFS control bindings or via a SimConnect input manager like spad.next (exact same behavior both ways)
  • load up Flight Design CTSL at an airport
  • taxi around and test both pedals carefully

PC specs for those who want to assist (if not entered in your profile)

  • Ryzen 3700X
  • RTX 2070S
  • Honeycomb Alpha, Bravo units
  • Logitech rudder pedals

Build Version # when you first started experiencing this issue:

Noticed in 1.18.15.0. I’ve flown this plane a lot before SU5, and never noticed it before, but I might have missed it.

Are you on the Steam or Microsoft Store version?

Microsoft Store.

Did you submit this to Zendesk? If so, what is your ticket #?

I did, but it just said my request was submitted successfully, I didn’t get a ticket number.

I’m having the same issue with my thrustmaster rudder pedals

1 Like

Same issue here and it only affects the CTSL since SU5, all other planes are fine

2 Likes

Still the same after today’s hotfix. Why does each and every update break something?

1 Like

I am facing the same problem. I usualy only fly with the cessna 172, 152 and the Airbus neo. All three of them have the same behaviour.

I have noticed that if I push the joystick button 1 ( for brakes) the toe brakes get reset to 0.

BTW. I’m using thrustmaster T.Flightstick X + T-Rudder.

I have not tested the rest of airplanes but have a feeling they will have the same behaviour.

I don’t think you’re having the same problem. The C172’s differential braking works just fine here.

Sorry I could not reply before.

I guess it is not exactly the same problem but differential braking was working just fine until the last update. I noticed the problem because after touchdown, I would push both brakes (right+left) and even after achieving rolling speed and releasing the brakes the plane would come to a full stop and would not move unless aplying full power. I tried the button on the joystick by chance and the brakes returned to 0%.

If I only use one peddal the other will not be affected. I mean this one will remain in 0% while the first will only return to around 25%.

It’s easy to see the brakes changing position in the virtual cockpit.

Thanks for your comment. I will report the bug and hope for a fix.

1 Like

I also have had this issue with my logitech pedals

3 Likes

Just stumbled into this recently as well with my Logitech pro flight pedals. Issue is exactly how OP describes. Still around after SU7.

3 Likes

Still happening which is a shame because its a nice aeroplane otherwise. Brakes stick on regardless of using pedals or keyboard or even mouse and in-cockpit lever. Gave up flying it 2 updates ago. Maybe Asobo can’t fix this one or I am sure they will have tried.

Same issue on my MFG crosswinds. Rudder work fine but toe brakes will not. Any help much appreciated

The problem with the Flight Design CTSL brakes not returning to 0% still persists after one year… :see_no_evil: :speak_no_evil:

3 Likes

Same here. Any news ?

No change afaik; I ended up assigning a custom profile for the plane in spad.next to run the brakes via a lever, which both works and is more realistic to the particular type. :smiley:

Also experiencing this issue. Don’t know what brand my RP are but it says Pro Flight Rudder Pedals. Maybe that is the brand or maybe Saitek?? I’m not sure. Don’t think it matters much anyways. It seems to be affecting all pedals no matter of the brand. Since the latest update is XIV and they still haven’t fixed it by now…I wouldn’t hold my breath on this one. Shame, it’s a nice little plane to put around in sight seeing

6 months later and I just encountered this problem.

There is not yet a solution to my knowledge