Freezing animations on aircraft at random

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Tried without addons. Still happens.
Are you using Developer Mode or made changes in it?
Brief description of the issue:
All aircraft animations freeze for random amounts of time. Just a second or two up to five minutes. The plane still responds to all control inputs, but the animations, instruments, flight controls, etc, are all frozen. The pilots disappear and the plane model go to some low resolution mode, too. Happens with any aircraft, but most often with A320, Cessna 172 and 150, and XCub. Happens with or without Mods.
Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
Fly any aircraft.
PC specs for those who want to assist (if not entered in your profile)
Intel 10700 I7 processor, GTX2060 card, 32gb ram, M.2 SSD with 600GB free. 250mb internet connection.
Build Version # when you first started experiencing this issue:
Since the first launch of MSFS2020, but then it went away until the last update. Now it’s back.
Are you on the Steam or Microsoft Store version?
Did you submit this to Zendesk? If so, what is your ticket #?
No, not yet. I believe this is a known issue. Since Asobo apparently cant solve it, Im reaching out to the community for help.

Experienced the same thing today. For the first time after updating to

I have that happen as well, usually after being out of the plane for a long time using the drone cam. It’s not just the instruments inside, flaps and gear also stop animating. I’ve had landings without any gear showing, plane rolling on a cushion on air. (Bonanza)

It clears up after a while, randomly.

Yesterday the multi function knob of the G1000 stopped working. I could still input destinations with D-> and dial in a code (same knob) but could not get the nearby airport list to come up anymore.

Random glitches happen often.

1 Like

Yes, agreed.

The thing that gets me is this used to happen very infrequently, so it really wasnt a big deal. Maybe once in 30 or 40 flights. Now it’s every other flight, and often several times per flight. Super, super annoying.

1 Like

Same for me since a few days, and I had never before this kind of issues

I’ve noticed this a few times, it’s been happening for about a month at random times, the prop on my Cessna stops rotating for up to a minute.

I had success today with disabling the Multiplyer (again), and I had no frozen cockpit anymore. It looks to me, that this helps, as I had this issue at all the flights since last update. Do you see this the same?

I have multiplayer turned off as always and get the frozen cockpit issue. It still can’t figure out what triggers it but it seems to related to heavy workload due to weather. It can trigger over land or over open ocean, but never seen it happen with clear skies.

There seem to be several stages, first the pilots won’t leave so the viewpoint is inside their heads, sunglasses floating in front of you. Outside plane animations are frozen then as well, but the dashboard still looks good.

At its worst there are holes in the dashboard (can peek through outside), nothing works anymore, temperature display is gone, screens are blank, very crude textures.

It often restores after a while or after landing, never permanent.

What I’ve had a couple times since the last update is that the G1000 nearby airport list won’t show anymore. That whole selection menu is no longer accessible, it simply doesn’t respond to turning the multi function knob. Entering direct to codes still works. This one doesn’t heal over time, once the nearby airport list is inaccessible I can only enter direct codes. A new, isolated problem since the rest of the cockpit stays fully functional.

I’m having the same thing with the XCub (BLL Mod). The 1.8.7 version, slightly older, seems to do it less than the newest. But, every flight, several times throughout the flight, this happens for 20 seconds up to several minutes.

Seems like this freezing animations thing has been going on for many months. How are there still no leads on this, Asobo?