FS Pushes me MS Store for update - Nothing there. FS Shuts Down

I’m having the same issue but I’m on Windows 11 22000.100 with the new Microsoft Store Preview so I assumed it was because of that.

Are you on Windows 10?

Same for me. I’ve rebooted multiple times, signed out of both MS Store and Xbox App, and ran wsreset.exe but nothing works

Same here. Maybe related to Windows 11? Once in the Microsoft Store it forces you to use the PC Xbox app to obtain the update, but nothing there indeed.

Same here kicks me to MS store no update

+1 (Windows 11)

1 Like

same problem

Add me to this disaster. WSRESET.exe, logoff, log back in, etc. Start the sim: “A mandatory update is required. Go to the Microsoft Store to download the update”
No updates waiting for me anywhere.


I went to the Updates part of the MS Store and nothing updated there. But when I tried to launch MSFS through the store it updated.

So the weird solution for this one is locate the FS listing for the latest update pictured below:

Click on the FS badge and then click play or install depending on what you see.
When it is finished (it is pretty quick) click on play.
Once you are in FS you will get the hot fix and hopefully be on your way to play.

NEO4316 BTW is the one who got me headed in the right direction! Thank you NEO

And yes I agree this is ridiculous to have to go this way for a fix.

where did you fine that page? and are you windows 11?

Was working earlier today. Now at 20:00 it’s displaying this modal box. I suspect there is something up with the update server maybe.

Same here. Kicks me to the store. No update in sight. Windows 10, latest version. I assume this is an update server issue. Now I can’t play the sim after a long week. Thanks MS.

Your installation/update process is pathetic.


This did not work for me…I just keep getting kicked to the store…

Maybe a solution.

  • disconnect your pc to internet
  • launch MSFS
  • when launched, reconnect you pc to internet and wait few minutes or seconds depending of you connexion speed.
  • You will see the updates available in content manager.
  • Launch all the updates (34 for me)

I don’t know yet if it will work cause updates are very slow but you can try this too.

1 Like

For anyone reading this thread, the solution here worked for me. No uninstall/repair required. See if it works for you.

that badge is in the windows store after clicking get updates it will show the most recent updates

in the MS store click on the FS Badge (follow my instructions above)

Will not update to hotfix for me either. Going to the game product page, clicking play there, forcing update checks, none of it will see an update available and won’t let me play. I’m starting to suspect they’ve pulled the update but forgot to remove the version check in the game. Fingers crossed they pulled it because another hotfix is imminent?

Same thing, same build.

I have the same problem. Does not Microsoft have Software QA testers before releasing updates?
I worked as Software QA Engineer, and every new build was tested, before releasing updates to clients.