FS2020 is not using all the GPU and CPU power in VR - Could this explain the low performance?

I was looking forward to the new VR feature in MS, but to be honest i’m very dissapointed with the performance.

Without the VR mode is able to run almost everything in High or Ultra (with a resolution of 5780x1080) and get around 49 frames in London in the air.

Current setup:

MSI Nvidia 3080
AMD 3700x
32GB (3200mhz)

When I switch to VR with almost everything on low (some on settings medium) i’m not able to get over 40 frames. Which is strange because the displayed resolution from my Oculus Rift is much lower, set to 1280x1075. I already installed openxr and played with the displayed resolution, but no results. Micro stutters and bad performance.

After an investigation I noticed in MSI afterburner that my CPU and my GPU are not used to the max anymore, which is not the case in the normal mode.

I know, it’s not DX12, so only one CPU core would be used, but most of the time my CPU core is between 50 or 80%, never 100%. Also my GPU is all the time between 50% and 85% of ultilization, so for what ever reason my hardware is never pushed to the limit. The GPU is used so badly in VR mode that even the fan’s on my GPU stops spinning, because there not generating enough heath :laughing:

Did somebody else noticed this aswell, because this could explain the (extreme) low performance in VR mode.

While I don’t have an answer to your question – in fact, my CPU (9900K) and GPU (RTX 2070) tend to be maxed out when playing VR, I am super curious what that LCD display is that you’re showing … Some kind of external FPS/CPU/GPU monitor?

Same thing here, my setup:
Msi 3080
5950, x570
32Gb (3600)
Reverb g2

I’ve been trying all sorts of things, (openXR/scaling/reprojection on/off, Nvidia drivers, steam etc, registry edit for the virtual monitors), but for some reason my GPU seems to not be utilised much in VR (max 20% in task manager), when I switch back to “pancake” mode, usage shoots up again. (In task manager view)
Performance in VR is atrocious. Especially for the high end systems I (thought I) have :slight_smile:

So no solution here, but at least we’re not alone :wink:

1 Like

I think this goes back to the “MAIN THREAD” issue. Most of us aren’t just CPU bound, we’re either core bound, or even thread bound if our CPU supports hyperthreading because that runs, and from my research must run, on a single thread/core. DX12 might help with that, but until then it’s just brute force… clock speed and IPC. AMD’s latest batch leapfrogged Intel on the IPC side, but if rumors are true, Intel will be leapfrogging right back with their 11th Gen desktop CPUs that are coming in Q1.

That doesn’t mean going out and buying a shiny new CPU unless your CPU needs it, and can benefit noticeably from it.

That’s also why your GPU isn’t breaking a sweat, because the CPU just isn’t feeding it enough frames to process that will make it do so. NOW, VR “helps” that because just having it on, regardless of if you’re simming or not, it consumes what is not an insignificant amount of resources from your GPU. Mine runs between 17% and about 26% doing “nothing” (which is not really nothing because at the least it’s displaying the cliff house or whatever that other “home base” is).

And all of the above is why people are buying 3080s or 3090s and not getting the performance bump they expected. To see a significant increase is going to require higher clocks, higher IPC, the ability to run the “MAIN THREAD” spread across threads/cores, or in a perfect world, all of the above. But until it can feed enough frames to your GPU to make it sweat, it’s not going to make that much of a difference.

Now, having said all that, is it just geek mumbo jumbo, or did I manage to at least make it understandable?


Since you’re using a 3080 and you’re forced using a Nvidia driver with known bugs in VR, you’re stuck until Nvidia makes corrections. However you can already get better perf in disabling MSI Afterburner (and any other similar tools). In addition you might want trying out an older Nvidia driver

NB: the problem with VR perf is not just single core CPU maxed out, it also has to do with presenting 2x views to the headset and this doesn’t linearly scale by the resolution. In effect, the GPU has to draw the same scene twice from a different angle. This means any cache optimization for the first view don’t translate to the 2nd one for example. On top of this there are synchronization limits to waiting before being able to ending 2 views at once. A low CPU and GPU use in VR is not because of bad optimizations, not always, it is most often because one is waiting for the other.



I have specs lower than minimum reqs for VR but looks like I’m having the somewhat the same issue.

My specs:

  • GTX 1070
  • Intel® Core™ i7-6850K CPU @ 3.60GHz
  • 16 RAM (2400 mHz)
  • HTC Cosmos Vive
  • Everything is on LOW in VR
  • Everything on Med in non VR (usually getting about 40-50 FPS with small GA planes and steam VR off)
  • All VR software beta(Vive, SteamVR, OpenXR)

On the screen above it shows that I’m limited by MainThread but only one CPU core is used at about 50%(rest cores utilized at about 30-50%). GPU is used at about 30%.

I’m always getting 18 fps in any glass cockpit plane (a320 - 18 fps, Cessna 172 G1000 - 18 fps) 766x500 rendering res (same super sampling res) - 18 fps. The only aircraft in which I was able to get about 30 fps in VR was Cessna 152.

Tried this awesome guide by CptLucky8. TAA option made VR look better and there is no stutters but still stable 18 fps with glass cockpit planes
After 3 days of trying if feels like I’m out of the options… (if anybody had same issue - please help).

On the other hand here is the screen without VR. GPU is 90% loaded, CPU is about 70% - it is clear to me that I have GPU bottleneck in this specific case - no questions here.

The only thing is left for me is to hope that current behavior may have something to do with MFS VR optimization and that something might change with Xbox release.

Thank you for your kind words! The locked 18Hz leads me thinking it is trying to lock to 72/4 Hz. I don’t remember the Vive options but what about cross checking whether you can configure it to 90Hz instead?

I had a windows developer look into it with me and he thinks there’s an issue with the way FS is utilizing the hardware. Even my machine is coasting…

R5 2600, all 12 threads are coasting at 60%. No one thread or core is even close to max.

GTX1080 running at 20% (yes, twenty) utilization.

32GB ram

SSD is on vacation. The line barely shows off the bottom of the performance monitor window.

I was looking into buying new hardware but it seems as if the hardware I have is, like everyone else, not being utilized to its potential.


Thanks for taking the time to reply and explain. It is not geek mumbo jumbo to me, but always good to check :slight_smile:

However, as also shared in the other comments, my CPU’s are not breaking a sweat either. At least from task manager perspective they are at 70%-80% usage.
However I will venture to investigate further wrt how fast the CPU can feed the GPU, at least I’ll learn something new out of this.

My suspicion is that the comment mentioning MSFS not utilising this particular hardware in the right way (for whatever reason) is the culprit however.


Thanks for the idea! Did some research about Vive Comsos refresh rate. From what I understand Vive Cosmos is locked at 90HZ and there is no way to change it.

not part of the topic

While I was going trough vive options I found ‘Motion compensation’ option. Turned it on and it works pretty well for me, looks like I found my temporary solution.
Link for anybody who gets interested

1 Like

This means in this case it is rendering at 90Hz / 5 = 18fps.

1 Like

Hi there I am in the same situstion stuck at 18 fps max in vr no matter what. Captain thanks so much for the guide and data. Ive been thru the guide and this site going on 4 days now. Here are my stats:

7940x cpu
2080 Ti
32 gb ram
Vive Cosmos
Steam VR
Bought from MS store

Most everything is on ultra including clouds with a few things on high. Ambient occlusion is off. Shadowmaps and terrain shadows set at 1536 and 512. It is limited by main thread, but occasionally limited by gpu in crowded turns. Interestingly, as i reduced cpu intensive features the main thread stayed at 18 fps but from the dev tool it showed gaps in the cpu bar charts that looked like it was waiting and doing nothing. As i reduced cpu options further I could see these wait states increasing in the cpu bar chart but fps stayed at 18. 'A bit maddening it is troubleshooting all this, but yeah major avgeek fun.

1 Like

Oh and the graphics driver that I am using currently is version 452.06.

It’s interesting, I don’t have this weird behavior, my hardware seems fully used… My GTX1080 is used at 100% in VR, all session long, with an i7 10700K stock clock working quietly, and 32GB RAM, and I have the Oculus Rift CV1, so “low resolution” at SS 100%.
I oscillate between 30 and 45fps. 45fps Interpolation ASW ON or OFF but Locked is my goal here, I can’t handle less, it make me sick.
To reach those 45 fps all is at low or off when available, but texture at ULTRA (no cost), TAA and Render Scale at 100%.

If I really want to stay at a rock solid 45fps I have to lower my render scale at 80 or below (I’m already low at 100 so it’s a no go) or uncheck the “Volumetric Effects” in options when you activate the DevMode (try this if you are GPU limited).

So taking aside possible optimizations from the devs, my hardware is fully utilized with my GPU at 100%, and my CPU having headroom.

Hey all,

This sounds familiar.
I also have bad utilization of my cpu and gpu.
When in non VR mode, my gpu is between 95 - 100%.
And cores 1-11 are 20-50% and core 12 is 60-85%
And it states that i am gpu limited.

When i switch to VR mode, everything drops.
GPU at 50-60%
And all cores are at 10- 40.
But it says my main thread is limiting.

I7 8700k 1080 ti 16gb.
No solution yet, and tried a lot with little to no difference.

Pretty sure with all the replys here that it’s not our hardware but is a software issue that we can not fix.

One commonality between gtaboncer’s system and mine is that we both are using Vive Cosmos.

Is there anyone else stuck at 18 fps or HMD refresh rate/5 who does not have a Vive Cosmos?

What graphics driver are you using gtaboncer?

Im using a Vive Cosmos with a driver or two behind the newest one. Im not getting stuck at 18 fps…

what i do find is that when i turn down the stuff that uses data, i get better frame rates
Also the holy 70TAA 220SS im seeing…and i mean im eyeing it…like 29-30fps. I want to say 40…cuz its really smooth but i gotta turn things down to like 50-60TAA.

totally agree with you, i mean i don’t have any of my 6 cores more than 40-50% and i can clearly see lot of “system” which usually means lots of wait state or hardware calls.
and i’m limited by main thread… will try an older nvidia driver just in case as seen in another post because performances are getting worse week after week for me., last week or 2 weeks ago i was 25 fps now i’m at 15-19 fps…

Same here. 7700k, GTX 1070.

CPU is at 50%
GPU is at 20%
in VR mode

What gives?