FSX Import Showcase

Update: Got textures to work :slight_smile:

22 Likes

Following this as I’ve been trying to import the FSX Goose with no success. Interested in knowing how you managed it.

I repeat, please share your process here. Even partial details would be incredibly helpful at this point.

4 Likes

I don’t know how SlinkyMate has done it, and would be very interested to hear that as well.

But I’ve had some partial success by creating a “package” of the FSX aircraft folder. Or at least something that MS FS will recognize. Basically so it ends up in a file structure like:

[MSFS dir]\Packages\Community
  klasbj-goose\
    manifest.json
    layout.json
    SimObjects\Airplanes\Grumman_Goose_G21A\

manifest.json and layout.json seems to be what makes it a “package”, containing some metadata and a list of all other files that should be read by the simulator respectively.

It seems to load the graphical model, flight model and main textures fine. Though I’m having quite a few issues with gauges not working (at all, it seems). It also seems to have trouble with (at least some) specular map textures.

I tried creating the packages using the SDK at first, but it didn’t seem to want to include all the files. In the end I created a program that copies a directory and generates layout.json since I didn’t want to do that manually. (Available here: https://github.com/klasbj/planeconverter, if anyone’s interested.)

Edit: To preempt some common questions:
You need to .NET Core 3.1 SDK to build the program. (It can also be installed as part of VS2019.)

While the program may have been somewhat ambitously named, it doesn’t really convert anything. It simply packages FSX structured airplanes so they can be loaded into MSFS as is. Most aircraft have some issues, e.g. it appears that only 3D gauges work, since they don’t use a generated texture.

It’s currently unlikely that the program will see further development as a converter, as I don’t see how it could resolve any of the issues I’ve seen so far.

12 Likes

How do you use this app ? utter noob at this , but no exe inside

It’s just the source code, you would have to build it yourself. It’s not currently in a state where I would be comfortable releasing a built version. It moves and deletes things on the file system, and I can’t guarantee that it won’t delete your entire C: drive or somehow manage to burn down your house :slight_smile:

3 Likes

@ChronocidalGuy The post below your comment has pretty much summed up the process. The XML file in the model folder you just add the mdl file instead of the gltf. I had issues at first with it not appearing but I’m pretty sure the case was not adding the right format in the XML. The package manager itself does not process the textures, I think that’s due to the package manager looking at the gltf file and reading the texture names which it cannot access the mdl file due to support issues. So you have to manually add the entries into the layout.json.

The gauges do work on the aircraft i ported but they are bugged which I haven’t looked in-depth yet on what needs fixing and if it is possible to fix them.

Do you know what you changed to get over the “not appearing” issue?

That’s what I’m hitting no matter what I try, up to and including copying other stock gltf files included with the sim. Nothing will appear in the hangar, no matter what I change.

I don’t even care about textures, gauges, or even animation, I just want to know how to get a plain cube model to appear in the sim as a starting point.

@ChronocidalGuy I’m pretty sure it was just a simple xml change.

Added both to a pastebin due to formatting. Just separated them with -----. :slight_smile:

1 Like

I wish anything here would work for me, but it’s just refusing to cooperate.

Making the directory list of files for the two .json files does look like an annoying thing to complete, but the problem is, that shouldn’t be required if I’m using the default SimpleAircraft, should it?

All I want to do is take the working SimpleAircraft, and get it to load a different model. That’s it. My model.cfg and xml references are all working fine, so long as I use the default aircraft model, but the instant I try and point it to another file (either .gltf OR .mdl), the sim goes belly up, and I get an invisible aircraft.

I have the same problem , i used the converter above to convert whole fsx airplane folder like eurofighter or other , then put them on community folder , even tried to mess with themodel .cfg , copy pasted all you written here , but cant find simple aircraft.xml , and nothing appear in the sim , I guess im just a noob at this i have zero knowledge, willwait for a detailed tutorial <3

What an amazing work.

So, there’s a nice big fat “Gotcha!” in the file structure of the SDK.

There are two duplicate sets of “Package” files. One just labeled “Package”, with the other named “PackageSources.” The source file is the one you have to edit before anything changes.

Once I did that, my exported gltf files seem to be importing just fine, just without any animations or textures yet.

I’m going to mess with the stock FSX models some and see if they perform similarly.

On the positive side, it appears the 2020 engine really does prefer polygons to textures… that X-Wing is a CGI-level model with 300k+ polygons, and everything modeled in, running silky smooth.

9 Likes

The package folder is what the package tool creates after export. I’m pretty sure the temp location is the same folder where you built from. So yes, you’ve been editing the compiled build it seems. Good to see you sorted it! :smile:

1 Like

I guess the screwy thing is that it changed in the first place without a rebuild? I edited the model xml reference in the main sim program folder, and pointed it to a different model, but it choked, but editing in the pre-compiled folder without compiling works? :face_with_raised_eyebrow:

The file dependencies don’t make any sense to me yet, and I still can’t seem to get the sim to recognize a package that’s actually placed into the “community” folder.

So, does that indicate that a rebuild of the package is required to make -any- change to the plane in the sim?

i get this error message when trying to load the source in visual basics.
C:\MSFS SDK\Tools\planeconverter-master\PlaneConverter\PlaneConverter.csproj : error : Project file is incomplete. Expected imports are missing.

UPDATE: Seems i need VB 2019.

1 Like

It’s a .NET Core 3.1 project, so you would need that. I think it’s included automatically in VS 2019, otherwise you can download the SDK directly from MS and run the command line tools.

Will try that.

My friend made a exe from your code and we had to make some changes. For some reason your file would produce links with double \ in the links.

So, I realized that running your content through the project package setup will build some of the necessary .json files. I’ve been messing around with that X-Wing project from FSX some, and managed to build myself a full project that will appear as a third party package in the marketplace when you open/build it.

Only problem now is that the aircraft.cfg from FSX seems to be non-functional. I’ve got no engine thrust, and if I place myself in mid-air with slew mode, I’ll just hang there, with no control at all.

Also, for some bizarre reason, though the dev tools can read the aircraft.cfg while in the sim, they cannot edit it. Maybe that’s by design? But when you make tweaks, there’s definitely a “save and resync” menu option that just gives me an error about the action being impossible. Not sure what to do with that yet.

I might try building a new aircraft.cfg out of something like the Citation stock file, and see what I get.

Any news on getting legacy xml gauges to load?

XML gauges are not showing the images only the gauge frame. Does anyone know where i place the fsx cab file? Or why the images in the cab file fail to load. Here is the sdk showing the xml vcockpit still works.
[VCockpit01]
size_mm=1024,768
pixel_size=1024,768
texture=$TEXTURE
background_color=0,0,255
gauge00=MODULENAME!GAUGENAME, 0,0,1024,768