Grob tutor throttle no longer works after SU7

Just a quick note, we’re still on SU7, SU8 scheduled for February I beleive.

1 Like

Title changed to refer to correct current Sim Update cycle.

Also, try mapping Throttle 1 to Power Management axis instead of Throttle. This seems to be a global SU7 change that’s impacting mostly Third Party planes.

1 Like

Sorry SU7. I have tried changing to Axis 1 on the throttle but doesnt fix

thanks for the info. Do you know if this will be fixed?

It’s logged for review. That’s all the status I have.

I would recommend reaching out to the creator. They may have a temporary workaround.

It’s all very odd. I had a good tryout of it today and the throttle works fine. I have my Logitech quadrant and yoke set to defaults.

Sounds more like a hardware/USB problem?

This might help

1 Like

Unfortunately they say its a problem with fs2020 and suggested the same work around. I really am getting fed up of these issues after most updates. The team need to be more effective at testing final update builds before releasing.

It’s not as it all works perfectly on every other aircraft.

1 Like

You have to delete “throttle axis” binding and instead bind “throttle 1 axis”. It won’t work, if “throttle axis” and “throttle 1 axis” are both mapped to your throttle device.

they need to fix this as I therefore need to keep remapping to even fly the aircraft. Ill wait for a fix. Weird that its only the grob that this affects. All my other third party addons work perfectly well.

Well there is more than a handful of aircraft I own, that needed throttle remapping since SU 7. BTW your other aircraft will work, too, with throttle mapped to “throttle 1”, so you only will need to remap it once and for all. For twin engine aircraft you can map “throttle 1 axis” and “throttle 2 axis” to your throttle. Just make sure “throttle axis” is cleared.

1 Like

I have remapped throttle 1 but it doesn’t fix it.

I’ll wait for Asobo to fix

Throttle working fine here. If you play around with the control mapping you should get it working. What controller are you using?

Bind “throttle 1 axis” and clear “throttle axis” - that should do it. 2nd step is required.

Im using the T16000 HOTAS. I am sure this will get fixed by Asobo. Ill just wait.

Okay, so just a single throttle axis. Try the following 3 steps separately to see what works:

  • Bind only Throttle Axis 1 to the throttle.
  • Bind Throttle Axis 1, 2, 3 & 4 to the throttle.
  • Bind Throttle Axis 1, 2, 3, 4 & Throttle Axis to the throttle.

Hopefully one of the combinations above works for you.

You may wait forever. Asobo has changed throttle settings for some reason (which I don’t know) - try donka73’s settings. I am sure combinations 1 and 2 will work. But as long as “throttle axis” is mapped to your throttle it won’t.