GTN750 Project

Already done^^. Just download the new version. Kind Regards. Jay Dee

1 Like

I just try to figure out what is different between the people how have CTD´s and me^^. I just know the AI traffic caused a lot of CTD after last major patch, that the DEv Mod 100% crashed my PA28 and the rest is speculation^^. Kind Regards, JayDee

1 Like

– I tend to always fly with Dev Mode on, and very seldom get CTDs – but I do occasionally.

Maybe next test flight, I should turn off Dev Mode … or at least only turn it on when I “REALLY” need it

I fly the JF Arrow. After removing the GTN 750 the CTDs seem to have stopped (after 5 hours no CTD).

So now i will activate the GTN750 again and remove the VFR map from the toolbar. Does this disable the VFR map entirely?

I have CTD’d 5 times yesterday, ALL 5 while using the 750. 3 of them while flying the JF Piper Arrow, and 2 while flying the Diamond DA62x mod. I have not CTD’d without the 750, so I do suspect that is the issue. Have flown a host of other planes and avionics mods without crashing.

2 Likes

I installed the GTN750 again and after 10 minutes in flight a CTD.
Tried again with the VFR map turned off, and again after about 10 minutes CTD.
Now i am going to test it in another aircraft.

EDIT: I got a CTD in the C172 after about 10-15 minutes

1 Like

There is an option in the last version of the GTN to disable Traffic data and messaging. These 2 features are the only ones constantly checked by the GPS. So try to disable them.
Disable also any AI feature in the game.
Test with one of the standard aircrafts.
Fly with clear sky.
Remove any other Mods or external software.
DO NOT overclock your GPU.
Read that: https://flightsimulator.zendesk.com/hc/en-us/articles/360015893879-Crashing-CTDs-issues.

I’m still waiting for an exact GTN sequence to reproduce a CTD. I will be happy if somebody can give it to me.

Working on it… but so far most of my CTD only appear after an 10+ hour flight (as the last 3, after flying all day from about 07:00 , with a CTD between 18:00 - 19:00 Eastern USA time !! )

There’s the rub.

Every single one of my crashes happened while I was not actively using either GPS.

Two of my most recent ones were while I was taxiing, so the I had started the plane, contacted ATC for taxi clearance, and begun taxiing. Another I was an hour into a flight, and again not touching the GPS. I could tell you it was in the main map page, but that’s about it.

I have never once had a situation, other than that issue where we had issues loading plan files into the 530 where I could state “I press this button, then twiddle this knob, and CTD”.

They would have an easier time because they would have retail symbols to load with the crash dump. However, compiler optimizations make this type of crash dump analysis much harder. You have to have a very good understanding of systems level debugging to make headway. The other problem with mini dumps is that there is no associated memory, so even if you know the stack that caused the crash, sometimes that is not enough to figure out the root cause.

1 Like

A log file with different levels is the best companion in this situation but I don’t know if there is one here.

1 Like

Well…I just had a CTD with the 530 mod instead of using the 750. The CTD itself was very similar to the last one I had (both with the JF Piper Arrow). Both of these last crashes occurred on approach about 2NM out from different airports. As FYI, both of these flights (and pretty much all of my flights) are also using SkyPark, but I don’t know whether that matters or not. Out of my 7 crashes, 2 of them were on the runway throttling up for the takeoff, 2 were as mentioned above, and the rest just randomly during cruise.

Great tutorial demonstrating the many features of the pms50 GTN750.

Just asking this since nearly every flight with the GTN750 gives me CTD’s with the JF Arrow. Could a CTD also be caused by FlightEvents which I use for connecting ForeFlight?

I tried flying multiple flights with the 750. Some were without issues. I repeated the flights were CTD occure with using the GNS530/430 combo (with the mod) while the 750 still being installed. There were no issues after that. All flights were done using TrackIR, Vastim and FlightEvents with the same route/live weather.
I am kind of helpless since I am not sure if its the arrow, flightevents or the 750.

I confirm that all the flights, 1H00 / 1H30, go without problem, with the GTN 750. - C208 ASOBO / VATSIM / TrackIr / LnvMap / Sim Acars. And, to advance research, below is the content of my community:
explorer_2021-05-01_11-13-04

1 Like

Been flying now for over 20 hours … Pa28 with GTN750 – NO CTDs
I have MSFS set to “do not use Internet”, but after I started it up with Ethernet cable disconnected, and it started in MSFS non Internet mode, I re-connected the cable, so I can get Metars etc. Just no MP or Connection to the MSFS servers.

Based on the theory that the CTD are caused by a kernel issue, it might seem that these CTD are associated with MSFS being connected to Internet servers … Internet connections being something that vary greatly between MSFS Users.

Having got a reasonably stable baseline of a setup witch now does not seem to have its previous CTD issues, now is the time to slowly start turning back on Interet functionality, to at least see what specific Internet function may be the cause of the previous CTDs.
ie MP, scenery downloading, or ATC from MSFS servers.

I do seem to be in a stable situation at the moment, with Metar weather updates, and the ability to connect to Vatsim – without CTDs. IF that what it takes at the moment, I’ll take that .

Thanks for all these tests. Hope we’ll catch the bandit!

Someone reported also a possible issue with the Arrow auto fuel selector. I don’t have much information here.

1 Like

I didn’t even know it had an auto fuel selector.

Unfortunately its like “À la recherche d’une aiguille dans une botte de foin

and it does not help that one does not even know what a Needle or Haystack looks like in MSFS, or even have a map to know where the haystack is.

2 Likes

Having put in my ATIS key, I get ATIS info, each time I run MSFS and look in the GNS750.

I have also scanned the QR code, and have Navigraph Charts showing.

The problem I am having is that, maybe after a PC re-boot, although the GTN750 says I am "connected’ to navigraph, I cannot get charts, unless I log out and the use the QR code to log back in and get verified.

Is this to be expected, or should the QR code scan be good, between re-boots ?