Heading Increment Bug (10 degree instead of 1) Explained

Microsoft and Asobo should be ashamed of themselves for the quality of their product. At least they sucked up Working Title to get some people on board that know what they’re doing. The only good thing about this simulator is the graphics, period! Systems are awful and flight dynamics are pitiful. It’s not bad for a game I guess, but its not much of a simulator. I’ve been a pilot for 46 years and have been in a lot of aircraft and not one in this game measures up. SORRY

2 Likes

I may be wrong, but after the move to hire the WorkingTitle Crew I begin to feel a lack of competency at ASOBO for the simulation aspects of the game. Don’t get me wrong - they have built a great foundation from the environmental perspective and I’m not bashing them, but I did not see fundamental progress when it comes to such issues as this obvious bug - and you know best there are a few more - , at least not considering the 200 people they pretended to be working on it.
What disturbes me is the move to integrate these WT guys into their internal environment instead of opening the sim further so more 3rd parties like you can get involved in improving the product.

1 Like

I’m not a programmer but it’s obvious that the only thing working is buttons. As soon as I bind any function to one of the many switches on my Thrustmaster Warthog throttle (not some totally uncommon peripheral imho), the increment bug appears. What I don’t get is how this can go unnoticed for ASOBO - don’t they have peripherals with switches at their facilities?

2 Likes

Just to clarify: As a rule of thumb, ANY joystick peripheral with ANY “always on” switch (aka not a momentary button) bound to the sim will cause the issue. On the alpha, that just happens to be all the panel elements (switches, magneto selector and toggles) while everything on the yoke handle is just fine because it’s all momentary.

3 Likes

Any mapped button can cause it, just keep it pressed.

This might also explain why in the previous Q&A he was saying Force Feedback is implemented while it is not.

I’ve posted the question for yesterday’s Q&A but it seems it was not high enough in the list because it was not talked about at all: Live Dev Q&A: Guided Question - #15 by CptLucky8

And the Parking Brake lever of the TCA Addon too, it also send a constant input when parking brake is set to ON. Not to mention the Ignition Knob when set to IGN/START.

Will there be a fix? I worked fine before sim update 3…

1 Like

Since the update 3 … I have this bug of 10 degrees increment with speed and heading, what a pitty, it was perfectly working before update 3 … this update is really starting to drive me mad and i’m clearly losing patience.

3 Likes

same here once u click autopilot it happens

Ok, so I had time to loose instead of flying (thanks microsoft) … I tried the workaround for the people with honeycomb alpha yoke, and I had to remove

  • All Magnetos Buttons assignements
  • All light Buttons assignments
  • All Electrical Button assigments
  • All avionics button assignement assignements

Removing the buttons I was thinking please, I hope I have not to remove, flaps, trim, view or autopilot disconnect …

Now it’s working, I have 1 degree increment … yeeaaah, bought a powerful yoke to finally remove all cool assignements thanks again microsoft and asobo.

4 Likes

That’s crazy that you had to do that!

I’m fricken loving the vJoy + gremlin solution!

I’ve got it working perfectly with lots of extra functionality by prorating an assigned shift button

Couldn’t care less If they fixed it because the ‘condition’ statements in gremlin gives me so many options

I’ve noticed that this same bug also effects trim as well as the heading.

I submitted the issue and was told that this is a known issue I should “be assured” that they working on fixing it. I’m not assured though.

1 Like

It does. That’s why I don’t get the people saying it was fine as long as you “clicked” on the heading wheel etc. You still had messed up trim!

while it’s a pity you can go for FSUIPC and LINDA, assign the swtiches via linda and have no problem anymore

The trim issue is different from the heading bug.

I think this is the best thing regarding opening up the sim though. WT was a 3rd party, and they experienced first hand all the pain of the platform, so they are the most suitable one to work on that. They might still be constraint by their contract with Microsoft, but at least they can now steer the ship from the inside.

1 Like

I think what you are referring to are DPST vs SPST switches. Dual Pole Single Throw switches physically have one common terminal and two switch terminals. The switch when thrown connects one of the poles to the common while disconnecting the other. Single Pole Single Throw switches have only one switch terminal along with the common. When thrown one way the switch is connected. The other way gives you no connection.

But these our Honeycombs are physical switches, rocker and toggle switches and they are dual pole, i.e. both sides of the switches are wired to circuits. They are not momentary-on switches that open when you let go of them. so they will always present a closed circuit on one pole.

In the description of the cause of the bug I have seen mentioned the “set” commands, like Set NAV Lights or Set Yaw Damper. If it is the form of the command would it make any difference if instead of “Set Yaw Damper” on one side of the switch you used “Yaw Damper On” & “Yaw Damper Off” on the two sides of a switch?

1 Like