[IFR] Is anybody suffering from this C172 G1000 GPS Bug? i am frustrated :(


i’ve tried a couple of ways to set a gps route/app and the only way it KIND OF works is through the menu before the flight. i tried today also after the patch and i set a short flight with a direct departure towards the IAF. the g1000 simulation for some reason creates an arc from my departure towards the IAF which i have not discovered how to bypass so far. if i select fpl, and do direct on the IAF (like in real garmin) to go directly to that waypoint without the random ARC nothing happens. If i select D-> and type down the IAF and select ACTIVATE another thinner pink line appears on the MFD but the AP/FMS/CDI still is following the ARC nav path no matter what. If i deactivate the AP and try to fly direct to the IAF expecting the ARC to dissapear after i managed to set the thinner pink line it still does not proceed with the approach and if i activate the AP again it will turn around to go and try to do the whole ARC again, which is absolutely absurd. If i delete the approach midflight and try to set it up through nearest-select approach etc, it will send me directly to my destination and no waypoints will be selected. having GPS IS CRUCIAL for a non precision approach like a LOC(unless u use VORs also), and not being able to do these things properly is driving me nuts. this is on the c172 g1000 plane btw. The flight i was trying to do was KCOI KTIX ILS36. tried KMCO also, same result…send direct to airport and when selecting approach nothing happens…keeps the same USR → KMCO

i am really frustrated btw :frowning:

Hang in there. It’ll get fixed at some point. Just a matter if time.

Have you tried Working Title’s G1000 Mod? If it doesn’t fix your problem, file a bug with them and they can probably address your issue. That latest version has some great fixes and it works with If you download it, just remember that it will probably break when the next patch comes out and you’ll need to give them a day or so to get it working again (though this time they had the fixed version out within hours of the patch releasing.

1 Like

I’ll try this, will update on findings. Ty

Ouin!!! J’ai le même problème avec le LOC, (NAV 1 ? 2) Je n’arrive plus à atterrir sur la Piste direct, j’atterri à côté à gauche de la piste ??? ;-(

after installing the mod the issue persists. i cannot load or active an approach like in the real plane, and neither can i avoid the arc if i press direct to IAF, as you can see in the images there is another thinner pink line that is drawn but the autopilot does not pay attention to.

If I am understanding your issue correctly then it’s not just a G1000 problem. You can’t Direct To any points that are parts of an approach within the sim currently with any plane to avoid the arc, iirc.

I believe there are a few work arounds where you manually type/input in the waypoint you’d like to go to, direct-to that point, and then the gps will pick up the leg from there I think. There was a post and video someone did yesterday that explains this but it was for the G3000, which i think also should also work for all fms/gps systems in game. I wish I’d have saved it for ya.

I.e. you are on the right thought logic here, but try adding a waypoint between your two airports. And that that waypoint being the where the arc ends. So based on your screen shot, manually add AWINY between KCOI and KTIX. It’s probably a pain to do so mid flight in the g1000 compared to the g3000 though.

Edit: Found the video for ya. And here’s a similar thread to vote.

i have tried in a couple of ways what you are saying but haven;t been able to make the autopilot redirect on the g1000, i have seen a couple of videos from CLUMSY and Pilot emilie on the g3000 doing what you say and it seems to work. haven’t figured it out on the g1000 yet, also loading an approach or change of waypoints mid flight in case of ATC change of route would be a pain in the a**, if it is even possible.

The workaround used to work on the TBM 930 G3000. However today, upon loading KSBA VOR Rwy 25 from KWANG transition and with KWANG entered as the last enroute waypoint the aircraft started a back-turn again.

My workaround is now not using any PROC but entering approach waypoints manually :roll_eyes: