I'm seeing all airports as uncontrolled after updating to SU5

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.

no, removed entire Community folder

Are you using Developer Mode or made changes in it?

no, not using developer mode

Brief description of the issue:

At least KSNA, KSLI, KFUL, and KLGB in the Orange County, California area are coming up as uncontrolled airports in the ATC window. This means instead of asking for clearance from ATC for takeoff, taxi, or land you announce your intention on the unicom channel and then do it without being given clearance. This is wrong as these are all controlled airports, and used to work as expected.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

  • update to SU5
  • spend hours removing all 3rd-party Marketplace add-ons to prevent hangs on startup
  • add only the G1000 NXi after that
  • load up an SR22 at KSNA ramp 84
  • notice once avionics are on that your ATC window shows the uncontrolled mode
  • check other airports in the area and see the same

PC specs for those who want to assist (if not entered in your profile)
Shouldn’t matter, but: Ryzen 3700X, 32 GiB, Windows 10 Pro release version, NVIDIA RTX 2070 Super, latest game-ready drivers. Honeycomb Alpha and Bravo and Saitek/Logitech rudder pedals.

Build Version # when you first started experiencing this issue:

Are you on the Steam or Microsoft Store version?
MS Store

Did you submit this to Zendesk? If so, what is your ticket #?


I’ve partially resolved this by removing Content.xml and letting the sim regenerate it. This has returned navaids, airspaces, and frequencies on the World Map, and ATC works at KSNA again. However on the map, all airports still show with the brown icon indicating “no published procedures”


Yes confirmed this worked for me as well. Restored everything but the correct icons on World Map. I tip my hat to you sir.

1 Like

Moderator Edit: Merged from another topic.

Community folder clear,

Since the update all airports are displaying as VFR only, is anyone else seeing this,

I do have Navigraph and have downloaded the latest AIRAC cycle post update - still nothing?

1 Like

I’m having the same issue…

Can confirm. VOR’s arent even working too. Nothing is picking up.

Same issue here as well. Emptied my Community folder but no luck.

Same issue here. There is some “AI ATC” which would be nice if it actually worked.

There was another post with the FIX! Need to delete the Content.xml file.

1 Like

So when I tested this morning, I was able to start an IFR flight from KSNA to KLAX (set up from the world map, or by requesting IFR while in the air after setting up the flight plan in the FMS) HOWEVER I was never given further instructions beyond take-off.

I wasn’t able to switch frequencies. No climb instructions. No approach instructions. Asking for the next waypoint gave me the same heading even after I’d passed over LAX.

1 Like

Not a complete fix, see above.

True, but it is functional. I’ll take this “fix” over not being able to navigate. Now its just a visual issue in the menu.

1 Like

It’s not just visual, I also can’t do IFR successfully. No approach, no clearance to land.

Ah, I haven’t tried IFR. I’ll give it a go and see what happens.

1 Like

Yeah, IFR still broken. Can tune to the channel but it doesnt communcate to ATC and vica-versa.

1 Like

I’m really confused, this topic now seems to address multiple topics. I came here to find the bug associated with the World Map incorrectly showing all airports as not having any procedures associated with them (all markers are brown). Is there another problem that we can’t create IFR flights either?

The ticks around the circle represent that the airport has services/is attended.

In game in the world map, according to the legend Brown signifies that the airport has no approach or departure procedures or radar minimums, green signifies that it does have them.

Now all airports are brown, showing no procedures, even though they do have them.

All airports are now shown to have services. Even airports without a parking spot and airports that are water runway only. This may be true?

This is an FAA Sectional Legend - here, Blue signifies a control tower, while magenta signifies not. Similar to brown and green on the world map, except that Green signifies procedures as opposed to a control tower according to the SDK, unless that has changed now with SU5.


Regarding the other bug being reported here…

I just flew an IFR flight. What happens is, Tower clears you to contact departure after takeoff and immediately changes the frequency before you acknowledge the handoff. So you can’t contact departure. Select to go back to tower frequency, acknowledge the handoff, and everything will procede properly from there.

I don’t know if it’s possible to clean up this thread any more. There’s at least two bugs reported in this thread.

1 Like

There’s one bug which is “a bunch of related stuff is broken”.

1 Like

Ok I have good news and bad news. :wink:

Good news:

  • I got IFR flight plans to work again – flew KSNA to KLAX with default IFR low altitude flight plan, and was assigned ILS 25R approach and everything worked.

Bad news:

  • The world map still shows all airports as brown/having no procedures, even though they… seem to work now?

Worse news:

  • The way to fix IFR was to COMPLETELY uninstall MSFS and reinstall it from the Windows Store

Well, they should be sending out a hotfix. I’m going to wait on that before uninstalling and reinstalling. But glad you found a solution.


I don’t think you needed to reinstall. IFR worked for me without issue in creating a plan. I did not, however, try to choose an approach or departure. I never do. Just like in real life, I expect ATC to do that. I also ran into an issue on leaving the departure airspace that Tower kicked me to departure before ATC was ready for me to dial in departure (see my other post). But the rest of the plan worked. I even did a missed approach on the other end, and that worked.

Clearly something is borked, however.