Intolerable flashing in top third of screen since update

Same problem here. What fixes it for me though is to set the resolution to 640x480 then revert back.

Does this fix the issue for you for the rest of the flight? :thinking:

Thanks for the tip. Just tried this - doesn’t work for me sadly.

I can complete a whole flight no issues as long as there are no clouds.

Yes, but my wx is broken with this update also, no clouds.

1 Like

Same problem with me, GTX960M 4GB … It’s so annoying :man_facepalming:

1 Like

If you are using a GPU from the GeForce 600/700/900 series using either the Kepler or Maxwell 1.0 architecture, this issue is happening because those GPUs are obsolete since the 1.10.7.0 patch. This is the response from support for this issue.

https://forums.flightsimulator.com/uploads/default/original/3X/a/7/a71f998b6918069131dc63df0dc249b3225b1374.png

I have gathered several reports in this thread, it seems that Maxwell 2.0 GPUs and newer are in the clear for now.

1 Like

Here is a link to another thread with the same issues

I have this screen flickering as well. :sob:
Very bad bug, when it happens restart of the software necessary.

!! Dangerous for people with epilepsy !!

Exact steps how the flickering happens:

Restarting the software is the only way to get rid of the flicker.

Edit: Turning weather to clear skies fixes the issue.

Agree, this is totally unacceptable! I cannot upgrade my laptop graphics card!
Either they shouldn’t force an upgrade, or fix this issue!!

1 Like

think we should start a class action law suit, for not giving people their refunds who can no longer play the game due to them no longer supporting video cards. got the game 3 weeks ago, and had no issues with playing the game. and get 30fps at medum settings, now i cant even play at low end settings.

We should ban together and start the law suit

5 Likes

This morning (in AU) I tried setting Weather to “Clear Skies”, an option a few posters have mentioned and indeed it gives “Clear Skies”. Sorry couldn’t help myself. In short the problem goes away, in all views.

For now I’m happy, I can at least continue to fly and it buys some time. Hopefully we may be lucky enough that a fix can be implimented. Otherwise I will be stuck in clear skies until I can upgrade.

Did you contact support about this issue? Did they give you a more definitive answer regarding support of older hardware?

If yes then that’s worrying moving forward. I mean they probably wouldn’t care much now since there aren’t many of us, Kepler and Maxwell 1.0 users, left nowadays, but it’s going to get real ugly if, for example, a GPU like the GTX 1080 Ti is considered obsolete in two years from now.

Even if it doesn’t concern everyone right now, shifting minimum requirements is something that everyone should stand up against. It would be understandable if this happened due to a major engine upgrade like DirectX 12, but when it comes to a simple bug like the flashing clouds we have now then there’s just no excuse.

WOW ! They need to correct that ASAP.

2 Likes

For me the 10.8.0 update has solved this.

Thanks ASOBO!

Having the same problem on my gtx780ti I hope Microsoft reconsiders…for me I am returning to P3D maybe in january I will buy a rtx 3070 when available

Unfortunately, negative on GTX770 with 10.8.0.

10.8.0 doesn’t solve it for M2000M

Agreed. The game is unplayable after the patch due to flickering. Is there any chance of getting a refund?

1 Like

AlienTrucker above suggested that he asked for a refund was denied one.

Pas de panique, ils vont trouver la solution… attendons un peu.